4.4.3-6
This commit is contained in:
parent
08e9ee2de5
commit
1d0a646cc5
@ -1,2 +1,2 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.3-20100208.tar.bz2
|
||||
gcc-4.4.3-20100211.tar.bz2
|
||||
|
20
gcc.spec
20
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20100208
|
||||
%global SVNREV 156609
|
||||
%global DATE 20100211
|
||||
%global SVNREV 156726
|
||||
%global gcc_version 4.4.3
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 5
|
||||
%global gcc_release 6
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%if 0%{?fedora} >= 13
|
||||
@ -176,8 +176,7 @@ Patch17: gcc44-pr38757.patch
|
||||
Patch18: gcc44-libstdc++-docs.patch
|
||||
Patch19: gcc44-ppc64-aixdesc.patch
|
||||
Patch20: gcc44-max-vartrack-size.patch
|
||||
Patch21: gcc44-rh559186.patch
|
||||
Patch22: gcc44-no-add-needed.patch
|
||||
Patch21: gcc44-no-add-needed.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -487,9 +486,8 @@ which are required to compile with the GNAT.
|
||||
%endif
|
||||
%patch19 -p0 -b .ppc64-aixdesc~
|
||||
%patch20 -p0 -b .max-vartrack-size~
|
||||
%patch21 -p0 -b .rh559186~
|
||||
%if 0%{?fedora} >= 13
|
||||
%patch22 -p0 -b .no-add-needed~
|
||||
%patch21 -p0 -b .no-add-needed~
|
||||
%endif
|
||||
|
||||
# This testcase doesn't compile.
|
||||
@ -1880,6 +1878,14 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 11 2010 Jakub Jelinek <jakub@redhat.com> 4.4.3-6
|
||||
- update from gcc-4_4-branch
|
||||
- PR tree-optimization/42705
|
||||
- fix up -femit-struct-debug-baseonly (#561320, PR debug/43010)
|
||||
- --enable-checking=valgrind bugfixes (PRs fortran/43029, fortran/43030)
|
||||
- VTA backports (#562312)
|
||||
- some further --enable-checking=valgrind bugfixes (PR target/38781)
|
||||
|
||||
* Mon Feb 8 2010 Jakub Jelinek <jakub@redhat.com> 4.4.3-5
|
||||
- update from gcc-4_4-branch
|
||||
- PRs fortran/38324, fortran/41044, fortran/41167, fortran/42309,
|
||||
|
@ -1,65 +0,0 @@
|
||||
2010-01-27 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* Makefile.in (c-common.o): Depend on $(OPTABS_H).
|
||||
* c-common.c: Include optabs.h.
|
||||
(set_builtin_user_assembler_name): Also handle
|
||||
ffs if int is smaller than word.
|
||||
|
||||
* gcc.dg/builtin-ffs-1.c: New test.
|
||||
|
||||
--- gcc/Makefile.in.jj 2010-01-21 08:58:12.000000000 +0100
|
||||
+++ gcc/Makefile.in 2010-01-27 19:17:05.000000000 +0100
|
||||
@@ -1890,7 +1890,7 @@ c-common.o : c-common.c $(CONFIG_H) $(SY
|
||||
$(TARGET_H) $(C_TREE_H) tree-iterator.h langhooks.h tree-mudflap.h \
|
||||
intl.h opts.h $(REAL_H) $(CPPLIB_H) $(TREE_INLINE_H) $(HASHTAB_H) \
|
||||
$(BUILTINS_DEF) $(CGRAPH_H) $(BASIC_BLOCK_H) $(TARGET_DEF_H) \
|
||||
- $(GIMPLE_H) libfuncs.h
|
||||
+ $(GIMPLE_H) libfuncs.h $(OPTABS_H)
|
||||
|
||||
c-pretty-print.o : c-pretty-print.c $(C_PRETTY_PRINT_H) \
|
||||
$(C_TREE_H) $(CONFIG_H) $(SYSTEM_H) coretypes.h $(TM_H) $(REAL_H) \
|
||||
--- gcc/c-common.c.jj 2009-11-09 16:38:29.000000000 +0100
|
||||
+++ gcc/c-common.c 2010-01-27 19:16:35.000000000 +0100
|
||||
@@ -52,6 +52,7 @@ along with GCC; see the file COPYING3.
|
||||
#include "gimple.h"
|
||||
#include "fixed-value.h"
|
||||
#include "libfuncs.h"
|
||||
+#include "optabs.h"
|
||||
|
||||
cpp_reader *parse_in; /* Declared in c-pragma.h. */
|
||||
|
||||
@@ -4421,6 +4422,14 @@ set_builtin_user_assembler_name (tree de
|
||||
case BUILT_IN_ABORT:
|
||||
abort_libfunc = set_user_assembler_libfunc ("abort", asmspec);
|
||||
break;
|
||||
+ case BUILT_IN_FFS:
|
||||
+ if (INT_TYPE_SIZE < BITS_PER_WORD)
|
||||
+ {
|
||||
+ set_user_assembler_libfunc ("ffs", asmspec);
|
||||
+ set_optab_libfunc (ffs_optab, mode_for_size (INT_TYPE_SIZE,
|
||||
+ MODE_INT, 0), "ffs");
|
||||
+ }
|
||||
+ break;
|
||||
default:
|
||||
break;
|
||||
}
|
||||
--- gcc/testsuite/gcc.dg/builtin-ffs-1.c.jj 2010-01-27 14:27:45.000000000 +0100
|
||||
+++ gcc/testsuite/gcc.dg/builtin-ffs-1.c 2010-01-27 14:27:10.000000000 +0100
|
||||
@@ -0,0 +1,17 @@
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-O2" } */
|
||||
+
|
||||
+extern int ffs (int) __asm ("__GI_ffs") __attribute__ ((nothrow, const));
|
||||
+
|
||||
+int
|
||||
+ffsll (long long int i)
|
||||
+{
|
||||
+ unsigned long long int x = i & -i;
|
||||
+
|
||||
+ if (x <= 0xffffffff)
|
||||
+ return ffs (i);
|
||||
+ else
|
||||
+ return 32 + ffs (i >> 32);
|
||||
+}
|
||||
+
|
||||
+/* { dg-final { scan-assembler-not "\nffs\n|\nffs\[^a-zA-Z0-9_\]|\[^a-zA-Z0-9_\]ffs\n" } } */
|
@ -6,3 +6,4 @@ gcc-4_4_2-25_fc13:HEAD:gcc-4.4.2-25.fc13.src.rpm:1263487371
|
||||
gcc-4_4_3-1_fc13:HEAD:gcc-4.4.3-1.fc13.src.rpm:1264094717
|
||||
gcc-4_4_3-4_fc13:HEAD:gcc-4.4.3-4.fc13.src.rpm:1264621537
|
||||
gcc-4_4_3-5_fc13:HEAD:gcc-4.4.3-5.fc13.src.rpm:1265659730
|
||||
gcc-4_4_3-6_fc13:HEAD:gcc-4.4.3-6.fc13.src.rpm:1265925505
|
||||
|
Loading…
Reference in New Issue
Block a user