9.0.0-0.3
This commit is contained in:
parent
3694befabb
commit
1321d9a8de
2
gcc.spec
2
gcc.spec
@ -261,6 +261,7 @@ Patch12: gcc9-pr88714.patch
|
||||
Patch13: gcc9-pr88901.patch
|
||||
Patch14: gcc9-pr88044.patch
|
||||
Patch15: gcc9-utf-array-test.patch
|
||||
Patch16: gcc9-aarch64-bootstrap.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -843,6 +844,7 @@ to NVidia PTX capable devices if available.
|
||||
%patch13 -p0 -b .pr88901~
|
||||
%patch14 -p0 -b .pr88044~
|
||||
%patch15 -p0 -b .utf-array-test~
|
||||
%patch16 -p0 -b .aarch64-bootstrap~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
|
47
gcc9-aarch64-bootstrap.patch
Normal file
47
gcc9-aarch64-bootstrap.patch
Normal file
@ -0,0 +1,47 @@
|
||||
2019-01-19 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* config/aarch64/aarch64.c (aarch64_stack_protect_guard): Move
|
||||
outside of #if CHECKING_P code.
|
||||
|
||||
--- gcc/config/aarch64/aarch64.c.jj 2019-01-19 09:39:18.859831024 +0100
|
||||
+++ gcc/config/aarch64/aarch64.c 2019-01-19 18:25:18.037239167 +0100
|
||||
@@ -18662,6 +18662,19 @@ aarch64_simd_clone_usable (struct cgraph
|
||||
}
|
||||
}
|
||||
|
||||
+/* Implement TARGET_STACK_PROTECT_GUARD. In case of a
|
||||
+ global variable based guard use the default else
|
||||
+ return a null tree. */
|
||||
+static tree
|
||||
+aarch64_stack_protect_guard (void)
|
||||
+{
|
||||
+ if (aarch64_stack_protector_guard == SSP_GLOBAL)
|
||||
+ return default_stack_protect_guard ();
|
||||
+
|
||||
+ return NULL_TREE;
|
||||
+}
|
||||
+
|
||||
+
|
||||
/* Target-specific selftests. */
|
||||
|
||||
#if CHECKING_P
|
||||
@@ -18706,19 +18719,6 @@ aarch64_run_selftests (void)
|
||||
|
||||
} // namespace selftest
|
||||
|
||||
-/* Implement TARGET_STACK_PROTECT_GUARD. In case of a
|
||||
- global variable based guard use the default else
|
||||
- return a null tree. */
|
||||
-static tree
|
||||
-aarch64_stack_protect_guard (void)
|
||||
-{
|
||||
- if (aarch64_stack_protector_guard == SSP_GLOBAL)
|
||||
- return default_stack_protect_guard ();
|
||||
-
|
||||
- return NULL_TREE;
|
||||
-}
|
||||
-
|
||||
-
|
||||
#endif /* #if CHECKING_P */
|
||||
|
||||
#undef TARGET_STACK_PROTECT_GUARD
|
Loading…
Reference in New Issue
Block a user