4.4.3-5
This commit is contained in:
parent
bc7138a9a2
commit
08e9ee2de5
@ -1,2 +1,2 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.3-20100127.tar.bz2
|
||||
gcc-4.4.3-20100208.tar.bz2
|
||||
|
32
gcc.spec
32
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20100127
|
||||
%global SVNREV 156296
|
||||
%global DATE 20100208
|
||||
%global SVNREV 156609
|
||||
%global gcc_version 4.4.3
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 4
|
||||
%global gcc_release 5
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%if 0%{?fedora} >= 13
|
||||
@ -70,7 +70,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# Need binutils which support --build-id >= 2.17.50.0.17-3
|
||||
# Need binutils which support %gnu_unique_object >= 2.19.51.0.14
|
||||
# Need binutils which support .cfi_sections >= 2.19.51.0.14-33
|
||||
%if 0%{?fedora} >= 13
|
||||
# Need binutils which support --no-add-needed >= 2.20.51.0.2-12
|
||||
BuildRequires: binutils >= 2.20.51.0.2-12
|
||||
%else
|
||||
BuildRequires: binutils >= 2.19.51.0.14-33
|
||||
%endif
|
||||
# While gcc doesn't include statically linked binaries, during testing
|
||||
# -static is used several times.
|
||||
BuildRequires: glibc-static
|
||||
@ -125,7 +130,12 @@ Requires: cpp = %{version}-%{release}
|
||||
# Need binutils that support --build-id
|
||||
# Need binutils that support %gnu_unique_object
|
||||
# Need binutils that support .cfi_sections
|
||||
%if 0%{?fedora} >= 13
|
||||
# Need binutils that support --no-add-needed
|
||||
Requires: binutils >= 2.20.51.0.2-12
|
||||
%else
|
||||
Requires: binutils >= 2.19.51.0.14-33
|
||||
%endif
|
||||
# Make sure gdb will understand DW_FORM_strp
|
||||
Conflicts: gdb < 5.1-2
|
||||
Requires: glibc-devel >= 2.2.90-12
|
||||
@ -167,6 +177,7 @@ Patch18: gcc44-libstdc++-docs.patch
|
||||
Patch19: gcc44-ppc64-aixdesc.patch
|
||||
Patch20: gcc44-max-vartrack-size.patch
|
||||
Patch21: gcc44-rh559186.patch
|
||||
Patch22: gcc44-no-add-needed.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -477,6 +488,9 @@ which are required to compile with the GNAT.
|
||||
%patch19 -p0 -b .ppc64-aixdesc~
|
||||
%patch20 -p0 -b .max-vartrack-size~
|
||||
%patch21 -p0 -b .rh559186~
|
||||
%if 0%{?fedora} >= 13
|
||||
%patch22 -p0 -b .no-add-needed~
|
||||
%endif
|
||||
|
||||
# This testcase doesn't compile.
|
||||
rm libjava/testsuite/libjava.lang/PR35020*
|
||||
@ -1866,6 +1880,18 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 8 2010 Jakub Jelinek <jakub@redhat.com> 4.4.3-5
|
||||
- update from gcc-4_4-branch
|
||||
- PRs fortran/38324, fortran/41044, fortran/41167, fortran/42309,
|
||||
fortran/42650, fortran/42736, libfortran/42901, middle-end/42898,
|
||||
middle-end/42995, rtl-optimization/42952, tree-optimization/42462,
|
||||
tree-optimization/42890, tree-optimization/42931
|
||||
- VTA backports
|
||||
- PRs target/42924, debug/42896, rtl-optimization/42889
|
||||
%if 0%{?fedora} >= 13
|
||||
- pass --no-add-needed to the linker
|
||||
%endif
|
||||
|
||||
* Wed Jan 27 2010 Jakub Jelinek <jakub@redhat.com> 4.4.3-4
|
||||
- update from gcc-4_4-branch
|
||||
- PRs bootstrap/42786, fortran/42866, target/38697, target/42841
|
||||
|
52
gcc44-no-add-needed.patch
Normal file
52
gcc44-no-add-needed.patch
Normal file
@ -0,0 +1,52 @@
|
||||
2010-02-08 Roland McGrath <roland@redhat.com>
|
||||
|
||||
* config/rs6000/sysv4.h (LINK_EH_SPEC): Pass --no-add-needed to the
|
||||
linker.
|
||||
* config/linux.h (LINK_EH_SPEC): Likewise.
|
||||
* config/alpha/elf.h (LINK_EH_SPEC): Likewise.
|
||||
* config/ia64/linux.h (LINK_EH_SPEC): Likewise.
|
||||
|
||||
--- gcc/config/alpha/elf.h.~1~
|
||||
+++ gcc/config/alpha/elf.h
|
||||
@@ -421,7 +421,7 @@ extern int alpha_this_gpdisp_sequence_nu
|
||||
I imagine that other systems will catch up. In the meantime, it
|
||||
doesn't harm to make sure that the data exists to be used later. */
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
-#define LINK_EH_SPEC "%{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
+#define LINK_EH_SPEC "--no-add-needed %{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
#endif
|
||||
|
||||
/* A C statement (sans semicolon) to output to the stdio stream STREAM
|
||||
--- gcc/config/ia64/linux.h.~1~
|
||||
+++ gcc/config/ia64/linux.h
|
||||
@@ -58,7 +58,7 @@ do { \
|
||||
Signalize that because we have fde-glibc, we don't need all C shared libs
|
||||
linked against -lgcc_s. */
|
||||
#undef LINK_EH_SPEC
|
||||
-#define LINK_EH_SPEC "%{!r:--build-id} "
|
||||
+#define LINK_EH_SPEC "--no-add-needed %{!r:--build-id} "
|
||||
|
||||
#define MD_UNWIND_SUPPORT "config/ia64/linux-unwind.h"
|
||||
|
||||
--- gcc/config/linux.h.~1~
|
||||
+++ gcc/config/linux.h
|
||||
@@ -89,7 +89,7 @@ see the files COPYING3 and COPYING.RUNTI
|
||||
} while (0)
|
||||
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
-#define LINK_EH_SPEC "%{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
+#define LINK_EH_SPEC "--no-add-needed %{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
#endif
|
||||
|
||||
/* Define this so we can compile MS code for use with WINE. */
|
||||
--- gcc/config/rs6000/sysv4.h.~1~
|
||||
+++ gcc/config/rs6000/sysv4.h
|
||||
@@ -917,7 +917,7 @@ SVR4_ASM_SPEC \
|
||||
%{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER "}}}"
|
||||
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
-# define LINK_EH_SPEC "%{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
+# define LINK_EH_SPEC "--no-add-needed %{!static:--eh-frame-hdr} %{!r:--build-id} "
|
||||
#endif
|
||||
|
||||
#define CPP_OS_LINUX_SPEC "-D__unix__ -D__gnu_linux__ -D__linux__ \
|
@ -5,3 +5,4 @@ gcc-4_4_2-20_fc13:HEAD:gcc-4.4.2-20.fc13.src.rpm:1261484502
|
||||
gcc-4_4_2-25_fc13:HEAD:gcc-4.4.2-25.fc13.src.rpm:1263487371
|
||||
gcc-4_4_3-1_fc13:HEAD:gcc-4.4.3-1.fc13.src.rpm:1264094717
|
||||
gcc-4_4_3-4_fc13:HEAD:gcc-4.4.3-4.fc13.src.rpm:1264621537
|
||||
gcc-4_4_3-5_fc13:HEAD:gcc-4.4.3-5.fc13.src.rpm:1265659730
|
||||
|
Loading…
Reference in New Issue
Block a user