import gcc-8.4.1-1.el8

# Conflicts:
#	.gcc.metadata
#	.gitignore
#	SOURCES/gcc8-libstdc++-docs.patch
#	SPECS/gcc.spec
This commit is contained in:
CentOS Sources 2020-10-08 08:08:33 +00:00
commit 069ba4080f
5 changed files with 3398 additions and 0 deletions

3
.gcc.metadata Normal file
View File

@ -0,0 +1,3 @@
6d0269f5a6a1907dfb48cb6d8b64538bde7f1f6d SOURCES/gcc-8.4.1-20200928.tar.xz
3bdb3cc01fa7690a0e20ea5cfffcbe690f7665eb SOURCES/nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz
ce8eb83be0ac37fb5d5388df455a980fe37b4f13 SOURCES/nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz

3
.gitignore vendored Normal file
View File

@ -0,0 +1,3 @@
SOURCES/gcc-8.4.1-20200928.tar.xz
SOURCES/nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz
SOURCES/nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz

View File

@ -0,0 +1,24 @@
--- libstdc++-v3/doc/html/index.html.jj 2011-01-03 12:53:21.282829010 +0100
+++ libstdc++-v3/doc/html/index.html 2011-01-04 18:06:28.999851145 +0100
@@ -5,6 +5,8 @@
<a class="link" href="https://www.fsf.org" target="_top">FSF
</a>
</p><p>
+ Release 8.4.1
+ </p><p>
Permission is granted to copy, distribute and/or modify this
document under the terms of the GNU Free Documentation
License, Version 1.2 or any later version published by the
--- libstdc++-v3/doc/html/api.html.jj 2011-01-03 12:53:21.000000000 +0100
+++ libstdc++-v3/doc/html/api.html 2011-01-04 18:12:01.672757784 +0100
@@ -20,7 +20,9 @@
member functions for the library classes, finding out what is in a
particular include file, looking at inheritance diagrams, etc.
</p><p>
- The API documentation, rendered into HTML, can be viewed online
+ The API documentation, rendered into HTML, can be viewed locally
+ <a class="link" href="api/index.html" target="_top">for the 8.4.1 release</a>,
+ online
<a class="link" href="http://gcc.gnu.org/onlinedocs/" target="_top">for each GCC release</a>
and
<a class="link" href="http://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/index.html" target="_top">

View File

@ -0,0 +1,96 @@
2020-09-28 Jakub Jelinek <jakub@redhat.com>
Revert:
2020-09-27 Steven G. Kargl <kargl@gcc.gnu.org>
Mark Eggleston <markeggleston@gcc.gnu.org>
PR fortran/95614
* decl.c (gfc_get_common): Use gfc_match_common_name instead
of match_common_name.
* decl.c (gfc_bind_idents): Use gfc_match_common_name instead
of match_common_name.
* match.c : Rename match_common_name to gfc_match_common_name.
* match.c (gfc_match_common): Use gfc_match_common_name instead
of match_common_name.
* match.h : Rename match_common_name to gfc_match_common_name.
* resolve.c (resolve_common_vars): Check each symbol in a
common block has a global symbol. If there is a global symbol
issue an error if the symbol type is known as is not a common
block name.
--- gcc/fortran/decl.c
+++ gcc/fortran/decl.c
@@ -5789,7 +5789,7 @@ get_bind_c_idents (void)
found_id = MATCH_YES;
gfc_get_ha_symbol (name, &tmp_sym);
}
- else if (gfc_match_common_name (name) == MATCH_YES)
+ else if (match_common_name (name) == MATCH_YES)
{
found_id = MATCH_YES;
com_block = gfc_get_common (name, 0);
@@ -5834,7 +5834,7 @@ get_bind_c_idents (void)
found_id = MATCH_YES;
gfc_get_ha_symbol (name, &tmp_sym);
}
- else if (gfc_match_common_name (name) == MATCH_YES)
+ else if (match_common_name (name) == MATCH_YES)
{
found_id = MATCH_YES;
com_block = gfc_get_common (name, 0);
--- gcc/fortran/match.c
+++ gcc/fortran/match.c
@@ -5028,8 +5028,7 @@ gfc_get_common (const char *name, int from_module)
/* Match a common block name. */
-match
-gfc_match_common_name (char *name)
+match match_common_name (char *name)
{
match m;
@@ -5073,7 +5072,7 @@ gfc_match_common (void)
for (;;)
{
- m = gfc_match_common_name (name);
+ m = match_common_name (name);
if (m == MATCH_ERROR)
goto cleanup;
--- gcc/fortran/match.h
+++ gcc/fortran/match.h
@@ -103,9 +103,11 @@ match gfc_match_call (void);
/* We want to use this function to check for a common-block-name
that can exist in a bind statement, so removed the "static"
- declaration of the function in match.c. */
+ declaration of the function in match.c.
-match gfc_match_common_name (char *name);
+ TODO: should probably rename this now that it'll be globally seen to
+ gfc_match_common_name. */
+match match_common_name (char *name);
match gfc_match_common (void);
match gfc_match_block_data (void);
--- gcc/fortran/resolve.c
+++ gcc/fortran/resolve.c
@@ -932,16 +932,9 @@ static void
resolve_common_vars (gfc_common_head *common_block, bool named_common)
{
gfc_symbol *csym = common_block->head;
- gfc_gsymbol *gsym;
for (; csym; csym = csym->common_next)
{
- gsym = gfc_find_gsymbol (gfc_gsym_root, csym->name);
- if (gsym && gsym->type != GSYM_UNKNOWN && gsym->type != GSYM_COMMON)
- gfc_error_now ("Global entity %qs at %L cannot appear in a "
- "COMMON block at %L", gsym->name,
- &gsym->where, &csym->common_block->where);
-
/* gfc_add_in_common may have been called before, but the reported errors
have been ignored to continue parsing.
We do the checks again here. */

3272
SPECS/gcc.spec Normal file

File diff suppressed because it is too large Load Diff