4.4.0-9
This commit is contained in:
parent
23f7769aa4
commit
057d3867f2
@ -1,2 +1,2 @@
|
|||||||
fastjar-0.97.tar.gz
|
fastjar-0.97.tar.gz
|
||||||
gcc-4.4.0-20090612.tar.bz2
|
gcc-4.4.0-20090615.tar.bz2
|
||||||
|
14
gcc.spec
14
gcc.spec
@ -1,9 +1,9 @@
|
|||||||
%global DATE 20090612
|
%global DATE 20090615
|
||||||
%global SVNREV 148427
|
%global SVNREV 148501
|
||||||
%global gcc_version 4.4.0
|
%global gcc_version 4.4.0
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %{release}, append them after %{gcc_release} on Release: line.
|
# %{release}, append them after %{gcc_release} on Release: line.
|
||||||
%global gcc_release 8
|
%global gcc_release 9
|
||||||
%global _unpackaged_files_terminate_build 0
|
%global _unpackaged_files_terminate_build 0
|
||||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||||
%global include_gappletviewer 1
|
%global include_gappletviewer 1
|
||||||
@ -158,6 +158,7 @@ Patch26: gcc44-power7-2.patch
|
|||||||
Patch27: gcc44-power7-3.patch
|
Patch27: gcc44-power7-3.patch
|
||||||
Patch28: gcc44-pr38757.patch
|
Patch28: gcc44-pr38757.patch
|
||||||
Patch29: gcc44-libstdc++-docs.patch
|
Patch29: gcc44-libstdc++-docs.patch
|
||||||
|
Patch30: gcc44-rh506099.patch
|
||||||
|
|
||||||
Patch1000: fastjar-0.97-segfault.patch
|
Patch1000: fastjar-0.97-segfault.patch
|
||||||
|
|
||||||
@ -465,6 +466,7 @@ which are required to compile with the GNAT.
|
|||||||
%if %{build_libstdcxx_docs}
|
%if %{build_libstdcxx_docs}
|
||||||
%patch29 -p0 -b .libstdc++-docs~
|
%patch29 -p0 -b .libstdc++-docs~
|
||||||
%endif
|
%endif
|
||||||
|
%patch30 -p0 -b .rh506099~
|
||||||
|
|
||||||
# This testcase doesn't compile.
|
# This testcase doesn't compile.
|
||||||
rm libjava/testsuite/libjava.lang/PR35020*
|
rm libjava/testsuite/libjava.lang/PR35020*
|
||||||
@ -1803,6 +1805,12 @@ fi
|
|||||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 15 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-9
|
||||||
|
- update from gcc-4_4-branch
|
||||||
|
- PR fortran/40168
|
||||||
|
- fix up debug.exp testsuite (PR testsuite/40426)
|
||||||
|
- fix up a pasto in recent -D_FORTIFY_SOURCE changes (#506099)
|
||||||
|
|
||||||
* Fri Jun 12 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-8
|
* Fri Jun 12 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-8
|
||||||
- update from gcc-4_4-branch
|
- update from gcc-4_4-branch
|
||||||
- PRs c++/40381, libfortran/40330
|
- PRs c++/40381, libfortran/40330
|
||||||
|
92
gcc44-rh506099.patch
Normal file
92
gcc44-rh506099.patch
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
2009-06-15 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* tree-object-size.c (addr_object_size): Fix a pasto in the last
|
||||||
|
change.
|
||||||
|
|
||||||
|
* gcc.dg/builtin-object-size-7.c: New test.
|
||||||
|
|
||||||
|
--- gcc/tree-object-size.c.jj 2009-06-12 10:36:08.000000000 +0200
|
||||||
|
+++ gcc/tree-object-size.c 2009-06-15 18:40:17.000000000 +0200
|
||||||
|
@@ -316,7 +316,7 @@ addr_object_size (struct object_size_inf
|
||||||
|
&& tree_int_cst_lt (pt_var_size, bytes2))
|
||||||
|
bytes2 = size_zero_node;
|
||||||
|
else
|
||||||
|
- bytes2 = size_binop (MINUS_EXPR, var_size, bytes2);
|
||||||
|
+ bytes2 = size_binop (MINUS_EXPR, pt_var_size, bytes2);
|
||||||
|
bytes = size_binop (MIN_EXPR, bytes, bytes2);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--- gcc/testsuite/gcc.dg/builtin-object-size-7.c.jj 2009-06-15 18:54:33.000000000 +0200
|
||||||
|
+++ gcc/testsuite/gcc.dg/builtin-object-size-7.c 2009-06-15 18:55:58.000000000 +0200
|
||||||
|
@@ -0,0 +1,71 @@
|
||||||
|
+/* { dg-do run } */
|
||||||
|
+/* { dg-options "-O2" } */
|
||||||
|
+
|
||||||
|
+typedef __SIZE_TYPE__ size_t;
|
||||||
|
+extern void *malloc (size_t);
|
||||||
|
+extern void abort (void);
|
||||||
|
+
|
||||||
|
+struct A
|
||||||
|
+{
|
||||||
|
+ int i, j, k;
|
||||||
|
+ char buf[255];
|
||||||
|
+ int l, m, n, o;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+main (void)
|
||||||
|
+{
|
||||||
|
+ const size_t s = sizeof (struct A);
|
||||||
|
+ const size_t o = __builtin_offsetof (struct A, buf);
|
||||||
|
+ struct A *a = malloc (s);
|
||||||
|
+ struct A *b = malloc (o + 212);
|
||||||
|
+ if (__builtin_object_size (a->buf, 0) != s - o)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (a->buf, 1) != sizeof (a->buf))
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (a->buf, 2) != s - o)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (a->buf, 3) != sizeof (a->buf))
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[0], 0) != s - o)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[0], 1) != sizeof (a->buf))
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[0], 2) != s - o)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[0], 3) != sizeof (a->buf))
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[6], 0) != s - o - 6)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[6], 1) != sizeof (a->buf) - 6)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[6], 2) != s - o - 6)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&a->buf[6], 3) != sizeof (a->buf) - 6)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (b->buf, 0) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (b->buf, 1) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (b->buf, 2) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (b->buf, 3) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[0], 0) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[0], 1) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[0], 2) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[0], 3) != 212)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[28], 0) != 212 - 28)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[28], 1) != 212 - 28)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[28], 2) != 212 - 28)
|
||||||
|
+ abort ();
|
||||||
|
+ if (__builtin_object_size (&b->buf[28], 3) != 212 - 28)
|
||||||
|
+ abort ();
|
||||||
|
+ return 0;
|
||||||
|
+}
|
Loading…
Reference in New Issue
Block a user