6.0.0-0.15
This commit is contained in:
parent
f027054e0f
commit
005db08c91
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/gcc-6.0.0-20160219.tar.bz2
|
||||
/gcc-6.0.0-20160227.tar.bz2
|
||||
/gcc-6.0.0-20160302.tar.bz2
|
||||
/gcc-6.0.0-20160305.tar.bz2
|
||||
|
20
gcc.spec
20
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20160302
|
||||
%global SVNREV 233890
|
||||
%global DATE 20160305
|
||||
%global SVNREV 234005
|
||||
%global gcc_version 6.0.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.14
|
||||
%global gcc_release 0.15
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
# Hardening slows the compiler way too much.
|
||||
@ -206,7 +206,6 @@ Patch10: gcc6-no-add-needed.patch
|
||||
Patch11: gcc6-libgo-p224.patch
|
||||
Patch12: gcc6-aarch64-async-unw-tables.patch
|
||||
Patch13: gcc6-libsanitize-aarch64-va42.patch
|
||||
Patch14: gcc6-pr69947.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -773,7 +772,6 @@ package or when debugging this package.
|
||||
rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||
%patch12 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch13 -p0 -b .libsanitize-aarch64-va42~
|
||||
%patch14 -p0 -b .pr69947~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
mkdir dwz-wrapper
|
||||
@ -3066,6 +3064,18 @@ fi
|
||||
%doc rpm.doc/changelogs/libcc1/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Sat Mar 5 2016 Jakub Jelinek <jakub@redhat.com> 6.0.0-0.15
|
||||
- update from the trunk
|
||||
- PRs c++/51406, c++/66786, c++/67164, c++/69203, c++/70035, c++/70054,
|
||||
c++/70067, c++/70084, c/67854, c/68187, c/69798, c/69824, c/69973,
|
||||
ipa/69990, libffi/70024, libgomp/69555, middle-end/67278,
|
||||
middle-end/70050, rtl-opt/67145, rtl-optimization/57676,
|
||||
rtl-optimization/69052, rtl-optimization/69904,
|
||||
rtl-optimization/69941, rtl-optimization/69942, target/67278,
|
||||
target/70004, target/70014, target/70021, target/70028, target/70059,
|
||||
target/70062, testsuite/69766, tree-optimization/55936,
|
||||
tree-optimization/68659, tree-optimization/70043
|
||||
|
||||
* Wed Mar 2 2016 Jakub Jelinek <jakub@redhat.com> 6.0.0-0.14
|
||||
- update from the trunk
|
||||
- PRs ada/70017, c++/51489, c++/69795, c++/69961, c++/69995, c++/70036,
|
||||
|
@ -1,66 +0,0 @@
|
||||
2016-02-25 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR debug/69947
|
||||
* dwarf2out.c (prune_unused_types_walk_loc_descr): Handle
|
||||
all other ops that have dw_val_class_die_ref operands,
|
||||
and DW_OP_GNU_entry_value.
|
||||
|
||||
* gcc.dg/guality/pr69947.c: New test.
|
||||
|
||||
--- gcc/dwarf2out.c.jj 2016-02-25 17:04:11.465781368 +0100
|
||||
+++ gcc/dwarf2out.c 2016-02-25 17:41:26.785371399 +0100
|
||||
@@ -25641,11 +25641,29 @@ prune_unused_types_walk_loc_descr (dw_lo
|
||||
for (; loc != NULL; loc = loc->dw_loc_next)
|
||||
switch (loc->dw_loc_opc)
|
||||
{
|
||||
+ case DW_OP_GNU_implicit_pointer:
|
||||
+ case DW_OP_GNU_convert:
|
||||
+ case DW_OP_GNU_reinterpret:
|
||||
+ if (loc->dw_loc_oprnd1.val_class == dw_val_class_die_ref)
|
||||
+ prune_unused_types_mark (loc->dw_loc_oprnd1.v.val_die_ref.die, 1);
|
||||
+ break;
|
||||
case DW_OP_call2:
|
||||
case DW_OP_call4:
|
||||
case DW_OP_call_ref:
|
||||
+ case DW_OP_GNU_const_type:
|
||||
+ case DW_OP_GNU_parameter_ref:
|
||||
+ gcc_assert (loc->dw_loc_oprnd1.val_class == dw_val_class_die_ref);
|
||||
prune_unused_types_mark (loc->dw_loc_oprnd1.v.val_die_ref.die, 1);
|
||||
break;
|
||||
+ case DW_OP_GNU_regval_type:
|
||||
+ case DW_OP_GNU_deref_type:
|
||||
+ gcc_assert (loc->dw_loc_oprnd2.val_class == dw_val_class_die_ref);
|
||||
+ prune_unused_types_mark (loc->dw_loc_oprnd2.v.val_die_ref.die, 1);
|
||||
+ break;
|
||||
+ case DW_OP_GNU_entry_value:
|
||||
+ gcc_assert (loc->dw_loc_oprnd1.val_class == dw_val_class_loc);
|
||||
+ prune_unused_types_walk_loc_descr (loc->dw_loc_oprnd1.v.val_loc);
|
||||
+ break;
|
||||
default:
|
||||
break;
|
||||
}
|
||||
--- gcc/testsuite/gcc.dg/guality/pr69947.c.jj 2016-02-25 17:22:13.729098931 +0100
|
||||
+++ gcc/testsuite/gcc.dg/guality/pr69947.c 2016-02-25 17:22:13.729098931 +0100
|
||||
@@ -0,0 +1,22 @@
|
||||
+/* PR debug/69947 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-g" } */
|
||||
+
|
||||
+#include "../nop.h"
|
||||
+
|
||||
+static const char *c = "foobar";
|
||||
+
|
||||
+__attribute__((noinline, noclone)) void
|
||||
+foo (void)
|
||||
+{
|
||||
+ static const char a[] = "abcdefg";
|
||||
+ const char *b = a; /* { dg-final { gdb-test 14 "c\[2\]" "'o'" } } */
|
||||
+ asm (NOP : : : "memory"); /* { dg-final { gdb-test 14 "b\[4\]" "'e'" } } */
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ foo ();
|
||||
+ return 0;
|
||||
+}
|
Loading…
Reference in New Issue
Block a user