13.3.1-2
Resolves: RHEL-40244
This commit is contained in:
parent
2ec74d3b28
commit
dc34f0f024
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/gcc-13.1.1-20230614.tar.xz
|
||||
/gcc-13.2.1-20231205.tar.xz
|
||||
/gcc-13.3.1-20240522.tar.xz
|
||||
/gcc-13.3.1-20240611.tar.xz
|
||||
|
22
gcc.spec
22
gcc.spec
@ -5,13 +5,13 @@ BuildRequires: scl-utils-build
|
||||
%{?scl:%global __strip %%{_scl_root}/usr/bin/strip}
|
||||
%{?scl:%global __objdump %%{_scl_root}/usr/bin/objdump}
|
||||
%{?scl:%scl_package gcc}
|
||||
%global DATE 20240522
|
||||
%global gitrev 5632a1dc05eae4936ac0d8d7e8a5cb717bce5960
|
||||
%global DATE 20240611
|
||||
%global gitrev 03b1a31f9807251f378fcecb29c4669eed357eb2
|
||||
%global gcc_version 13.3.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 1
|
||||
%global gcc_release 2
|
||||
%global nvptx_tools_gitrev aa3404ad5a496cda5d79a50bedb1344fd63e8763
|
||||
%global newlib_cygwin_gitrev 9e09d6ed83cce4777a5950412647ccc603040409
|
||||
%global mpc_version 1.0.3
|
||||
@ -330,6 +330,7 @@ Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-znver5.patch
|
||||
Patch13: gcc13-pr107071.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -696,6 +697,7 @@ so that there cannot be any synchronization problems.
|
||||
%endif
|
||||
%patch -P11 -p0 -b .d-shared-libphobos~
|
||||
%patch -P12 -p1 -b .znver5~
|
||||
%patch -P13 -p1 -b .pr107071~
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
%patch -P100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -1826,7 +1828,7 @@ ln -sf ../../../%{multilib_32_arch}-%{_vendor}-%{_target_os}%{?_gnu}/%{gcc_major
|
||||
%if 0%{?_enable_debug_packages}
|
||||
mkdir -p $RPM_BUILD_ROOT%{?scl:%{_root_prefix}}%{!?scl:%{_prefix}}/lib/debug%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}
|
||||
adirs="$FULLPATH"
|
||||
if [ $FULLLPATH -ne $FULLPATH ]; then
|
||||
if [ "$FULLLPATH" != "$FULLPATH" ]; then
|
||||
adirs="$adirs $FULLLPATH"
|
||||
fi
|
||||
for f in `find $adirs -maxdepth 1 -a \
|
||||
@ -2907,6 +2909,18 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 11 2024 Marek Polacek <polacek@redhat.com> 13.3.1-2
|
||||
- update from releases/gcc-13 branch
|
||||
- PRs ada/114398, ada/114708, c/114493, c++/111529, c++/113598,
|
||||
fortran/110415, fortran/114827, fortran/115150, libstdc++/114940,
|
||||
libstdc++/115269, middle-end/108789, rtl-optimization/114902,
|
||||
rtl-optimization/115092, target/113281, target/113719, target/115297,
|
||||
target/115317, target/115324, tree-optimization/115192,
|
||||
tree-optimization/115307, tree-optimization/115337
|
||||
- fix a shell condition (RHEL-40722)
|
||||
- backport a fix for modes_1.f90 (RHEL-40234)
|
||||
- fix up pointer types to may_alias structures (PR c/114493, RHEL-40244)
|
||||
|
||||
* Thu May 30 2024 Marek Polacek <polacek@redhat.com> 13.3.1-1
|
||||
- update from releases/gcc-13 branch
|
||||
- GCC 13.3 release
|
||||
|
@ -8804,7 +8804,7 @@
|
||||
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
|
||||
--- libstdc++-v3/src/nonshared20/tzdb80.cc.jj 2023-05-19 20:25:50.447297532 +0200
|
||||
+++ libstdc++-v3/src/nonshared20/tzdb80.cc 2023-05-19 19:51:19.200552634 +0200
|
||||
@@ -0,0 +1,128 @@
|
||||
@@ -0,0 +1,126 @@
|
||||
+// Copyright The GNU Toolchain Authors.
|
||||
+//
|
||||
+// This file is part of the GNU ISO C++ Library. This library is free
|
||||
@ -8906,9 +8906,7 @@
|
||||
+asm (".hidden _ZZNSt19_Sp_make_shared_tag5_S_tiEvE5__tag");
|
||||
+asm (".hidden _ZZNSt8__detail18__waiter_pool_base6_S_forEPKvE3__w");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE10_M_disposeEv");
|
||||
+#if defined(__aarch64__) || defined(__powerpc64__) || defined(__x86_64__)
|
||||
+asm (".hidden _ZNKSt10filesystem7__cxx114path8iteratordeEv");
|
||||
+#endif
|
||||
+#if defined(__aarch64__) || defined(__x86_64__)
|
||||
+asm (".hidden _ZSt25__unguarded_linear_insertIN9__gnu_cxx17__normal_iteratorIPNSt6chrono9time_zoneESt6vectorIS3_SaIS3_EEEENS0_5__ops14_Val_comp_iterIZNSt6ranges8__detail16__make_comp_projINSB_4lessEMS3_KDoFSt17basic_string_viewIcSt11char_traitsIcEEvEEEDaRT_RT0_EUlOSL_OSN_E_EEEvSL_SN_");
|
||||
+#endif
|
||||
@ -12052,7 +12050,7 @@
|
||||
+#include "../c++17/string-inst.cc"
|
||||
--- libstdc++-v3/src/nonshared17/floating_to_chars110.cc.jj 2023-05-19 18:08:54.897043256 +0200
|
||||
+++ libstdc++-v3/src/nonshared17/floating_to_chars110.cc 2023-05-19 19:39:17.219738117 +0200
|
||||
@@ -0,0 +1,31 @@
|
||||
@@ -0,0 +1,36 @@
|
||||
+// Copyright (C) 2019-2023 Free Software Foundation, Inc.
|
||||
+//
|
||||
+// This file is part of the GNU ISO C++ Library. This library is free
|
||||
@ -12084,6 +12082,11 @@
|
||||
+#if !defined(__s390x__) && !defined(__aarch64__)
|
||||
+asm (".hidden _ZNSt8__detail18__to_chars_10_implIjEEvPcjT_");
|
||||
+#endif
|
||||
+#if defined(__powerpc64__)
|
||||
+asm (".hidden _ZSt8to_charsPcS_u9__ieee128");
|
||||
+asm (".hidden _ZSt8to_charsPcS_u9__ieee128St12chars_format");
|
||||
+asm (".hidden _ZSt8to_charsPcS_u9__ieee128St12chars_formati");
|
||||
+#endif
|
||||
--- libstdc++-v3/src/nonshared17/string-inst110.cc.jj 2023-05-19 20:14:44.341711057 +0200
|
||||
+++ libstdc++-v3/src/nonshared17/string-inst110.cc 2023-05-19 19:41:57.743474432 +0200
|
||||
@@ -0,0 +1,37 @@
|
||||
|
28
gcc13-pr107071.patch
Normal file
28
gcc13-pr107071.patch
Normal file
@ -0,0 +1,28 @@
|
||||
commit c8c587b854c9e85fc9ce58c8192d532205f0ee1f
|
||||
Author: Tamar Christina <tamar.christina@arm.com>
|
||||
Date: Wed Feb 21 11:42:13 2024 +0000
|
||||
|
||||
AArch64: skip modes_1.f90 [PR107071]
|
||||
|
||||
This test has never worked on AArch64 since the day it was committed. It has
|
||||
a number of issues that prevent it from working on AArch64:
|
||||
|
||||
The testfailures seem to be known and triaged, so until that's fixed there's
|
||||
no point in running this test.
|
||||
|
||||
gcc/testsuite/ChangeLog:
|
||||
|
||||
PR fortran/107071
|
||||
* gfortran.dg/ieee/modes_1.f90: skip aarch64, arm.
|
||||
|
||||
diff --git a/gcc/testsuite/gfortran.dg/ieee/modes_1.f90 b/gcc/testsuite/gfortran.dg/ieee/modes_1.f90
|
||||
index 205c47f3800..e29d8c678e6 100644
|
||||
--- a/gcc/testsuite/gfortran.dg/ieee/modes_1.f90
|
||||
+++ b/gcc/testsuite/gfortran.dg/ieee/modes_1.f90
|
||||
@@ -1,5 +1,5 @@
|
||||
! { dg-do run }
|
||||
-!
|
||||
+! { dg-skip-if "PR libfortran/78314" { aarch64*-*-gnu* arm*-*-gnueabi arm*-*-gnueabihf } }
|
||||
! Test IEEE_MODES_TYPE, IEEE_GET_MODES and IEEE_SET_MODES
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.3.1-20240522.tar.xz) = a0d7a71101af71309a5b3677cff7e0b193d06d1eac0ca642573dda24614dc8f101342d576727a1a3ea3bf0adf6b53a1a472516b1a4164391a32af735bcce9923
|
||||
SHA512 (gcc-13.3.1-20240611.tar.xz) = 4cf86cf58663e89b54198824eaf6387157f8fb205f700815d8066150f393ceecb41f3f369c772e5855a4555eccf24c5dfd501507337d0438cc8134d0df02f696
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-aa3404ad5a496cda5d79a50bedb1344fd63e8763.tar.xz) = 33a024326426375533cb5dd9b68b2508f37540be418d2506bfa19a5f5866485e9af150469064e9059b68136ad8cb080b3b12e7eb5c6b7d1288cf6bfb3f6bb5d0
|
||||
|
Loading…
Reference in New Issue
Block a user