13.2.1-5
Resolves: RHEL-11600
This commit is contained in:
parent
12d373f659
commit
a6c44036a2
3
.gitignore
vendored
3
.gitignore
vendored
@ -0,0 +1,3 @@
|
||||
/gcc-13.2.1-20231011.tar.xz
|
||||
/nvptx-tools-aa3404ad5a496cda5d79a50bedb1344fd63e8763.tar.xz
|
||||
/gcc-13.2.1-20231113.tar.xz
|
45
gcc.spec
45
gcc.spec
@ -5,14 +5,14 @@ BuildRequires: scl-utils-build
|
||||
%{?scl:%global __strip %%{_scl_root}/usr/bin/strip}
|
||||
%{?scl:%global __objdump %%{_scl_root}/usr/bin/objdump}
|
||||
%{?scl:%scl_package gcc}
|
||||
%global DATE 20230614
|
||||
%global gitrev 0d7019741b037c7e9c4e57d6de3bce6bb2ed8026
|
||||
%global gcc_version 13.1.1
|
||||
%global DATE 20231113
|
||||
%global gitrev 4292c70489195b52615f16679dc6df18cd1c8432
|
||||
%global gcc_version 13.2.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 4
|
||||
%global nvptx_tools_gitrev 93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b
|
||||
%global gcc_release 5
|
||||
%global nvptx_tools_gitrev aa3404ad5a496cda5d79a50bedb1344fd63e8763
|
||||
%global newlib_cygwin_gitrev 9e09d6ed83cce4777a5950412647ccc603040409
|
||||
%global mpc_version 1.0.3
|
||||
%global isl_version 0.24
|
||||
@ -149,7 +149,7 @@ BuildRequires: scl-utils-build
|
||||
Summary: GCC version 13
|
||||
Name: %{?scl_prefix}gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.3%{?dist}
|
||||
Release: %{gcc_release}%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -329,6 +329,7 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr110792.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -358,9 +359,7 @@ Patch3016: 0019-xfails.patch
|
||||
Patch3017: 0020-more-fixes.patch
|
||||
Patch3018: 0021-libstdc++-disable-tests.patch
|
||||
Patch3019: 0022-libstdc++-revert-behavior.patch
|
||||
Patch3020: gcc13-testsuite-no-ssp.patch
|
||||
Patch3021: gcc13-testsuite-p10.patch
|
||||
Patch3022: gcc13-testsuite-plugin.patch
|
||||
Patch3023: gcc13-testsuite-dwarf.patch
|
||||
|
||||
%if 0%{?rhel} == 9
|
||||
@ -695,6 +694,7 @@ so that there cannot be any synchronization problems.
|
||||
%patch -P10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch -P11 -p0 -b .d-shared-libphobos~
|
||||
%patch -P12 -p0 -b .pr110792~
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
%patch -P100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -740,9 +740,7 @@ rm -f libphobos/testsuite/libphobos.gc/forkgc2.d
|
||||
%if 0%{?rhel} <= 7
|
||||
%patch -P3019 -p1 -b .dts-test-19~
|
||||
%endif
|
||||
%patch -P3020 -p1 -b .dts-test-20~
|
||||
%patch -P3021 -p1 -b .dts-test-21~
|
||||
%patch -P3022 -p1 -b .dts-test-22~
|
||||
%patch -P3023 -p1 -b .dts-test-23~
|
||||
|
||||
find gcc/testsuite -name \*.pr96939~ | xargs rm -f
|
||||
@ -2906,6 +2904,33 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 13 2023 Marek Polacek <polacek@redhat.com> 13.2.1-5
|
||||
- update from releases/gcc-13 branch
|
||||
- PRs c++/89038, c/111884, d/110712, d/112270, fortran/67740, fortran/97245,
|
||||
fortran/111837, fortran/112316, libbacktrace/111315,
|
||||
libbacktrace/112263, libstdc++/110944, libstdc++/111172,
|
||||
libstdc++/111936, libstdc++/112089, libstdc++/112314,
|
||||
middle-end/111253, middle-end/111818, modula2/111756, modula2/112110,
|
||||
target/101177, target/110170, target/111001, target/111366,
|
||||
target/111367, target/111380, target/111935, target/112443,
|
||||
tree-optimization/111397, tree-optimization/111445,
|
||||
tree-optimization/111489, tree-optimization/111583,
|
||||
tree-optimization/111614, tree-optimization/111622,
|
||||
tree-optimization/111694, tree-optimization/111764,
|
||||
tree-optimization/111820, tree-optimization/111833,
|
||||
tree-optimization/111917
|
||||
- fix aarch64 RA ICE (#2241139, PR target/111528)
|
||||
- fix ia32 doubleword rotates (#2238781, PR target/110792)
|
||||
|
||||
* Thu Nov 9 2023 Marek Polacek <polacek@redhat.com> 13.2.1-4
|
||||
- update from releases/gcc-13 branch
|
||||
- PRs ada/110488, ada/111434, c++/99631, c++/111471, c++/111485, c++/111493,
|
||||
c++/111512, fortran/68155, fortran/92586, fortran/111674,
|
||||
libstdc++/108046, libstdc++/111050, libstdc++/111102,
|
||||
libstdc++/111511, middle-end/111699, modula2/111510, target/111121,
|
||||
target/111411, tree-optimization/110315, tree-optimization/110386,
|
||||
tree-optimization/111331, tree-optimization/111519
|
||||
|
||||
* Thu Jul 6 2023 Marek Polacek <polacek@redhat.com> 13.1.1-4.3
|
||||
- fix utf-1.C with -gdwarf-4 (#2217506)
|
||||
|
||||
|
@ -8804,7 +8804,7 @@
|
||||
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
|
||||
--- libstdc++-v3/src/nonshared20/tzdb80.cc.jj 2023-05-19 20:25:50.447297532 +0200
|
||||
+++ libstdc++-v3/src/nonshared20/tzdb80.cc 2023-05-19 19:51:19.200552634 +0200
|
||||
@@ -0,0 +1,120 @@
|
||||
@@ -0,0 +1,124 @@
|
||||
+// Copyright The GNU Toolchain Authors.
|
||||
+//
|
||||
+// This file is part of the GNU ISO C++ Library. This library is free
|
||||
@ -8891,12 +8891,11 @@
|
||||
+asm (".hidden _ZNSt6chrono9tzdb_list5_Node11_S_the_listE");
|
||||
+asm (".hidden _ZTSSt23_Sp_counted_ptr_inplaceINSt6chrono9tzdb_list5_NodeESaIvELN9__gnu_cxx12_Lock_policyE2EE");
|
||||
+asm (".hidden _ZTISt23_Sp_counted_ptr_inplaceINSt6chrono9tzdb_list5_NodeESaIvELN9__gnu_cxx12_Lock_policyE2EE");
|
||||
+#if 0
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED2Ev");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED1Ev");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC2EOS4_");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC1EOS4_");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE10_M_disposeEv");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE9_M_assignERKS4_");
|
||||
+#endif
|
||||
+asm (".hidden _ZTSSt19_Sp_make_shared_tag");
|
||||
+asm (".hidden _ZNSt16_Sp_counted_baseILN9__gnu_cxx12_Lock_policyE2EE10_M_releaseEv");
|
||||
+asm (".hidden _ZNSt10unique_ptrINSt10filesystem7__cxx114path5_List5_ImplENS3_13_Impl_deleterEED2Ev");
|
||||
@ -8907,9 +8906,12 @@
|
||||
+asm (".hidden _ZTISt16_Sp_counted_baseILN9__gnu_cxx12_Lock_policyE2EE");
|
||||
+asm (".hidden _ZZNSt19_Sp_make_shared_tag5_S_tiEvE5__tag");
|
||||
+asm (".hidden _ZZNSt8__detail18__waiter_pool_base6_S_forEPKvE3__w");
|
||||
+#if defined(__x86_64__) || defined(__aarch64__) || defined(__i386__)
|
||||
+#if defined(__aarch64__)
|
||||
+asm (".hidden _ZNKSt10filesystem7__cxx114path8iteratordeEv");
|
||||
+#endif
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE9_M_assignERKS4_");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC1EOS4_");
|
||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC2EOS4_");
|
||||
+asm (".hidden _ZSt23__atomic_wait_address_vIiZNKSt13__atomic_baseIiE4waitEiSt12memory_orderEUlvE_EvPKT_S4_T0_");
|
||||
+#if defined(__i386__)
|
||||
+asm (".hidden _ZSt16__introsort_loopIN9__gnu_cxx17__normal_iteratorIPNSt6chrono9time_zoneESt6vectorIS3_SaIS3_EEEEiNS0_5__ops15_Iter_comp_iterIZNSt6ranges8__detail16__make_comp_projINSB_4lessESt8identityEEDaRT_RT0_EUlOSG_OSI_E_EEEvSG_SG_SI_T1_");
|
||||
|
@ -4,7 +4,7 @@
|
||||
<a class="link" href="https://www.fsf.org" target="_top">FSF
|
||||
</a>
|
||||
</p><p>
|
||||
+ Release 13.1.1
|
||||
+ Release 13.2.1
|
||||
+ </p><p>
|
||||
Permission is granted to copy, distribute and/or modify this
|
||||
document under the terms of the GNU Free Documentation
|
||||
@ -17,7 +17,7 @@
|
||||
</p><p>
|
||||
- The API documentation, rendered into HTML, can be viewed online
|
||||
+ The API documentation, rendered into HTML, can be viewed locally
|
||||
+ <a class="link" href="api/index.html" target="_top">for the 13.1.1 release</a>,
|
||||
+ <a class="link" href="api/index.html" target="_top">for the 13.2.1 release</a>,
|
||||
+ online
|
||||
<a class="link" href="http://gcc.gnu.org/onlinedocs/" target="_top">for each GCC release</a>
|
||||
and
|
||||
|
163
gcc13-pr110792.patch
Normal file
163
gcc13-pr110792.patch
Normal file
@ -0,0 +1,163 @@
|
||||
PR target/110792: Early clobber issues with rot32di2_doubleword on i386.
|
||||
|
||||
This patch is a conservative fix for PR target/110792, a wrong-code
|
||||
regression affecting doubleword rotations by BITS_PER_WORD, which
|
||||
effectively swaps the highpart and lowpart words, when the source to be
|
||||
rotated resides in memory. The issue is that if the register used to
|
||||
hold the lowpart of the destination is mentioned in the address of
|
||||
the memory operand, the current define_insn_and_split unintentionally
|
||||
clobbers it before reading the highpart.
|
||||
|
||||
Hence, for the testcase, the incorrectly generated code looks like:
|
||||
|
||||
salq $4, %rdi // calculate address
|
||||
movq WHIRL_S+8(%rdi), %rdi // accidentally clobber addr
|
||||
movq WHIRL_S(%rdi), %rbp // load (wrong) lowpart
|
||||
|
||||
Traditionally, the textbook way to fix this would be to add an
|
||||
explicit early clobber to the instruction's constraints.
|
||||
|
||||
(define_insn_and_split "<insn>32di2_doubleword"
|
||||
- [(set (match_operand:DI 0 "register_operand" "=r,r,r")
|
||||
+ [(set (match_operand:DI 0 "register_operand" "=r,r,&r")
|
||||
(any_rotate:DI (match_operand:DI 1 "nonimmediate_operand" "0,r,o")
|
||||
(const_int 32)))]
|
||||
|
||||
but unfortunately this currently generates significantly worse code,
|
||||
due to a strange choice of reloads (effectively memcpy), which ends up
|
||||
looking like:
|
||||
|
||||
salq $4, %rdi // calculate address
|
||||
movdqa WHIRL_S(%rdi), %xmm0 // load the double word in SSE reg.
|
||||
movaps %xmm0, -16(%rsp) // store the SSE reg back to the stack
|
||||
movq -8(%rsp), %rdi // load highpart
|
||||
movq -16(%rsp), %rbp // load lowpart
|
||||
|
||||
Note that reload's "&" doesn't distinguish between the memory being
|
||||
early clobbered, vs the registers used in an addressing mode being
|
||||
early clobbered.
|
||||
|
||||
The fix proposed in this patch is to remove the third alternative, that
|
||||
allowed offsetable memory as an operand, forcing reload to place the
|
||||
operand into a register before the rotation. This results in:
|
||||
|
||||
salq $4, %rdi
|
||||
movq WHIRL_S(%rdi), %rax
|
||||
movq WHIRL_S+8(%rdi), %rdi
|
||||
movq %rax, %rbp
|
||||
|
||||
I believe there's a more advanced solution, by swapping the order of
|
||||
the loads (if first destination register is mentioned in the address),
|
||||
or inserting a lea insn (if both destination registers are mentioned
|
||||
in the address), but this fix is a minimal "safe" solution, that
|
||||
should hopefully be suitable for backporting.
|
||||
|
||||
2023-08-06 Roger Sayle <roger@nextmovesoftware.com>
|
||||
|
||||
gcc/testsuite/ChangeLog
|
||||
PR target/110792
|
||||
* gcc.target/i386/pr110792.c: Remove dg-final scan-assembler-not.
|
||||
|
||||
2023-08-03 Roger Sayle <roger@nextmovesoftware.com>
|
||||
|
||||
gcc/ChangeLog
|
||||
PR target/110792
|
||||
* config/i386/i386.md (<any_rotate>ti3): For rotations by 64 bits
|
||||
place operand in a register before gen_<insn>64ti2_doubleword.
|
||||
(<any_rotate>di3): Likewise, for rotations by 32 bits, place
|
||||
operand in a register before gen_<insn>32di2_doubleword.
|
||||
(<any_rotate>32di2_doubleword): Constrain operand to be in register.
|
||||
(<any_rotate>64ti2_doubleword): Likewise.
|
||||
|
||||
gcc/testsuite/ChangeLog
|
||||
PR target/110792
|
||||
* g++.target/i386/pr110792.C: New 32-bit C++ test case.
|
||||
* gcc.target/i386/pr110792.c: New 64-bit C test case.
|
||||
|
||||
--- gcc/config/i386/i386.md
|
||||
+++ gcc/config/i386/i386.md
|
||||
@@ -15341,7 +15341,10 @@ (define_expand "<insn>ti3"
|
||||
emit_insn (gen_ix86_<insn>ti3_doubleword
|
||||
(operands[0], operands[1], operands[2]));
|
||||
else if (CONST_INT_P (operands[2]) && INTVAL (operands[2]) == 64)
|
||||
- emit_insn (gen_<insn>64ti2_doubleword (operands[0], operands[1]));
|
||||
+ {
|
||||
+ operands[1] = force_reg (TImode, operands[1]);
|
||||
+ emit_insn (gen_<insn>64ti2_doubleword (operands[0], operands[1]));
|
||||
+ }
|
||||
else
|
||||
{
|
||||
rtx amount = force_reg (QImode, operands[2]);
|
||||
@@ -15376,7 +15379,10 @@ (define_expand "<insn>di3"
|
||||
emit_insn (gen_ix86_<insn>di3_doubleword
|
||||
(operands[0], operands[1], operands[2]));
|
||||
else if (CONST_INT_P (operands[2]) && INTVAL (operands[2]) == 32)
|
||||
- emit_insn (gen_<insn>32di2_doubleword (operands[0], operands[1]));
|
||||
+ {
|
||||
+ operands[1] = force_reg (DImode, operands[1]);
|
||||
+ emit_insn (gen_<insn>32di2_doubleword (operands[0], operands[1]));
|
||||
+ }
|
||||
else
|
||||
FAIL;
|
||||
|
||||
@@ -15544,8 +15550,8 @@ (define_insn_and_split "ix86_rotr<dwi>3_doubleword"
|
||||
})
|
||||
|
||||
(define_insn_and_split "<insn>32di2_doubleword"
|
||||
- [(set (match_operand:DI 0 "register_operand" "=r,r,r")
|
||||
- (any_rotate:DI (match_operand:DI 1 "nonimmediate_operand" "0,r,o")
|
||||
+ [(set (match_operand:DI 0 "register_operand" "=r,r")
|
||||
+ (any_rotate:DI (match_operand:DI 1 "register_operand" "0,r")
|
||||
(const_int 32)))]
|
||||
"!TARGET_64BIT"
|
||||
"#"
|
||||
@@ -15562,8 +15568,8 @@ (define_insn_and_split "<insn>32di2_doubleword"
|
||||
})
|
||||
|
||||
(define_insn_and_split "<insn>64ti2_doubleword"
|
||||
- [(set (match_operand:TI 0 "register_operand" "=r,r,r")
|
||||
- (any_rotate:TI (match_operand:TI 1 "nonimmediate_operand" "0,r,o")
|
||||
+ [(set (match_operand:TI 0 "register_operand" "=r,r")
|
||||
+ (any_rotate:TI (match_operand:TI 1 "register_operand" "0,r")
|
||||
(const_int 64)))]
|
||||
"TARGET_64BIT"
|
||||
"#"
|
||||
--- gcc/testsuite/g++.target/i386/pr110792.C
|
||||
+++ gcc/testsuite/g++.target/i386/pr110792.C
|
||||
@@ -0,0 +1,16 @@
|
||||
+/* { dg-do compile { target ia32 } } */
|
||||
+/* { dg-options "-O2" } */
|
||||
+
|
||||
+template <int ROT, typename T>
|
||||
+inline T rotr(T input)
|
||||
+{
|
||||
+ return static_cast<T>((input >> ROT) | (input << (8 * sizeof(T) - ROT)));
|
||||
+}
|
||||
+
|
||||
+unsigned long long WHIRL_S[256] = {0x18186018C07830D8};
|
||||
+unsigned long long whirl(unsigned char x0)
|
||||
+{
|
||||
+ const unsigned long long s4 = WHIRL_S[x0&0xFF];
|
||||
+ return rotr<32>(s4);
|
||||
+}
|
||||
+/* { dg-final { scan-assembler-not "movl\tWHIRL_S\\+4\\(,%eax,8\\), %eax" } } */
|
||||
--- gcc/testsuite/gcc.target/i386/pr110792.c
|
||||
+++ gcc/testsuite/gcc.target/i386/pr110792.c
|
||||
@@ -0,0 +1,17 @@
|
||||
+/* { dg-do compile { target int128 } } */
|
||||
+/* { dg-options "-O2" } */
|
||||
+
|
||||
+static inline unsigned __int128 rotr(unsigned __int128 input)
|
||||
+{
|
||||
+ return ((input >> 64) | (input << (64)));
|
||||
+}
|
||||
+
|
||||
+unsigned __int128 WHIRL_S[256] = {((__int128)0x18186018C07830D8) << 64 |0x18186018C07830D8};
|
||||
+unsigned __int128 whirl(unsigned char x0)
|
||||
+{
|
||||
+ register int t __asm("rdi") = x0&0xFF;
|
||||
+ const unsigned __int128 s4 = WHIRL_S[t];
|
||||
+ register unsigned __int128 tt __asm("rdi") = rotr(s4);
|
||||
+ asm("":::"memory");
|
||||
+ return tt;
|
||||
+}
|
@ -1,46 +0,0 @@
|
||||
From b964d2647b0da15543faed5add5044fd79a85c5c Mon Sep 17 00:00:00 2001
|
||||
From: Marek Polacek <polacek@redhat.com>
|
||||
Date: Thu, 29 Jun 2023 15:59:29 -0400
|
||||
Subject: [PATCH] i386: add -fno-stack-protector to two tests
|
||||
|
||||
These tests fail when the testsuite is executed with -fstack-protector-strong.
|
||||
To avoid this, this patch adds -fno-stack-protector to dg-options.
|
||||
|
||||
Tested on x86_64-pc-linux-gnu, ok for trunk?
|
||||
|
||||
gcc/testsuite/ChangeLog:
|
||||
|
||||
* gcc.target/i386/pr104610.c: Use -fno-stack-protector.
|
||||
* gcc.target/i386/pr69482-1.c: Likewise.
|
||||
---
|
||||
gcc/testsuite/gcc.target/i386/pr104610.c | 2 +-
|
||||
gcc/testsuite/gcc.target/i386/pr69482-1.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gcc/testsuite/gcc.target/i386/pr104610.c b/gcc/testsuite/gcc.target/i386/pr104610.c
|
||||
index fe39cbe5b8a..5173fc8898c 100644
|
||||
--- a/gcc/testsuite/gcc.target/i386/pr104610.c
|
||||
+++ b/gcc/testsuite/gcc.target/i386/pr104610.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* { dg-do compile } */
|
||||
-/* { dg-options "-O2 -mavx -mmove-max=256 -mstore-max=256" } */
|
||||
+/* { dg-options "-O2 -mavx -mmove-max=256 -mstore-max=256 -fno-stack-protector" } */
|
||||
/* { dg-final { scan-assembler-times {(?n)vptest.*ymm} 1 } } */
|
||||
/* { dg-final { scan-assembler-times {sete} 1 } } */
|
||||
/* { dg-final { scan-assembler-not {(?n)je.*L[0-9]} } } */
|
||||
diff --git a/gcc/testsuite/gcc.target/i386/pr69482-1.c b/gcc/testsuite/gcc.target/i386/pr69482-1.c
|
||||
index f192261b104..99bb6ad5a37 100644
|
||||
--- a/gcc/testsuite/gcc.target/i386/pr69482-1.c
|
||||
+++ b/gcc/testsuite/gcc.target/i386/pr69482-1.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/* { dg-do compile } */
|
||||
-/* { dg-options "-O3" } */
|
||||
+/* { dg-options "-O3 -fno-stack-protector" } */
|
||||
|
||||
static inline void memset_s(void* s, int n) {
|
||||
volatile unsigned char * p = s;
|
||||
|
||||
base-commit: 070a6bf0bdc6761ad77ac97404c98f00a7007d54
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,94 +0,0 @@
|
||||
From 2ef902063590ebd7e8b8b8b4d708f6c7dc62a81d Mon Sep 17 00:00:00 2001
|
||||
From: Marek Polacek <polacek@redhat.com>
|
||||
Date: Thu, 29 Jun 2023 14:57:48 -0400
|
||||
Subject: [PATCH] testsuite: Use -fno-report-bug in gcc.dg/plugin/
|
||||
|
||||
Certain downstream compilers (for example, in Fedora) default to
|
||||
-freport-bug. The extra output breaks the following tests. We can use
|
||||
-fno-report-bug to fix that. Patch verified with:
|
||||
|
||||
$ make check RUNTESTFLAGS='--target_board=unix\{,-freport-bug\} plugin.exp'
|
||||
|
||||
Tested x86_64-pc-linux-gnu, ok for trunk/13?
|
||||
|
||||
gcc/testsuite/ChangeLog:
|
||||
|
||||
* gcc.dg/plugin/crash-test-ice-sarif.c: Use -fno-report-bug. Adjust
|
||||
scan-sarif-file.
|
||||
* gcc.dg/plugin/crash-test-ice-stderr.c: Use -fno-report-bug.
|
||||
* gcc.dg/plugin/crash-test-write-though-null-sarif.c: Use
|
||||
-fno-report-bug. Adjust scan-sarif-file.
|
||||
* gcc.dg/plugin/crash-test-write-though-null-stderr.c: Use
|
||||
-fno-report-bug.
|
||||
---
|
||||
gcc/testsuite/gcc.dg/plugin/crash-test-ice-sarif.c | 3 ++-
|
||||
gcc/testsuite/gcc.dg/plugin/crash-test-ice-stderr.c | 1 +
|
||||
.../gcc.dg/plugin/crash-test-write-though-null-sarif.c | 3 ++-
|
||||
.../gcc.dg/plugin/crash-test-write-though-null-stderr.c | 1 +
|
||||
4 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gcc/testsuite/gcc.dg/plugin/crash-test-ice-sarif.c b/gcc/testsuite/gcc.dg/plugin/crash-test-ice-sarif.c
|
||||
index 3b773a9a84c..84a4347a17e 100644
|
||||
--- a/gcc/testsuite/gcc.dg/plugin/crash-test-ice-sarif.c
|
||||
+++ b/gcc/testsuite/gcc.dg/plugin/crash-test-ice-sarif.c
|
||||
@@ -1,5 +1,6 @@
|
||||
/* { dg-do compile } */
|
||||
/* { dg-options "-fdiagnostics-format=sarif-file" } */
|
||||
+/* { dg-additional-options "-fno-report-bug" } */
|
||||
|
||||
extern void inject_ice (void);
|
||||
|
||||
@@ -56,7 +57,7 @@ void test_inject_ice (void)
|
||||
{ dg-final { scan-sarif-file "\"contextRegion\": " } }
|
||||
{ dg-final { scan-sarif-file "\"artifactLocation\": " } }
|
||||
{ dg-final { scan-sarif-file "\"region\": " } }
|
||||
- { dg-final { scan-sarif-file "\"startLine\": 8" } }
|
||||
+ { dg-final { scan-sarif-file "\"startLine\": 9" } }
|
||||
{ dg-final { scan-sarif-file "\"startColumn\": 3" } }
|
||||
{ dg-final { scan-sarif-file "\"endColumn\": 16" } }
|
||||
{ dg-final { scan-sarif-file "\"message\": " } }
|
||||
diff --git a/gcc/testsuite/gcc.dg/plugin/crash-test-ice-stderr.c b/gcc/testsuite/gcc.dg/plugin/crash-test-ice-stderr.c
|
||||
index cee701b135c..0064d3bc447 100644
|
||||
--- a/gcc/testsuite/gcc.dg/plugin/crash-test-ice-stderr.c
|
||||
+++ b/gcc/testsuite/gcc.dg/plugin/crash-test-ice-stderr.c
|
||||
@@ -1,4 +1,5 @@
|
||||
/* { dg-do compile } */
|
||||
+/* { dg-additional-options "-fno-report-bug" } */
|
||||
|
||||
extern void inject_ice (void);
|
||||
|
||||
diff --git a/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-sarif.c b/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-sarif.c
|
||||
index 57caa20155f..83b38d2ffb5 100644
|
||||
--- a/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-sarif.c
|
||||
+++ b/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-sarif.c
|
||||
@@ -1,5 +1,6 @@
|
||||
/* { dg-do compile } */
|
||||
/* { dg-options "-fdiagnostics-format=sarif-file" } */
|
||||
+/* { dg-additional-options "-fno-report-bug" } */
|
||||
|
||||
extern void inject_write_through_null (void);
|
||||
|
||||
@@ -56,7 +57,7 @@ void test_inject_write_through_null (void)
|
||||
{ dg-final { scan-sarif-file "\"contextRegion\": " } }
|
||||
{ dg-final { scan-sarif-file "\"artifactLocation\": " } }
|
||||
{ dg-final { scan-sarif-file "\"region\": " } }
|
||||
- { dg-final { scan-sarif-file "\"startLine\": 8" } }
|
||||
+ { dg-final { scan-sarif-file "\"startLine\": 9" } }
|
||||
{ dg-final { scan-sarif-file "\"startColumn\": 3" } }
|
||||
{ dg-final { scan-sarif-file "\"endColumn\": 31" } }
|
||||
{ dg-final { scan-sarif-file "\"message\": " } }
|
||||
diff --git a/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-stderr.c b/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-stderr.c
|
||||
index 7b43e423633..a9a211a3b1f 100644
|
||||
--- a/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-stderr.c
|
||||
+++ b/gcc/testsuite/gcc.dg/plugin/crash-test-write-though-null-stderr.c
|
||||
@@ -1,4 +1,5 @@
|
||||
/* { dg-do compile } */
|
||||
+/* { dg-additional-options "-fno-report-bug" } */
|
||||
|
||||
extern void inject_write_through_null (void);
|
||||
|
||||
|
||||
base-commit: 070a6bf0bdc6761ad77ac97404c98f00a7007d54
|
||||
--
|
||||
2.41.0
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.1.1-20230614.tar.xz) = 47deb22e3025f469cd54f60fd64cab91dd9bdc044224a2e913577d663f6218e8e7eaaf755a25e1e208c2f9a454bf657fcd2cb1b483c86805340b7fa65bcb2301
|
||||
SHA512 (gcc-13.2.1-20231113.tar.xz) = d5897c4dc4a223f20ffbbefe1c59077c5680fcb7287c97d9a84d4c25712dc02e4eb91aa3a14e3ae79b9a986d14bdeff1b93489ae9741053e0b069c42f52fe934
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz) = c719fad8689b2b6f3c888d0308604ddef884037d71ec3e755c68052d30075a181c29358fda516833ace437921b17602b147be7886317be94ec9736faa8cb52be
|
||||
SHA512 (nvptx-tools-aa3404ad5a496cda5d79a50bedb1344fd63e8763.tar.xz) = 33a024326426375533cb5dd9b68b2508f37540be418d2506bfa19a5f5866485e9af150469064e9059b68136ad8cb080b3b12e7eb5c6b7d1288cf6bfb3f6bb5d0
|
||||
|
Loading…
Reference in New Issue
Block a user