parent
3c25766354
commit
24ccb29592
7
gcc.spec
7
gcc.spec
@ -195,11 +195,8 @@ URL: http://gcc.gnu.org
|
|||||||
# Need binutils which support -plugin
|
# Need binutils which support -plugin
|
||||||
# Need binutils which support .loc view >= 2.30
|
# Need binutils which support .loc view >= 2.30
|
||||||
# Need binutils which support --generate-missing-build-notes=yes >= 2.31
|
# Need binutils which support --generate-missing-build-notes=yes >= 2.31
|
||||||
%if 0%{?scl:1}
|
BuildRequires: %{?scl_prefix}binutils >= 2.31
|
||||||
# FIXME XXX
|
BuildRequires: %{?scl_prefix}gdb >= 7.4.50
|
||||||
#BuildRequires: %{?scl_prefix}binutils >= 2.31
|
|
||||||
#BuildRequires: %{?scl_prefix}gdb >= 7.4.50
|
|
||||||
%endif
|
|
||||||
# While gcc doesn't include statically linked binaries, during testing
|
# While gcc doesn't include statically linked binaries, during testing
|
||||||
# -static is used several times.
|
# -static is used several times.
|
||||||
BuildRequires: glibc-static
|
BuildRequires: glibc-static
|
||||||
|
@ -8535,7 +8535,7 @@
|
|||||||
+#include "../c++20/sstream-inst.cc"
|
+#include "../c++20/sstream-inst.cc"
|
||||||
--- libstdc++-v3/src/nonshared20/sstream-inst80.cc.jj 2023-05-19 12:22:56.772881680 +0200
|
--- libstdc++-v3/src/nonshared20/sstream-inst80.cc.jj 2023-05-19 12:22:56.772881680 +0200
|
||||||
+++ libstdc++-v3/src/nonshared20/sstream-inst80.cc 2023-05-19 19:36:15.480300978 +0200
|
+++ libstdc++-v3/src/nonshared20/sstream-inst80.cc 2023-05-19 19:36:15.480300978 +0200
|
||||||
@@ -0,0 +1,34 @@
|
@@ -0,0 +1,36 @@
|
||||||
+// Copyright (C) 2012-2023 Free Software Foundation, Inc.
|
+// Copyright (C) 2012-2023 Free Software Foundation, Inc.
|
||||||
+//
|
+//
|
||||||
+// This file is part of the GNU ISO C++ Library. This library is free
|
+// This file is part of the GNU ISO C++ Library. This library is free
|
||||||
@ -8569,7 +8569,9 @@
|
|||||||
+#endif
|
+#endif
|
||||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE10_M_disposeEv");
|
+asm (".hidden _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE10_M_disposeEv");
|
||||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEE10_M_disposeEv");
|
+asm (".hidden _ZNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEE10_M_disposeEv");
|
||||||
|
+#if defined(__x86_64__)
|
||||||
+asm (".hidden _ZNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEE9_M_mutateEmmPKwm");
|
+asm (".hidden _ZNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEE9_M_mutateEmmPKwm");
|
||||||
|
+#endif
|
||||||
--- libstdc++-v3/src/nonshared20/tzdb.cc.jj 2023-05-19 14:48:48.951405987 +0200
|
--- libstdc++-v3/src/nonshared20/tzdb.cc.jj 2023-05-19 14:48:48.951405987 +0200
|
||||||
+++ libstdc++-v3/src/nonshared20/tzdb.cc 2023-05-19 20:27:30.804879166 +0200
|
+++ libstdc++-v3/src/nonshared20/tzdb.cc 2023-05-19 20:27:30.804879166 +0200
|
||||||
@@ -0,0 +1,89 @@
|
@@ -0,0 +1,89 @@
|
||||||
|
Loading…
Reference in New Issue
Block a user