- gc-7.1
- purge rpaths
This commit is contained in:
parent
d789135fe6
commit
a3347b0cb9
@ -1,3 +1 @@
|
|||||||
clog
|
gc-7.1.tar.gz
|
||||||
gc6.8.tar.gz
|
|
||||||
gc-7.0.tar.gz
|
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
diff -up /dev/null gc-7.0/include/extra/gc.h
|
|
||||||
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
|
||||||
+++ gc-7.0/include/extra/gc.h 2007-08-29 10:56:16.000000000 -0500
|
|
||||||
@@ -0,0 +1,2 @@
|
|
||||||
+/* This file is installed for backward compatibility. */
|
|
||||||
+#include <gc/gc.h>
|
|
||||||
diff -up /dev/null gc-7.0/include/extra/gc_cpp.h
|
|
||||||
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
|
||||||
+++ gc-7.0/include/extra/gc_cpp.h 2007-08-29 10:56:16.000000000 -0500
|
|
||||||
@@ -0,0 +1,2 @@
|
|
||||||
+/* This file is installed for backward compatibility. */
|
|
||||||
+#include <gc/gc_cpp.h>
|
|
||||||
diff -up gc-7.0/include/include.am.compat_header gc-7.0/include/include.am
|
|
||||||
--- gc-7.0/include/include.am.compat_header 2005-10-10 17:33:34.000000000 -0500
|
|
||||||
+++ gc-7.0/include/include.am 2007-08-29 10:56:16.000000000 -0500
|
|
||||||
@@ -52,3 +52,9 @@ dist_noinst_HEADERS += \
|
|
||||||
include/cord.h \
|
|
||||||
include/ec.h \
|
|
||||||
include/javaxfc.h
|
|
||||||
+
|
|
||||||
+# unprefixed header
|
|
||||||
+include_HEADERS += \
|
|
||||||
+ include/extra/gc.h \
|
|
||||||
+ include/extra/gc_cpp.h
|
|
||||||
+
|
|
||||||
diff -up gc-7.0/Makefile.in.compat_header gc-7.0/Makefile.in
|
|
||||||
--- gc-7.0/Makefile.in.compat_header 2007-06-28 16:12:36.000000000 -0500
|
|
||||||
+++ gc-7.0/Makefile.in 2007-08-29 10:58:17.000000000 -0500
|
|
||||||
@@ -462,7 +462,10 @@ EXTRA_DIST = gc_cpp.cpp README.QUICK BCC
|
|
||||||
# C Library
|
|
||||||
# ---------
|
|
||||||
lib_LTLIBRARIES = libgc.la $(am__append_4) libcord.la
|
|
||||||
-include_HEADERS =
|
|
||||||
+# unprefixed header
|
|
||||||
+include_HEADERS = \
|
|
||||||
+ include/extra/gc.h \
|
|
||||||
+ include/extra/gc_cpp.h
|
|
||||||
|
|
||||||
# installed headers
|
|
||||||
#
|
|
@ -1,9 +0,0 @@
|
|||||||
diff -up gc-7.0/bdw-gc.pc.in.includedir gc-7.0/bdw-gc.pc.in
|
|
||||||
--- gc-7.0/bdw-gc.pc.in.includedir 2005-10-10 17:33:34.000000000 -0500
|
|
||||||
+++ gc-7.0/bdw-gc.pc.in 2007-08-21 16:20:53.000000000 -0500
|
|
||||||
@@ -7,4 +7,4 @@ Name: Boehm-Demers-Weiser Conservative G
|
|
||||||
Description: A garbage collector for C and C++
|
|
||||||
Version: @PACKAGE_VERSION@
|
|
||||||
Libs: -L${libdir} -lgc
|
|
||||||
-Cflags: -I${includedir}
|
|
||||||
+Cflags: -I${includedir}/gc
|
|
18
gc.spec
18
gc.spec
@ -1,9 +1,9 @@
|
|||||||
|
|
||||||
Summary: A garbage collector for C and C++
|
Summary: A garbage collector for C and C++
|
||||||
Name: gc
|
Name: gc
|
||||||
Version: 7.0
|
Version: 7.1
|
||||||
|
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
||||||
@ -11,10 +11,8 @@ Source0: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-%{version}.ta
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: gc-7.0-gcinit.patch
|
Patch1: gc-7.0-gcinit.patch
|
||||||
# http://www.hpl.hp.com/hosted/linux/mail-archives/gc/2007-August/001838.html
|
|
||||||
Patch2: gc-7.0-compat_header.patch
|
|
||||||
|
|
||||||
BuildRequires: gawk
|
BuildRequires: automake libtool
|
||||||
|
|
||||||
# rpmforge compatibility
|
# rpmforge compatibility
|
||||||
Obsoletes: libgc < %{version}-%{release}
|
Obsoletes: libgc < %{version}-%{release}
|
||||||
@ -39,7 +37,11 @@ Provides: libgc-devel = %{version}-%{release}
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .gcinit
|
%patch1 -p1 -b .gcinit
|
||||||
%patch2 -p1 -b .compat_header
|
|
||||||
|
# refresh auto*/libtool to purge rpaths
|
||||||
|
rm -f libtool libtool.m4
|
||||||
|
libtoolize --force
|
||||||
|
autoreconf -i
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -99,6 +101,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun May 04 2008 Rex Dieter <rdieter@fedoraproject.org> 7.1-1
|
||||||
|
- gc-7.1
|
||||||
|
- purge rpaths
|
||||||
|
|
||||||
* Fri Feb 08 2008 Rex Dieter <rdieter@fedoraproject.org> 7.0-7
|
* Fri Feb 08 2008 Rex Dieter <rdieter@fedoraproject.org> 7.0-7
|
||||||
- respin (gcc43)
|
- respin (gcc43)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user