6946bd5e11
- fixup compat_header patch to avoid needing auto* tools
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
diff -up /dev/null gc-7.0/include/extra/gc.h
|
|
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
|
+++ gc-7.0/include/extra/gc.h 2007-08-29 10:56:16.000000000 -0500
|
|
@@ -0,0 +1,2 @@
|
|
+/* This file is installed for backward compatibility. */
|
|
+#include <gc/gc.h>
|
|
diff -up /dev/null gc-7.0/include/extra/gc_cpp.h
|
|
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
|
+++ gc-7.0/include/extra/gc_cpp.h 2007-08-29 10:56:16.000000000 -0500
|
|
@@ -0,0 +1,2 @@
|
|
+/* This file is installed for backward compatibility. */
|
|
+#include <gc/gc_cpp.h>
|
|
diff -up gc-7.0/include/include.am.compat_header gc-7.0/include/include.am
|
|
--- gc-7.0/include/include.am.compat_header 2005-10-10 17:33:34.000000000 -0500
|
|
+++ gc-7.0/include/include.am 2007-08-29 10:56:16.000000000 -0500
|
|
@@ -52,3 +52,9 @@ dist_noinst_HEADERS += \
|
|
include/cord.h \
|
|
include/ec.h \
|
|
include/javaxfc.h
|
|
+
|
|
+# unprefixed header
|
|
+include_HEADERS += \
|
|
+ include/extra/gc.h \
|
|
+ include/extra/gc_cpp.h
|
|
+
|
|
diff -up gc-7.0/Makefile.in.compat_header gc-7.0/Makefile.in
|
|
--- gc-7.0/Makefile.in.compat_header 2007-06-28 16:12:36.000000000 -0500
|
|
+++ gc-7.0/Makefile.in 2007-08-29 10:58:17.000000000 -0500
|
|
@@ -462,7 +462,10 @@ EXTRA_DIST = gc_cpp.cpp README.QUICK BCC
|
|
# C Library
|
|
# ---------
|
|
lib_LTLIBRARIES = libgc.la $(am__append_4) libcord.la
|
|
-include_HEADERS =
|
|
+# unprefixed header
|
|
+include_HEADERS = \
|
|
+ include/extra/gc.h \
|
|
+ include/extra/gc_cpp.h
|
|
|
|
# installed headers
|
|
#
|