ca7a30385c
- Resolves: #299551 - Add gawk-3.1.5-test-lc_num1.patch, a test for that bug. - BuldRequire autoconf and automake, for the test patch. - Add coment explaining why bison is buildrequired. - Remove BuildRequire: flex.
56 lines
1.9 KiB
Diff
56 lines
1.9 KiB
Diff
--- test/Makefile.am.ulitest 2005-07-26 20:07:43.000000000 +0200
|
|
+++ test/Makefile.am 2007-09-27 10:48:51.000000000 +0200
|
|
@@ -273,6 +273,8 @@
|
|
intprec.ok \
|
|
iobug1.awk \
|
|
iobug1.ok \
|
|
+ lc_num1.awk \
|
|
+ lc_num1.ok \
|
|
leaddig.awk \
|
|
leaddig.ok \
|
|
leadnl.awk \
|
|
@@ -588,7 +590,7 @@
|
|
fordel forsimp fsbs fsspcoln fsrs fstabplus funsemnl funsmnam funstack getline \
|
|
getline2 getline3 getlnbuf getnr2tb getnr2tm gsubasgn gsubtest \
|
|
gsubtst2 gsubtst3 gsubtst4 gsubtst5 hex hsprint inputred intest \
|
|
- intprec iobug1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
|
+ intprec iobug1 lc_num1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
|
messages minusstr mmap8k nasty nasty2 negexp nested nfldstr \
|
|
nfneg nfset nlfldsep nlinstr nlstrina noeffect nofmtch noloop1 \
|
|
noloop2 nonl noparms nors nulrsend numindex numsubstr octsub ofmt \
|
|
@@ -678,6 +680,12 @@
|
|
extend-msg-end:
|
|
@echo "======== Done with gawk extension tests ========"
|
|
|
|
+lc_num1:
|
|
+ @echo $@
|
|
+ @[ -z "$$GAWKLOCALE" ] && GAWKLOCALE=en_US.UTF-8; \
|
|
+ AWKPATH=$(srcdir) $(AWK) --posix -f $@.awk >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
|
|
+ @-$(CMP) $(srcdir)/$@.ok _$@ && rm -f _$@
|
|
+
|
|
|
|
# This test is a PITA because increasingly, /tmp is getting
|
|
# mounted noexec. So, we'll test it locally. Sigh.
|
|
--- /dev/null 1970-01-01 00:00:00 +0000
|
|
+++ test/lc_num1.ok 2007-09-27 10:47:26.000000000 +0200
|
|
@@ -0,0 +1 @@
|
|
+1,000,000 1000000
|
|
--- /dev/null 1970-01-01 00:00:00 +0000
|
|
+++ test/lc_num1.awk 2007-09-27 10:47:26.000000000 +0200
|
|
@@ -0,0 +1,4 @@
|
|
+# Bug reported by Ulrich Drepper.
|
|
+BEGIN {
|
|
+ printf("%'d %d\n", 1000000, 1000000)
|
|
+}
|
|
--- test/Gentests.ulitest 2005-05-11 17:28:17.000000000 +0200
|
|
+++ test/Gentests 2007-09-27 10:47:26.000000000 +0200
|
|
@@ -36,7 +36,7 @@
|
|
next
|
|
}
|
|
|
|
-/^[a-zA-Z][a-zA-Z0-9]*:/ {
|
|
+/^[a-zA-Z_][a-zA-Z0-9_]*:/ {
|
|
# remember all targets from Makefile.am
|
|
sub(/:.*/,"")
|
|
targets[$0]
|