- Add gawk-3.1.5-quote-sticky.patch
- Resolves: #299551 - Add gawk-3.1.5-test-lc_num1.patch, a test for that bug. - BuldRequire autoconf and automake, for the test patch. - Add coment explaining why bison is buildrequired. - Remove BuildRequire: flex.
This commit is contained in:
parent
04c8579739
commit
ca7a30385c
18
gawk-3.1.5-quote-sticky.patch
Normal file
18
gawk-3.1.5-quote-sticky.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Written-by: Ulrich Drepper
|
||||
|
||||
Index: builtin.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/gawk/gawk-stable/builtin.c,v
|
||||
retrieving revision 1.17
|
||||
retrieving revision 1.18
|
||||
diff -u -r1.17 -r1.18
|
||||
--- builtin.c 11 Aug 2007 19:49:23 -0000 1.17
|
||||
+++ builtin.c 22 Sep 2007 21:34:34 -0000 1.18
|
||||
@@ -724,6 +724,7 @@
|
||||
have_prec = FALSE;
|
||||
signchar = FALSE;
|
||||
zero_flag = FALSE;
|
||||
+ quote_flag = FALSE;
|
||||
lj = alt = big = bigbig = small = FALSE;
|
||||
fill = sp;
|
||||
cp = cend;
|
55
gawk-3.1.5-test-lc_num1.patch
Normal file
55
gawk-3.1.5-test-lc_num1.patch
Normal file
@ -0,0 +1,55 @@
|
||||
--- test/Makefile.am.ulitest 2005-07-26 20:07:43.000000000 +0200
|
||||
+++ test/Makefile.am 2007-09-27 10:48:51.000000000 +0200
|
||||
@@ -273,6 +273,8 @@
|
||||
intprec.ok \
|
||||
iobug1.awk \
|
||||
iobug1.ok \
|
||||
+ lc_num1.awk \
|
||||
+ lc_num1.ok \
|
||||
leaddig.awk \
|
||||
leaddig.ok \
|
||||
leadnl.awk \
|
||||
@@ -588,7 +590,7 @@
|
||||
fordel forsimp fsbs fsspcoln fsrs fstabplus funsemnl funsmnam funstack getline \
|
||||
getline2 getline3 getlnbuf getnr2tb getnr2tm gsubasgn gsubtest \
|
||||
gsubtst2 gsubtst3 gsubtst4 gsubtst5 hex hsprint inputred intest \
|
||||
- intprec iobug1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
||||
+ intprec iobug1 lc_num1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
||||
messages minusstr mmap8k nasty nasty2 negexp nested nfldstr \
|
||||
nfneg nfset nlfldsep nlinstr nlstrina noeffect nofmtch noloop1 \
|
||||
noloop2 nonl noparms nors nulrsend numindex numsubstr octsub ofmt \
|
||||
@@ -678,6 +680,12 @@
|
||||
extend-msg-end:
|
||||
@echo "======== Done with gawk extension tests ========"
|
||||
|
||||
+lc_num1:
|
||||
+ @echo $@
|
||||
+ @[ -z "$$GAWKLOCALE" ] && GAWKLOCALE=en_US.UTF-8; \
|
||||
+ AWKPATH=$(srcdir) $(AWK) --posix -f $@.awk >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
|
||||
+ @-$(CMP) $(srcdir)/$@.ok _$@ && rm -f _$@
|
||||
+
|
||||
|
||||
# This test is a PITA because increasingly, /tmp is getting
|
||||
# mounted noexec. So, we'll test it locally. Sigh.
|
||||
--- /dev/null 1970-01-01 00:00:00 +0000
|
||||
+++ test/lc_num1.ok 2007-09-27 10:47:26.000000000 +0200
|
||||
@@ -0,0 +1 @@
|
||||
+1,000,000 1000000
|
||||
--- /dev/null 1970-01-01 00:00:00 +0000
|
||||
+++ test/lc_num1.awk 2007-09-27 10:47:26.000000000 +0200
|
||||
@@ -0,0 +1,4 @@
|
||||
+# Bug reported by Ulrich Drepper.
|
||||
+BEGIN {
|
||||
+ printf("%'d %d\n", 1000000, 1000000)
|
||||
+}
|
||||
--- test/Gentests.ulitest 2005-05-11 17:28:17.000000000 +0200
|
||||
+++ test/Gentests 2007-09-27 10:47:26.000000000 +0200
|
||||
@@ -36,7 +36,7 @@
|
||||
next
|
||||
}
|
||||
|
||||
-/^[a-zA-Z][a-zA-Z0-9]*:/ {
|
||||
+/^[a-zA-Z_][a-zA-Z0-9_]*:/ {
|
||||
# remember all targets from Makefile.am
|
||||
sub(/:.*/,"")
|
||||
targets[$0]
|
25
gawk.spec
25
gawk.spec
@ -1,7 +1,7 @@
|
||||
Summary: The GNU version of the awk text processing utility
|
||||
Name: gawk
|
||||
Version: 3.1.5
|
||||
Release: 15%{?dist}
|
||||
Release: 16%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/Text
|
||||
URL: http://www.gnu.org/software/gawk/gawk.html
|
||||
@ -12,8 +12,12 @@ Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Requires: /bin/mktemp
|
||||
|
||||
BuildRequires: flex
|
||||
# needed for gawk-3.1.5-syntaxerror.patch:
|
||||
BuildRequires: bison
|
||||
# Seems currently unused:
|
||||
#BuildRequires: flex
|
||||
# for patch14:
|
||||
BuildRequires: autoconf automake
|
||||
|
||||
Patch1: gawk-3.1.3-getpgrp_void.patch
|
||||
Patch2: gawk-3.1.5-free.patch
|
||||
@ -33,6 +37,9 @@ Patch10: gawk-3.1.5-ipv6.patch
|
||||
Patch11: gawk-3.1.5-freewstr.patch
|
||||
# upstream patch - Invalid read of size 4
|
||||
Patch12: gawk-3.1.5-mbread.patch
|
||||
# bug #299551 - quote flag is sticky
|
||||
Patch13: gawk-3.1.5-quote-sticky.patch
|
||||
Patch14: gawk-3.1.5-test-lc_num1.patch
|
||||
|
||||
%description
|
||||
The gawk package contains the GNU version of awk, a text processing
|
||||
@ -56,8 +63,12 @@ considered to be a standard Linux tool for processing text.
|
||||
%patch10 -p1 -b .ipv6
|
||||
%patch11 -p1 -b .freewstr
|
||||
%patch12 -p1 -b .mbread
|
||||
%patch13 -p0 -b .uli
|
||||
%patch14 -p0 -b .ulitest
|
||||
|
||||
%build
|
||||
# for patch14:
|
||||
autoreconf
|
||||
%configure --bindir=/bin
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -73,6 +84,8 @@ ln -sf gawk.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/awk.1.gz
|
||||
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/awk
|
||||
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/gawk
|
||||
rm -f $RPM_BUILD_ROOT/bin/{,p}gawk-%{version}
|
||||
# FIXME: enable this at a suitable point of time:
|
||||
#mv $RPM_BUILD_ROOT/bin/{p,i}gawk $RPM_BUILD_ROOT%{_bindir}
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
@ -104,6 +117,14 @@ fi
|
||||
%{_datadir}/awk
|
||||
|
||||
%changelog
|
||||
* Wed Oct 31 2007 Stepan Kasal <skasal@redhat.com> - 3.1.5-16
|
||||
- Add gawk-3.1.5-quote-sticky.patch
|
||||
- Resolves: #299551
|
||||
- Add gawk-3.1.5-test-lc_num1.patch, a test for that bug.
|
||||
- BuldRequire autoconf and automake, for the test patch.
|
||||
- Add coment explaining why bison is buildrequired.
|
||||
- Remove BuildRequire: flex.
|
||||
|
||||
* Mon Feb 12 2007 Karel Zak <kzak@redhat.com> 3.1.5-15
|
||||
- fix #225777 - clean up spec file according to Fedora Merge Review
|
||||
suggestions (thanks to Dan Horak and Patrice Dumas)
|
||||
|
Loading…
Reference in New Issue
Block a user