- remove the versioned binaries even if the version is modified by the
snapshot patch, modify the file list to check this (#476166) - update the snapshot patch, dropping the upstreamed gawk-3.1.5-test-lc_num1.patch
This commit is contained in:
parent
cf9db2b005
commit
80b061ab89
@ -1,55 +0,0 @@
|
|||||||
--- test/Makefile.am.ulitest 2008-12-11 11:59:23.000000000 +0100
|
|
||||||
+++ test/Makefile.am 2008-12-11 12:00:34.000000000 +0100
|
|
||||||
@@ -307,6 +307,8 @@ EXTRA_DIST = \
|
|
||||||
intprec.ok \
|
|
||||||
iobug1.awk \
|
|
||||||
iobug1.ok \
|
|
||||||
+ lc_num1.awk \
|
|
||||||
+ lc_num1.ok \
|
|
||||||
leaddig.awk \
|
|
||||||
leaddig.ok \
|
|
||||||
leadnl.awk \
|
|
||||||
@@ -676,7 +678,7 @@ BASIC_TESTS = addcomma anchgsub argarray
|
|
||||||
fordel forsimp fsbs fsspcoln fsrs fstabplus funsemnl funsmnam funstack getline \
|
|
||||||
getline2 getline3 getlnbuf getnr2tb getnr2tm gsubasgn gsubtest \
|
|
||||||
gsubtst2 gsubtst3 gsubtst4 gsubtst5 gsubtst6 hex hsprint inputred intest intformat \
|
|
||||||
- intprec iobug1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
|
||||||
+ intprec iobug1 lc_num1 leaddig leadnl litoct longsub longwrds manglprm math membug1 \
|
|
||||||
messages minusstr mmap8k mtchi18n nasty nasty2 negexp nested nfldstr \
|
|
||||||
nfneg nfset nlfldsep nlinstr nlstrina noeffect nofile nofmtch noloop1 \
|
|
||||||
noloop2 nonl noparms nors nulrsend numindex numsubstr octsub ofmt \
|
|
||||||
@@ -774,6 +776,12 @@ extend-msg-start:
|
|
||||||
extend-msg-end:
|
|
||||||
@echo "======== Done with gawk extension tests ========"
|
|
||||||
|
|
||||||
+lc_num1:
|
|
||||||
+ @echo $@
|
|
||||||
+ @[ -z "$$GAWKLOCALE" ] && GAWKLOCALE=en_US.UTF-8; \
|
|
||||||
+ AWKPATH=$(srcdir) $(AWK) --posix -f $@.awk >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
|
|
||||||
+ @-$(CMP) $(srcdir)/$@.ok _$@ && rm -f _$@
|
|
||||||
+
|
|
||||||
|
|
||||||
# This test is a PITA because increasingly, /tmp is getting
|
|
||||||
# mounted noexec. So, we'll test it locally. Sigh.
|
|
||||||
--- /dev/null 1970-01-01 00:00:00 +0000
|
|
||||||
+++ test/lc_num1.ok 2007-09-27 10:47:26.000000000 +0200
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+1,000,000 1000000
|
|
||||||
--- /dev/null 1970-01-01 00:00:00 +0000
|
|
||||||
+++ test/lc_num1.awk 2007-09-27 10:47:26.000000000 +0200
|
|
||||||
@@ -0,0 +1,4 @@
|
|
||||||
+# Bug reported by Ulrich Drepper.
|
|
||||||
+BEGIN {
|
|
||||||
+ printf("%'d %d\n", 1000000, 1000000)
|
|
||||||
+}
|
|
||||||
--- test/Gentests.ulitest 2005-05-11 17:28:17.000000000 +0200
|
|
||||||
+++ test/Gentests 2007-09-27 10:47:26.000000000 +0200
|
|
||||||
@@ -45,7 +45,7 @@
|
|
||||||
next
|
|
||||||
}
|
|
||||||
|
|
||||||
-/^[a-zA-Z][a-zA-Z0-9]*:/ {
|
|
||||||
+/^[a-zA-Z_][a-zA-Z0-9_]*:/ {
|
|
||||||
# remember all targets from Makefile.am
|
|
||||||
sub(/:.*/,"")
|
|
||||||
targets[$0]
|
|
40293
gawk-stable-tree.patch
40293
gawk-stable-tree.patch
File diff suppressed because it is too large
Load Diff
22
gawk.spec
22
gawk.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The GNU version of the awk text processing utility
|
Summary: The GNU version of the awk text processing utility
|
||||||
Name: gawk
|
Name: gawk
|
||||||
Version: 3.1.6
|
Version: 3.1.6
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Text
|
Group: Applications/Text
|
||||||
URL: http://www.gnu.org/software/gawk/gawk.html
|
URL: http://www.gnu.org/software/gawk/gawk.html
|
||||||
@ -17,10 +17,6 @@ Requires: /bin/mktemp
|
|||||||
# patching the sources for these tools
|
# patching the sources for these tools
|
||||||
BuildRequires: autoconf automake gettext-devel texinfo bison
|
BuildRequires: autoconf automake gettext-devel texinfo bison
|
||||||
|
|
||||||
# test for #299551, submitted:
|
|
||||||
# http://lists.gnu.org/archive/html/bug-gnu-utils/2008-11/msg00044.html
|
|
||||||
Patch14: gawk-3.1.5-test-lc_num1.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The gawk package contains the GNU version of awk, a text processing
|
The gawk package contains the GNU version of awk, a text processing
|
||||||
utility. Awk interprets a special-purpose programming language to do
|
utility. Awk interprets a special-purpose programming language to do
|
||||||
@ -34,10 +30,9 @@ considered to be a standard Linux tool for processing text.
|
|||||||
mv libsigsegv-2.6 libsigsegv
|
mv libsigsegv-2.6 libsigsegv
|
||||||
# do not install with gawk
|
# do not install with gawk
|
||||||
echo 'install:' >>libsigsegv/Makefile.am
|
echo 'install:' >>libsigsegv/Makefile.am
|
||||||
%patch0
|
%patch0 -p1
|
||||||
# we have patched the sources for these:
|
# we have patched the sources for these:
|
||||||
rm awkgram.c doc/*.info
|
rm awkgram.c doc/*.info
|
||||||
%patch14 -b .ulitest
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf
|
autoreconf
|
||||||
@ -56,7 +51,8 @@ ln -sf gawk.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/awk.1.gz
|
|||||||
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/awk
|
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/awk
|
||||||
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/gawk
|
ln -sf ../../bin/gawk $RPM_BUILD_ROOT%{_bindir}/gawk
|
||||||
mv $RPM_BUILD_ROOT/bin/{p,i}gawk $RPM_BUILD_ROOT%{_bindir}
|
mv $RPM_BUILD_ROOT/bin/{p,i}gawk $RPM_BUILD_ROOT%{_bindir}
|
||||||
rm -f $RPM_BUILD_ROOT/bin/{,p}gawk-%{version} $RPM_BUILD_ROOT%{_infodir}/dir
|
# remove %{version}* , when we are building a snapshot...
|
||||||
|
rm -f $RPM_BUILD_ROOT/bin/{,p}gawk-%{version}* $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
|
||||||
%find_lang %name
|
%find_lang %name
|
||||||
|
|
||||||
@ -77,8 +73,8 @@ fi
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc README COPYING FUTURES LIMITATIONS NEWS
|
%doc README COPYING FUTURES LIMITATIONS NEWS
|
||||||
%doc README_d/README.multibyte README_d/README.tests POSIX.STD
|
%doc README_d/README.multibyte README_d/README.tests POSIX.STD
|
||||||
/bin/*
|
/bin/*awk
|
||||||
%{_bindir}/*
|
%{_bindir}/*awk
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%{_infodir}/gawk.info*
|
%{_infodir}/gawk.info*
|
||||||
%{_infodir}/gawkinet.info*
|
%{_infodir}/gawkinet.info*
|
||||||
@ -86,6 +82,12 @@ fi
|
|||||||
%{_datadir}/awk
|
%{_datadir}/awk
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 30 2009 Stepan Kasal <skasal@redhat.com> - 3.1.6-4
|
||||||
|
- remove the versioned binaries even if the version is modified by the
|
||||||
|
snapshot patch, modify the file list to check this (#476166)
|
||||||
|
- update the snapshot patch, dropping the upstreamed
|
||||||
|
gawk-3.1.5-test-lc_num1.patch
|
||||||
|
|
||||||
* Thu Dec 11 2008 Stepan Kasal <skasal@redhat.com> - 3.1.6-3
|
* Thu Dec 11 2008 Stepan Kasal <skasal@redhat.com> - 3.1.6-3
|
||||||
- grab the current stable tree from savannah
|
- grab the current stable tree from savannah
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user