import fwupd-1.7.9-1.el9
This commit is contained in:
parent
f3a6fa8e55
commit
7562c089b0
@ -4,5 +4,5 @@ a5f73c606abb93bf61625e4628d27a2cd460f162 SOURCES/DBXUpdate-20160809-x64.cab
|
||||
b5b2dc87daca1d3f8081a323290432c141aa405d SOURCES/DBXUpdate-20200729-aa64.cab
|
||||
3fb407561768a3a2f5fb49d7738b5e0650e70810 SOURCES/DBXUpdate-20200729-ia32.cab
|
||||
89db93c9d9d20f81791a262e817b99d8882c8bb0 SOURCES/DBXUpdate-20200729-x64.cab
|
||||
0ecfe80ec28ab7517765441b2f032de20e118ca9 SOURCES/fwupd-1.7.4.tar.xz
|
||||
3dd8f6ba4af65d5ecc304d57fb2453fa08d91199 SOURCES/fwupd-efi-1.1.tar.xz
|
||||
b2919819889051bcaa089a4b7e75e30ea2d80d68 SOURCES/fwupd-1.7.9.tar.xz
|
||||
1a586c3634ef190e6128351ee60fd17d0e584f7c SOURCES/fwupd-efi-1.3.tar.xz
|
||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -4,5 +4,5 @@ SOURCES/DBXUpdate-20160809-x64.cab
|
||||
SOURCES/DBXUpdate-20200729-aa64.cab
|
||||
SOURCES/DBXUpdate-20200729-ia32.cab
|
||||
SOURCES/DBXUpdate-20200729-x64.cab
|
||||
SOURCES/fwupd-1.7.4.tar.xz
|
||||
SOURCES/fwupd-efi-1.1.tar.xz
|
||||
SOURCES/fwupd-1.7.9.tar.xz
|
||||
SOURCES/fwupd-efi-1.3.tar.xz
|
||||
|
@ -1,58 +0,0 @@
|
||||
From e74d38bfd3097471fe60dbe843a68c16516a78da Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Mon, 17 Jan 2022 14:50:47 +0000
|
||||
Subject: [PATCH] Fix compiling with new versions of efivar
|
||||
|
||||
Fixes https://github.com/fwupd/fwupd/issues/4181
|
||||
---
|
||||
meson.build | 5 +++++
|
||||
plugins/uefi-capsule/fu-uefi-common.h | 3 +++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 833bdbf56..691cc8a58 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -412,6 +412,11 @@ endif
|
||||
if build_standalone and get_option('plugin_uefi_capsule')
|
||||
efiboot = dependency('efiboot')
|
||||
|
||||
+ efivar = dependency('efivar')
|
||||
+ if cc.has_header_symbol('efivar/efivar-types.h', 'efi_time_t', dependencies : efivar)
|
||||
+ conf.set('HAVE_EFI_TIME_T', '1')
|
||||
+ endif
|
||||
+
|
||||
efi_app_location = join_paths(libexecdir, 'fwupd', 'efi')
|
||||
conf.set_quoted('EFI_APP_LOCATION', efi_app_location)
|
||||
|
||||
diff --git a/plugins/uefi-capsule/fu-uefi-common.h b/plugins/uefi-capsule/fu-uefi-common.h
|
||||
index a21806d6b..1d616c9e0 100644
|
||||
--- a/plugins/uefi-capsule/fu-uefi-common.h
|
||||
+++ b/plugins/uefi-capsule/fu-uefi-common.h
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
#include <fwupdplugin.h>
|
||||
|
||||
+#include <efivar/efivar.h>
|
||||
#include <glib.h>
|
||||
|
||||
#define EFI_CAPSULE_HEADER_FLAGS_PERSIST_ACROSS_RESET 0x00010000
|
||||
@@ -17,6 +18,7 @@
|
||||
|
||||
#define EFI_OS_INDICATIONS_FILE_CAPSULE_DELIVERY_SUPPORTED 0x0000000000000004ULL
|
||||
|
||||
+#ifndef HAVE_EFI_TIME_T
|
||||
typedef struct __attribute__((__packed__)) {
|
||||
guint16 year;
|
||||
guint8 month;
|
||||
@@ -30,6 +32,7 @@ typedef struct __attribute__((__packed__)) {
|
||||
guint8 daylight;
|
||||
guint8 pad2;
|
||||
} efi_time_t;
|
||||
+#endif
|
||||
|
||||
typedef struct __attribute__((__packed__)) {
|
||||
fwupd_guid_t guid;
|
||||
--
|
||||
2.35.1
|
||||
|
@ -44,12 +44,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.7.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.7.9
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.1.tar.xz
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.3.tar.xz
|
||||
|
||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||
@ -65,9 +65,6 @@ Source301: redhatsecureboot301.cer
|
||||
Source500: redhatsecurebootca5.cer
|
||||
Source503: redhatsecureboot503.cer
|
||||
|
||||
# Backported from upstream
|
||||
Patch1: 0001-Fix-compiling-with-new-versions-of-efivar.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -77,7 +74,6 @@ BuildRequires: libgusb-devel >= %{libgusb_version}
|
||||
BuildRequires: libcurl-devel >= %{libcurl_version}
|
||||
BuildRequires: libjcat-devel >= %{libjcat_version}
|
||||
BuildRequires: polkit-devel >= 0.103
|
||||
BuildRequires: protobuf-c-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: systemd >= %{systemd_version}
|
||||
BuildRequires: systemd-devel
|
||||
@ -253,12 +249,14 @@ tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||
%else
|
||||
-Dplugin_modem_manager=false \
|
||||
%endif
|
||||
-Dplugin_logitech_bulkcontroller=false \
|
||||
-Dman=true \
|
||||
-Dbluez=false \
|
||||
-Dplugin_cfu=false \
|
||||
-Dplugin_mtd=false \
|
||||
-Dplugin_powerd=false \
|
||||
-Dplugin_uf2=false \
|
||||
-Dplugin_gpio=false \
|
||||
-Dsupported_build=true
|
||||
|
||||
%meson_build
|
||||
@ -350,8 +348,8 @@ done
|
||||
%{_sysconfdir}/pki/fwupd-metadata
|
||||
%if 0%{?have_msr}
|
||||
/usr/lib/modules-load.d/fwupd-msr.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/msr.conf
|
||||
%endif
|
||||
/usr/lib/modules-load.d/fwupd-redfish.conf
|
||||
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||
%{_datadir}/bash-completion/completions/fwupdtool
|
||||
@ -435,6 +433,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_ep963x.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_fastboot.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_fresco_pd.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_genesys.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_hailuck.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_iommu.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_jabra.so
|
||||
@ -460,6 +459,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_redfish.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_rts54hid.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_rts54hub.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_scsi.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_steelseries.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_superio.so
|
||||
%if 0%{?have_dell}
|
||||
@ -486,7 +486,6 @@ done
|
||||
%endif
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_usi_dock.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_logind.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_logitech_bulkcontroller.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_logitech_hidpp.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_upower.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_vli.so
|
||||
@ -538,9 +537,15 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Mar 31 2022 Richard Hughes <richard@hughsie.com> 1.7.4-2
|
||||
* Mon Jul 25 2022 Richard Hughes <richard@hughsie.com> 1.7.8-1
|
||||
- New upstream release
|
||||
- Resolves: rhbz#2059075
|
||||
|
||||
* Wed Apr 06 2022 Richard Hughes <richard@hughsie.com> 1.7.4-3
|
||||
- Disable the Logitech bulkcontroller plugin to avoid adding a dep to protobuf-c
|
||||
which lives in AppStream, not BaseOS.
|
||||
- Use the efi_vendor variable from EFI-RPM
|
||||
- Resolves: rhbz#2007520
|
||||
- Resolves: rhbz#2064904
|
||||
|
||||
* Thu Jan 13 2022 Richard Hughes <richard@hughsie.com> 1.7.4-1
|
||||
- New upstream release
|
||||
|
Loading…
Reference in New Issue
Block a user