import fwupd-1.7.4-2.el9_0

This commit is contained in:
CentOS Sources 2022-05-17 06:37:45 -04:00 committed by Stepan Oksanichenko
commit f3a6fa8e55
8 changed files with 1676 additions and 0 deletions

8
.fwupd.metadata Normal file
View File

@ -0,0 +1,8 @@
b2620c36bd23ca699567fd4e4add039ee4375247 SOURCES/DBXUpdate-20100307-x64.cab
dfdb1d0d42c1563ca63bd45c7e2ddc48cbfc5023 SOURCES/DBXUpdate-20140413-x64.cab
a5f73c606abb93bf61625e4628d27a2cd460f162 SOURCES/DBXUpdate-20160809-x64.cab
b5b2dc87daca1d3f8081a323290432c141aa405d SOURCES/DBXUpdate-20200729-aa64.cab
3fb407561768a3a2f5fb49d7738b5e0650e70810 SOURCES/DBXUpdate-20200729-ia32.cab
89db93c9d9d20f81791a262e817b99d8882c8bb0 SOURCES/DBXUpdate-20200729-x64.cab
0ecfe80ec28ab7517765441b2f032de20e118ca9 SOURCES/fwupd-1.7.4.tar.xz
3dd8f6ba4af65d5ecc304d57fb2453fa08d91199 SOURCES/fwupd-efi-1.1.tar.xz

8
.gitignore vendored Normal file
View File

@ -0,0 +1,8 @@
SOURCES/DBXUpdate-20100307-x64.cab
SOURCES/DBXUpdate-20140413-x64.cab
SOURCES/DBXUpdate-20160809-x64.cab
SOURCES/DBXUpdate-20200729-aa64.cab
SOURCES/DBXUpdate-20200729-ia32.cab
SOURCES/DBXUpdate-20200729-x64.cab
SOURCES/fwupd-1.7.4.tar.xz
SOURCES/fwupd-efi-1.1.tar.xz

View File

@ -0,0 +1,58 @@
From e74d38bfd3097471fe60dbe843a68c16516a78da Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Mon, 17 Jan 2022 14:50:47 +0000
Subject: [PATCH] Fix compiling with new versions of efivar
Fixes https://github.com/fwupd/fwupd/issues/4181
---
meson.build | 5 +++++
plugins/uefi-capsule/fu-uefi-common.h | 3 +++
2 files changed, 8 insertions(+)
diff --git a/meson.build b/meson.build
index 833bdbf56..691cc8a58 100644
--- a/meson.build
+++ b/meson.build
@@ -412,6 +412,11 @@ endif
if build_standalone and get_option('plugin_uefi_capsule')
efiboot = dependency('efiboot')
+ efivar = dependency('efivar')
+ if cc.has_header_symbol('efivar/efivar-types.h', 'efi_time_t', dependencies : efivar)
+ conf.set('HAVE_EFI_TIME_T', '1')
+ endif
+
efi_app_location = join_paths(libexecdir, 'fwupd', 'efi')
conf.set_quoted('EFI_APP_LOCATION', efi_app_location)
diff --git a/plugins/uefi-capsule/fu-uefi-common.h b/plugins/uefi-capsule/fu-uefi-common.h
index a21806d6b..1d616c9e0 100644
--- a/plugins/uefi-capsule/fu-uefi-common.h
+++ b/plugins/uefi-capsule/fu-uefi-common.h
@@ -9,6 +9,7 @@
#include <fwupdplugin.h>
+#include <efivar/efivar.h>
#include <glib.h>
#define EFI_CAPSULE_HEADER_FLAGS_PERSIST_ACROSS_RESET 0x00010000
@@ -17,6 +18,7 @@
#define EFI_OS_INDICATIONS_FILE_CAPSULE_DELIVERY_SUPPORTED 0x0000000000000004ULL
+#ifndef HAVE_EFI_TIME_T
typedef struct __attribute__((__packed__)) {
guint16 year;
guint8 month;
@@ -30,6 +32,7 @@ typedef struct __attribute__((__packed__)) {
guint8 daylight;
guint8 pad2;
} efi_time_t;
+#endif
typedef struct __attribute__((__packed__)) {
fwupd_guid_t guid;
--
2.35.1

Binary file not shown.

Binary file not shown.

Binary file not shown.

Binary file not shown.

1602
SPECS/fwupd.spec Normal file

File diff suppressed because it is too large Load Diff