New upstream release

This commit is contained in:
Richard Hughes 2023-12-04 13:02:33 +00:00 committed by root
parent 9b0489cc78
commit 71b1665d66
5 changed files with 47 additions and 55 deletions

1
.fwupd.metadata Normal file
View File

@ -0,0 +1 @@
c6c492b9acf3c741c8273c9b49db5400ae755e6b fwupd-1.9.10.tar.xz

1
.gitignore vendored
View File

@ -98,3 +98,4 @@
/DBXUpdate-20230509-aa64.cab /DBXUpdate-20230509-aa64.cab
/DBXUpdate-20230509-ia32.cab /DBXUpdate-20230509-ia32.cab
/DBXUpdate-20230509-x64.cab /DBXUpdate-20230509-x64.cab
/fwupd-1.9.10.tar.xz

View File

@ -0,0 +1,25 @@
From e887e1fd8a94fa0c65c7941acd5dfde6f6f8791c Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Mon, 4 Dec 2023 12:02:09 +0000
Subject: [PATCH] Do not check jcat.pc for supported engines
---
data/pki/meson.build | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/data/pki/meson.build b/data/pki/meson.build
index 58719cb7e..44e9840dd 100644
--- a/data/pki/meson.build
+++ b/data/pki/meson.build
@@ -1,6 +1,6 @@
# only install files that are going to be used
-supported_gpg = libjcat.get_variable(pkgconfig: 'supported_gpg', default_value: '0') == '1'
-supported_pkcs7 = libjcat.get_variable(pkgconfig: 'supported_pkcs7', default_value: '0') == '1' or host_machine.system() == 'windows'
+supported_gpg = true
+supported_pkcs7 = true
if supported_gpg
install_data([
--
2.43.0

View File

@ -36,11 +36,6 @@
%global have_msr 1 %global have_msr 1
%endif %endif
# libsmbios is only available on x86
%ifarch x86_64
%global have_dell 1
%endif
# Until we actually have seen it outside x86 # Until we actually have seen it outside x86
%ifarch i686 x86_64 %ifarch i686 x86_64
%global have_thunderbolt 1 %global have_thunderbolt 1
@ -53,7 +48,7 @@
Summary: Firmware update daemon Summary: Firmware update daemon
Name: fwupd Name: fwupd
Version: 1.8.16 Version: 1.9.10
Release: 1%{?dist} Release: 1%{?dist}
License: LGPLv2+ License: LGPLv2+
URL: https://github.com/fwupd/fwupd URL: https://github.com/fwupd/fwupd
@ -61,6 +56,7 @@ Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
Patch102: 0001-Do-not-check-jcat.pc-for-supported-engines.patch
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
@ -86,7 +82,6 @@ Source503: redhatsecureboot503.cer
BuildRequires: gettext BuildRequires: gettext
BuildRequires: glib2-devel >= %{glib2_version} BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: libxmlb-devel >= %{libxmlb_version} BuildRequires: libxmlb-devel >= %{libxmlb_version}
BuildRequires: libgcab1-devel
BuildRequires: libgudev1-devel BuildRequires: libgudev1-devel
BuildRequires: libgusb-devel >= %{libgusb_version} BuildRequires: libgusb-devel >= %{libgusb_version}
BuildRequires: libcurl-devel >= %{libcurl_version} BuildRequires: libcurl-devel >= %{libcurl_version}
@ -97,7 +92,6 @@ BuildRequires: systemd >= %{systemd_version}
BuildRequires: systemd-devel BuildRequires: systemd-devel
BuildRequires: libarchive-devel BuildRequires: libarchive-devel
BuildRequires: gobject-introspection-devel BuildRequires: gobject-introspection-devel
BuildRequires: gcab
%ifarch %{valgrind_arches} %ifarch %{valgrind_arches}
BuildRequires: valgrind BuildRequires: valgrind
BuildRequires: valgrind-devel BuildRequires: valgrind-devel
@ -112,6 +106,8 @@ BuildRequires: git-core
%if 0%{?have_flashrom} %if 0%{?have_flashrom}
BuildRequires: flashrom-devel >= 1.2-2 BuildRequires: flashrom-devel >= 1.2-2
%endif %endif
BuildRequires: libdrm-devel
BuildRequires: python3-jinja2
%if 0%{?have_modem_manager} %if 0%{?have_modem_manager}
BuildRequires: ModemManager-glib-devel >= 1.10.0 BuildRequires: ModemManager-glib-devel >= 1.10.0
@ -132,11 +128,6 @@ BuildRequires: tpm2-tss-devel >= 2.2.3
BuildRequires: pesign >= 113-20 BuildRequires: pesign >= 113-20
%endif %endif
%if 0%{?have_dell}
BuildRequires: efivar-devel >= 33
BuildRequires: libsmbios-devel >= 2.3.0
%endif
Requires(post): systemd Requires(post): systemd
Requires(preun): systemd Requires(preun): systemd
Requires(postun): systemd Requires(postun): systemd
@ -205,6 +196,7 @@ can be flashed using flashrom. It is probably not required on servers.
%prep %prep
%setup -q %setup -q
%patch102 -p1
mkdir -p subprojects/fwupd-efi mkdir -p subprojects/fwupd-efi
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1 tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
@ -217,16 +209,13 @@ cd -
%meson \ %meson \
-Ddocs=disabled \ -Ddocs=disabled \
-Dlvfs=disabled \ -Dlvfs=disabled \
-Dlaunchd=disabled \
-Dpassim=disabled \
%if 0%{?enable_tests} %if 0%{?enable_tests}
-Dtests=true \ -Dtests=true \
%else %else
-Dtests=false \ -Dtests=false \
%endif %endif
%if 0%{?enable_dummy}
-Dplugin_dummy=true \
%else
-Dplugin_dummy=false \
%endif
%if 0%{?have_flashrom} %if 0%{?have_flashrom}
-Dplugin_flashrom=enabled \ -Dplugin_flashrom=enabled \
%else %else
@ -260,17 +249,13 @@ cd -
-Dplugin_uefi_pk=disabled \ -Dplugin_uefi_pk=disabled \
-Dplugin_tpm=disabled \ -Dplugin_tpm=disabled \
%endif %endif
%if 0%{?have_dell}
-Dplugin_dell=enabled \
%else
-Dplugin_dell=disabled \
%endif
%if 0%{?have_modem_manager} %if 0%{?have_modem_manager}
-Dplugin_modem_manager=enabled \ -Dplugin_modem_manager=enabled \
%else %else
-Dplugin_modem_manager=disabled \ -Dplugin_modem_manager=disabled \
%endif %endif
-Dman=true \ -Dman=true \
-Dsystemd_unit_user="" \
-Dcompat_cli=true \ -Dcompat_cli=true \
-Dbluez=disabled \ -Dbluez=disabled \
-Dcbor=disabled \ -Dcbor=disabled \
@ -319,7 +304,7 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/fwupd
%find_lang %{name} %find_lang %{name}
%post %post
%systemd_post fwupd.service %systemd_post fwupd.service fwupd-refresh.timer
# change vendor-installed remotes to use the default keyring type # change vendor-installed remotes to use the default keyring type
for fn in /etc/fwupd/remotes.d/*.conf; do for fn in /etc/fwupd/remotes.d/*.conf; do
@ -329,23 +314,16 @@ for fn in /etc/fwupd/remotes.d/*.conf; do
done done
%preun %preun
%systemd_preun fwupd.service %systemd_preun fwupd.service fwupd-refresh.timer
%postun %postun
%systemd_postun_with_restart fwupd.service %systemd_postun_with_restart fwupd.service fwupd-refresh.timer
%systemd_postun_with_restart pesign.service %systemd_postun_with_restart pesign.service
%files -f %{name}.lang %files -f %{name}.lang
%doc README.md %doc README.md
%license COPYING %license COPYING
%config(noreplace)%{_sysconfdir}/fwupd/daemon.conf %config(noreplace)%{_sysconfdir}/fwupd/fwupd.conf
%if 0%{?have_uefi}
%config(noreplace)%{_sysconfdir}/fwupd/uefi_capsule.conf
%endif
%config(noreplace)%{_sysconfdir}/fwupd/redfish.conf
%if 0%{?have_thunderbolt}
%config(noreplace)%{_sysconfdir}/fwupd/thunderbolt.conf
%endif
%dir %{_libexecdir}/fwupd %dir %{_libexecdir}/fwupd
%{_libexecdir}/fwupd/fwupd %{_libexecdir}/fwupd/fwupd
%ifarch i686 x86_64 %ifarch i686 x86_64
@ -360,9 +338,7 @@ done
%{_bindir}/fwupdate %{_bindir}/fwupdate
%endif %endif
%{_bindir}/dfu-tool %{_bindir}/dfu-tool
%if 0%{?have_uefi}
%{_bindir}/dbxtool %{_bindir}/dbxtool
%endif
%{_bindir}/fwupdmgr %{_bindir}/fwupdmgr
%{_bindir}/fwupdtool %{_bindir}/fwupdtool
%{_bindir}/fwupdagent %{_bindir}/fwupdagent
@ -370,9 +346,6 @@ done
%dir %{_sysconfdir}/fwupd/bios-settings.d %dir %{_sysconfdir}/fwupd/bios-settings.d
%{_sysconfdir}/fwupd/bios-settings.d/README.md %{_sysconfdir}/fwupd/bios-settings.d/README.md
%dir %{_sysconfdir}/fwupd/remotes.d %dir %{_sysconfdir}/fwupd/remotes.d
%if 0%{?have_dell}
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/dell-esrt.conf
%endif
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf %config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf %config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor.conf %config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor.conf
@ -381,16 +354,12 @@ done
%{_sysconfdir}/pki/fwupd-metadata %{_sysconfdir}/pki/fwupd-metadata
%if 0%{?have_msr} %if 0%{?have_msr}
/usr/lib/modules-load.d/fwupd-msr.conf /usr/lib/modules-load.d/fwupd-msr.conf
%config(noreplace)%{_sysconfdir}/fwupd/msr.conf
%endif %endif
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf %{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
%{_datadir}/bash-completion/completions/fwupdmgr %{_datadir}/bash-completion/completions/fwupdmgr
%{_datadir}/bash-completion/completions/fwupdtool %{_datadir}/bash-completion/completions/fwupdtool
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish %{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml %{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
%if 0%{?have_dell}
%{_datadir}/fwupd/remotes.d/dell-esrt/metadata.xml
%endif
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md %{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml %{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy %{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
@ -410,16 +379,9 @@ done
%{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab %{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab
%{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab %{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab
%{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab %{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab
%{_mandir}/man1/fwupdtool.1* %{_mandir}/man1/*
%{_mandir}/man1/fwupdagent.1* %{_mandir}/man5/*
%{_mandir}/man1/dfu-tool.1* %{_mandir}/man8/*
%if 0%{?have_uefi}
%{_mandir}/man1/dbxtool.*
%endif
%{_mandir}/man1/fwupdmgr.1*
%if 0%{?have_uefi}
%{_mandir}/man1/fwupdate.1*
%endif
%{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml %{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml
%{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg %{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg
%{_datadir}/fwupd/firmware_packager.py %{_datadir}/fwupd/firmware_packager.py
@ -430,7 +392,6 @@ done
%{_unitdir}/fwupd.service %{_unitdir}/fwupd.service
%{_unitdir}/fwupd-refresh.service %{_unitdir}/fwupd-refresh.service
%{_unitdir}/fwupd-refresh.timer %{_unitdir}/fwupd-refresh.timer
%{_presetdir}/fwupd-refresh.preset
%{_unitdir}/system-update.target.wants/ %{_unitdir}/system-update.target.wants/
%dir %{_localstatedir}/lib/fwupd %dir %{_localstatedir}/lib/fwupd
%dir %{_localstatedir}/cache/fwupd %dir %{_localstatedir}/cache/fwupd
@ -490,6 +451,10 @@ done
%endif %endif
%changelog %changelog
* Mon Dec 04 2023 Richard Hughes <richard@hughsie.com> 1.9.10-1
- Update to latest stable upstream version.
- Resolves: #RHEL-15328
* Fri Jun 09 2023 Richard Hughes <richard@hughsie.com> 1.8.16-1 * Fri Jun 09 2023 Richard Hughes <richard@hughsie.com> 1.8.16-1
- Update to latest stable upstream version. - Update to latest stable upstream version.
- Resolves: rhbz#2209944 - Resolves: rhbz#2209944

View File

@ -1,4 +1,4 @@
SHA512 (fwupd-1.8.16.tar.xz) = 25dd773ca703ab6ad11eb042948bb719c2f3974a2e89ac8f9ae524384bce2c8a3d41e5754a5e0ab5595c14720737d53921dbf2859dd33519dcc480d227aac6c6 SHA512 (fwupd-1.9.10.tar.xz) = 308bcd3af84d82157492a2ee8dc6fa4d7df6a66cca64e45b3dff9b46d0367f7d3122671388b627f67ab59a69bac1cb36feeccd1668cce0487fe466736dd8b8cc
SHA512 (fwupd-efi-1.4.tar.xz) = c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991 SHA512 (fwupd-efi-1.4.tar.xz) = c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991
SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409 SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409
SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a