Ver. 2.8.7
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
fd1bb89c82
commit
bbdac42e55
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
fuse-2.8.4.tar.gz
|
fuse-2.8.4.tar.gz
|
||||||
/fuse-2.8.5.tar.gz
|
/fuse-2.8.5.tar.gz
|
||||||
/fuse-2.8.6.tar.gz
|
/fuse-2.8.6.tar.gz
|
||||||
|
/fuse-2.8.7.tar.gz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 459c84a3e5fda1ef7f7060d44903b31215857e70 Mon Sep 17 00:00:00 2001
|
From 22ba14e45e84e0bd12a9ab1c9d0460b9ae27c10c Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
Date: Mon, 9 Aug 2010 12:10:40 +0400
|
Date: Mon, 9 Aug 2010 12:10:40 +0400
|
||||||
Subject: [PATCH 2/3] More parentheses
|
Subject: [PATCH 1/1] More parentheses
|
||||||
|
|
||||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
---
|
---
|
||||||
@ -10,10 +10,10 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
|||||||
2 files changed, 4 insertions(+), 6 deletions(-)
|
2 files changed, 4 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
diff --git a/lib/fuse.c b/lib/fuse.c
|
diff --git a/lib/fuse.c b/lib/fuse.c
|
||||||
index 95cf50b..76c2681 100644
|
index d511964..328ebba 100644
|
||||||
--- a/lib/fuse.c
|
--- a/lib/fuse.c
|
||||||
+++ b/lib/fuse.c
|
+++ b/lib/fuse.c
|
||||||
@@ -961,17 +961,15 @@ static int fuse_compat_open(struct fuse_fs *fs, const char *path,
|
@@ -991,17 +991,15 @@ static int fuse_compat_open(struct fuse_fs *fs, const char *path,
|
||||||
{
|
{
|
||||||
int err;
|
int err;
|
||||||
if (!fs->compat || fs->compat >= 25)
|
if (!fs->compat || fs->compat >= 25)
|
||||||
@ -35,7 +35,7 @@ index 95cf50b..76c2681 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
diff --git a/lib/fuse_lowlevel.c b/lib/fuse_lowlevel.c
|
diff --git a/lib/fuse_lowlevel.c b/lib/fuse_lowlevel.c
|
||||||
index c519bfb..d6275b5 100644
|
index c86a910..4f19d61 100644
|
||||||
--- a/lib/fuse_lowlevel.c
|
--- a/lib/fuse_lowlevel.c
|
||||||
+++ b/lib/fuse_lowlevel.c
|
+++ b/lib/fuse_lowlevel.c
|
||||||
@@ -716,7 +716,7 @@ static void do_open(fuse_req_t req, fuse_ino_t nodeid, const void *inarg)
|
@@ -716,7 +716,7 @@ static void do_open(fuse_req_t req, fuse_ino_t nodeid, const void *inarg)
|
||||||
@ -48,5 +48,5 @@ index c519bfb..d6275b5 100644
|
|||||||
fuse_reply_open(req, &fi);
|
fuse_reply_open(req, &fi);
|
||||||
}
|
}
|
||||||
--
|
--
|
||||||
1.7.3.1
|
1.7.9.3
|
||||||
|
|
15
fuse.spec
15
fuse.spec
@ -1,6 +1,6 @@
|
|||||||
Name: fuse
|
Name: fuse
|
||||||
Version: 2.8.6
|
Version: 2.8.7
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: File System in Userspace (FUSE) utilities
|
Summary: File System in Userspace (FUSE) utilities
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -9,7 +9,7 @@ URL: http://fuse.sf.net
|
|||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source1: %{name}.conf
|
Source1: %{name}.conf
|
||||||
|
|
||||||
Patch2: fuse-0002-More-parentheses.patch
|
Patch1: fuse-0001-More-parentheses.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: kernel >= 2.6.14
|
Requires: kernel >= 2.6.14
|
||||||
Requires: which
|
Requires: which
|
||||||
@ -53,12 +53,12 @@ pgk-config) to develop FUSE based applications/filesystems.
|
|||||||
%setup -q
|
%setup -q
|
||||||
#disable device creation during build/install
|
#disable device creation during build/install
|
||||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||||
%patch2 -p1 -b .add_parentheses
|
%patch1 -p1 -b .add_parentheses
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Can't pass --disable-static here, or else the utils don't build
|
# Can't pass --disable-static here, or else the utils don't build
|
||||||
export MOUNT_FUSE_PATH="%{_sbindir}"
|
export MOUNT_FUSE_PATH="%{_sbindir}"
|
||||||
CFLAGS="%{optflags} -D_GNU_SOURCE" %configure
|
CFLAGS="%{optflags} -D_GNU_SOURCE" %configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -118,6 +118,9 @@ fi
|
|||||||
%{_includedir}/fuse
|
%{_includedir}/fuse
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 16 2012 Peter Lemenkov <lemenkov@gmail.com> - 2.8.7-1
|
||||||
|
- Ver. 2.8.7
|
||||||
|
|
||||||
* Sun Apr 15 2012 Kay Sievers <kay@redhat.com> - 2.8.6-4
|
* Sun Apr 15 2012 Kay Sievers <kay@redhat.com> - 2.8.6-4
|
||||||
- remove needless udev rule
|
- remove needless udev rule
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user