remove needless udev rule
The fuse permission setting is part of the default udev rules set. There is no need to ship a separate rules file for fuse. (Also, RPMs should place udev rules in /lib/udev/rules.d/, not in /etc. /etc is reserved for admins and should not be uded by packages. But that shouldn't matter as we don't need the file at all.) https://bugzilla.redhat.com/show_bug.cgi?id=748204
This commit is contained in:
parent
f52f1ca079
commit
fd1bb89c82
@ -1,20 +0,0 @@
|
||||
From ba47031f3557b81e732d41593c95e7b984b54b78 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||
Date: Mon, 9 Aug 2010 12:09:00 +0400
|
||||
Subject: [PATCH 1/3] Fix udev rules (Fedora-specific)
|
||||
|
||||
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||
---
|
||||
util/udev.rules | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/util/udev.rules b/util/udev.rules
|
||||
index 9585111..bb8033f 100644
|
||||
--- a/util/udev.rules
|
||||
+++ b/util/udev.rules
|
||||
@@ -1 +1 @@
|
||||
-KERNEL=="fuse", MODE="0666"
|
||||
+KERNEL=="fuse", MODE="0666",OWNER="root",GROUP="root"
|
||||
--
|
||||
1.7.3.1
|
||||
|
11
fuse.spec
11
fuse.spec
@ -1,6 +1,6 @@
|
||||
Name: fuse
|
||||
Version: 2.8.6
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: File System in Userspace (FUSE) utilities
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -9,7 +9,6 @@ URL: http://fuse.sf.net
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: %{name}.conf
|
||||
|
||||
Patch1: fuse-0001-Fix-udev-rules-Fedora-specific.patch
|
||||
Patch2: fuse-0002-More-parentheses.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: kernel >= 2.6.14
|
||||
@ -54,7 +53,6 @@ pgk-config) to develop FUSE based applications/filesystems.
|
||||
%setup -q
|
||||
#disable device creation during build/install
|
||||
sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
|
||||
%patch1 -p1 -b .fix_udev_rules
|
||||
%patch2 -p1 -b .add_parentheses
|
||||
|
||||
%build
|
||||
@ -78,6 +76,9 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/fuse
|
||||
# Install config-file
|
||||
install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
|
||||
|
||||
# Delete pointless udev rules, which do not belong in /etc (brc#748204)
|
||||
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/99-fuse.rules
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -99,7 +100,6 @@ fi
|
||||
%{_sbindir}/mount.fuse
|
||||
%attr(4755,root,root) %{_bindir}/fusermount
|
||||
%{_bindir}/ulockmgr_server
|
||||
%config %{_sysconfdir}/udev/rules.d/99-fuse.rules
|
||||
%config(noreplace) %{_sysconfdir}/%{name}.conf
|
||||
|
||||
%files libs
|
||||
@ -118,6 +118,9 @@ fi
|
||||
%{_includedir}/fuse
|
||||
|
||||
%changelog
|
||||
* Sun Apr 15 2012 Kay Sievers <kay@redhat.com> - 2.8.6-4
|
||||
- remove needless udev rule
|
||||
|
||||
* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 2.8.6-3
|
||||
- install everything in /usr
|
||||
https://fedoraproject.org/wiki/Features/UsrMove
|
||||
|
Loading…
Reference in New Issue
Block a user