Add support for upcoming json-c 0.14.0
This commit is contained in:
parent
3f446986bd
commit
fbca0aec49
39
0005-json-c-0.14.0.patch
Normal file
39
0005-json-c-0.14.0.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 7064b38fab818bac75364628682cee9e1c7219d9 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
||||
Date: Mon, 13 Apr 2020 13:28:51 +0200
|
||||
Subject: [PATCH] Add support for upcoming json-c 0.14.0.
|
||||
|
||||
TRUE/FALSE are not defined anymore. 1 and 0 are used instead.
|
||||
---
|
||||
lib/json.h | 15 +++++++++++++++
|
||||
1 file changed, 15 insertions(+)
|
||||
|
||||
diff --git a/lib/json.h b/lib/json.h
|
||||
index c8866c524..5979b8077 100644
|
||||
--- a/lib/json.h
|
||||
+++ b/lib/json.h
|
||||
@@ -28,6 +28,21 @@ extern "C" {
|
||||
#include "command.h"
|
||||
#include <json-c/json.h>
|
||||
|
||||
+/*
|
||||
+ * json-c 0.13.99 does not define TRUE/FALSE anymore
|
||||
+ * the json-c maintainers replaced them with pure 1/0
|
||||
+ * https://github.com/json-c/json-c/commit/0992aac61f8b
|
||||
+ */
|
||||
+#if defined JSON_C_VERSION_NUM && \
|
||||
+ JSON_C_VERSION_NUM >= ((0 << 16) | (13 << 8) | 99)
|
||||
+#ifndef FALSE
|
||||
+#define FALSE 0
|
||||
+#endif
|
||||
+#ifndef TRUE
|
||||
+#define TRUE 1
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* FRR style JSON iteration.
|
||||
* Usage: JSON_FOREACH(...) { ... }
|
||||
--
|
||||
2.26.0
|
||||
|
6
frr.spec
6
frr.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Name: frr
|
||||
Version: 7.3
|
||||
Release: 1%{?checkout}%{?dist}
|
||||
Release: 2%{?checkout}%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
@ -34,6 +34,7 @@ Patch0001: 0001-use-python3.patch
|
||||
Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-json-c-0.14.0.patch
|
||||
|
||||
%description
|
||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||
@ -176,6 +177,9 @@ make check PYTHON=%{__python3}
|
||||
#%%{_libdir}/frr/frr/libyang_plugins/*
|
||||
|
||||
%changelog
|
||||
* Mon Apr 13 2020 Björn Esser <besser82@fedoraproject.org> - 7.3-2
|
||||
- Add support for upcoming json-c 0.14.0
|
||||
|
||||
* Wed Feb 19 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-1
|
||||
- New version 7.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user