New version 7.3
This commit is contained in:
parent
6649e1db0a
commit
3f446986bd
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,4 @@
|
||||
/frr-7.1.tar.gz
|
||||
/frr-7.2.tar.gz
|
||||
/frr-7.3.tar.gz
|
||||
/remove-babeld-ldpd.sh
|
||||
|
@ -8,3 +8,13 @@ index 208fb11..0692adc 100755
|
||||
# Frr Reloader
|
||||
# Copyright (C) 2014 Cumulus Networks, Inc.
|
||||
#
|
||||
diff --git a/tools/generate_support_bundle.py b/tools/generate_support_bundle.py
|
||||
index 540b7a1..0876ebb 100755
|
||||
--- a/tools/generate_support_bundle.py
|
||||
+++ b/tools/generate_support_bundle.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
########################################################
|
||||
### Python Script to generate the FRR support bundle ###
|
||||
|
@ -8,8 +8,8 @@ index 0b7af18..0533e24 100644
|
||||
lib/log_vty.c \
|
||||
- lib/md5.c \
|
||||
lib/memory.c \
|
||||
lib/memory_vty.c \
|
||||
lib/mlag.c \
|
||||
lib/module.c \
|
||||
@@ -64,7 +64,6 @@ lib_libfrr_la_SOURCES = \
|
||||
lib/routemap.c \
|
||||
lib/sbuf.c \
|
||||
@ -24,8 +24,8 @@ index 0b7af18..0533e24 100644
|
||||
lib/log_vty.h \
|
||||
- lib/md5.h \
|
||||
lib/memory.h \
|
||||
lib/memory_vty.h \
|
||||
lib/module.h \
|
||||
lib/monotime.h \
|
||||
@@ -191,7 +190,6 @@ pkginclude_HEADERS += \
|
||||
lib/routemap.h \
|
||||
lib/sbuf.h \
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff --git a/tests/lib/test_typelist.h b/tests/lib/test_typelist.h
|
||||
index f20bbc52d..9039fa8a4 100644
|
||||
--- a/tests/lib/test_typelist.h
|
||||
+++ b/tests/lib/test_typelist.h
|
||||
@@ -98,12 +98,13 @@ static void ts_hash(const char *text, const char *expect)
|
||||
unsigned i = 0;
|
||||
uint8_t hash[32];
|
||||
char hashtext[65];
|
||||
- uint32_t count;
|
||||
+ uint32_t swap_count, count;
|
||||
|
||||
- count = htonl(list_count(&head));
|
||||
+ count = list_count(&head);
|
||||
+ swap_count = htonl(count);
|
||||
|
||||
SHA256_Init(&ctx);
|
||||
- SHA256_Update(&ctx, &count, sizeof(count));
|
||||
+ SHA256_Update(&ctx, &swap_count, sizeof(swap_count));
|
||||
|
||||
frr_each (list, &head, item) {
|
||||
struct {
|
||||
@@ -115,7 +115,7 @@ static void ts_hash(const char *text, const char *expect)
|
||||
};
|
||||
SHA256_Update(&ctx, &hashitem, sizeof(hashitem));
|
||||
i++;
|
||||
- assert(i < count);
|
||||
+ assert(i <= count);
|
||||
}
|
||||
SHA256_Final(hash, &ctx);
|
||||
|
11
frr.spec
11
frr.spec
@ -1,11 +1,12 @@
|
||||
%global frrversion 7.2
|
||||
%global frrversion 7.3
|
||||
%global frr_libdir /usr/lib/frr
|
||||
|
||||
%global _hardened_build 1
|
||||
%define _legacy_common_support 1
|
||||
|
||||
Name: frr
|
||||
Version: 7.2
|
||||
Release: 2%{?checkout}%{?dist}
|
||||
Version: 7.3
|
||||
Release: 1%{?checkout}%{?dist}
|
||||
Summary: Routing daemon
|
||||
License: GPLv2+
|
||||
URL: http://www.frrouting.org
|
||||
@ -33,7 +34,6 @@ Patch0001: 0001-use-python3.patch
|
||||
Patch0002: 0002-enable-openssl.patch
|
||||
Patch0003: 0003-disable-eigrp-crypto.patch
|
||||
Patch0004: 0004-fips-mode.patch
|
||||
Patch0005: 0005-test-typelist-power.patch
|
||||
|
||||
%description
|
||||
FRRouting is free software that manages TCP/IP based routing protocols. It takes
|
||||
@ -176,6 +176,9 @@ make check PYTHON=%{__python3}
|
||||
#%%{_libdir}/frr/frr/libyang_plugins/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 19 2020 Michal Ruprich <mruprich@redhat.com> - 7.3-1
|
||||
- New version 7.3
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (frr-7.2.tar.gz) = a99cd23ef9499e28fdf3b2d23993e4a9bcfea3c5eb4c8ddc33ad50b0afab961733729116e01397af9e77918b8c0de5598f6c22bbab92050b548fb5c21e5d81d8
|
||||
SHA512 (frr-7.3.tar.gz) = 51d41ea00c91a98ef4152c1650238fa0a6bdc45151917ed7a90f9441ddad8af2d206579b0c8693abcbe890379ec7d8eca47930f9a795e96d8e1cdc513e293237
|
||||
SHA512 (remove-babeld-ldpd.sh) = 9cf3040bfac3620d97c323cc64e35ce2afaf943f6398d0b4187af7756897f2a4e68afedf5dc495f735132e577479aa1c142e6c111575ea6cd931295a7f6f1557
|
||||
|
Loading…
Reference in New Issue
Block a user