New upstream release.
This commit is contained in:
parent
246209d89b
commit
c169ba9f22
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ fontconfig-2.8.0.tar.gz
|
|||||||
/fontconfig-2.10.1.tar.bz2
|
/fontconfig-2.10.1.tar.bz2
|
||||||
/fontconfig-2.10.2.tar.bz2
|
/fontconfig-2.10.2.tar.bz2
|
||||||
/fontconfig-2.10.91.tar.bz2
|
/fontconfig-2.10.91.tar.bz2
|
||||||
|
/fontconfig-2.10.92.tar.bz2
|
||||||
|
@ -1,81 +0,0 @@
|
|||||||
diff -pruN fontconfig-2.10.91.orig/Makefile.am fontconfig-2.10.91/Makefile.am
|
|
||||||
--- fontconfig-2.10.91.orig/Makefile.am 2013-01-09 13:16:35.000000000 +0900
|
|
||||||
+++ fontconfig-2.10.91/Makefile.am 2013-02-12 18:35:05.000000000 +0900
|
|
||||||
@@ -31,7 +31,6 @@ else
|
|
||||||
DIST_SUBDIRS = $(SUBDIRS) doc
|
|
||||||
endif
|
|
||||||
|
|
||||||
-AUTOMAKE_OPTIONS = dist-bzip2
|
|
||||||
ACLOCAL_AMFLAGS = -I m4
|
|
||||||
|
|
||||||
EXTRA_DIST = \
|
|
||||||
diff -pruN fontconfig-2.10.91.orig/configure.ac fontconfig-2.10.91/configure.ac
|
|
||||||
--- fontconfig-2.10.91.orig/configure.ac 2013-01-10 17:57:12.000000000 +0900
|
|
||||||
+++ fontconfig-2.10.91/configure.ac 2013-02-12 18:35:05.000000000 +0900
|
|
||||||
@@ -24,7 +24,6 @@ dnl
|
|
||||||
dnl Process this file with autoconf to create configure.
|
|
||||||
|
|
||||||
AC_PREREQ(2.61)
|
|
||||||
-AC_INIT(fonts.dtd)
|
|
||||||
|
|
||||||
dnl ==========================================================================
|
|
||||||
dnl Versioning
|
|
||||||
@@ -34,7 +33,8 @@ dnl This is the package version number,
|
|
||||||
dnl version. This same version number must appear in fontconfig/fontconfig.h
|
|
||||||
dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
|
|
||||||
dnl not possible to extract the version number here from fontconfig.h
|
|
||||||
-AM_INIT_AUTOMAKE(fontconfig, 2.10.91)
|
|
||||||
+AC_INIT([fontconfig], [2.10.91], [https://bugs.freedesktop.org/enger_bug.cgi?product=fontconfig])
|
|
||||||
+AM_INIT_AUTOMAKE([1.11 parallel-tests dist-bzip2])
|
|
||||||
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
|
|
||||||
|
|
||||||
dnl libtool versioning
|
|
||||||
@@ -680,7 +680,7 @@ dnl include the header file for workarou
|
|
||||||
dnl particularly for fat binaries
|
|
||||||
AH_BOTTOM([#include "config-fixups.h"])
|
|
||||||
|
|
||||||
-AC_OUTPUT([
|
|
||||||
+AC_CONFIG_FILES([
|
|
||||||
Makefile
|
|
||||||
fontconfig/Makefile
|
|
||||||
fc-lang/Makefile
|
|
||||||
@@ -703,3 +703,4 @@ fontconfig.spec
|
|
||||||
fontconfig.pc
|
|
||||||
fontconfig-zip
|
|
||||||
])
|
|
||||||
+AC_OUTPUT
|
|
||||||
diff -pruN fontconfig-2.10.91.orig/doc/Makefile.am fontconfig-2.10.91/doc/Makefile.am
|
|
||||||
--- fontconfig-2.10.91.orig/doc/Makefile.am 2013-01-04 10:47:59.000000000 +0900
|
|
||||||
+++ fontconfig-2.10.91/doc/Makefile.am 2013-02-12 18:35:05.000000000 +0900
|
|
||||||
@@ -53,7 +53,10 @@ SUFFIXES = \
|
|
||||||
TESTS = \
|
|
||||||
check-missing-doc \
|
|
||||||
$(NULL)
|
|
||||||
-TESTS_ENVIRONMENT=top_srcdir=${top_srcdir} sh
|
|
||||||
+TESTS_ENVIRONMENT = \
|
|
||||||
+ top_srcdir=${top_srcdir}; export top_srcdir; \
|
|
||||||
+ $(NULL)
|
|
||||||
+LOG_COMPILER = sh
|
|
||||||
#
|
|
||||||
DOC2HTML = docbook2html
|
|
||||||
DOC2TXT = docbook2txt
|
|
||||||
diff -pruN fontconfig-2.10.91.orig/test/Makefile.am fontconfig-2.10.91/test/Makefile.am
|
|
||||||
--- fontconfig-2.10.91.orig/test/Makefile.am 2013-01-09 11:26:45.000000000 +0900
|
|
||||||
+++ fontconfig-2.10.91/test/Makefile.am 2013-02-12 18:35:05.000000000 +0900
|
|
||||||
@@ -1,5 +1,15 @@
|
|
||||||
check_SCRIPTS=run-test.sh
|
|
||||||
-TESTS_ENVIRONMENT=src=${srcdir} EXEEXT=${EXEEXT} sh
|
|
||||||
+TEST_EXTENSIONS = \
|
|
||||||
+ .sh \
|
|
||||||
+ $(NULL)
|
|
||||||
+
|
|
||||||
+AM_TESTS_ENVIRONMENT= \
|
|
||||||
+ src=${srcdir}; export src; \
|
|
||||||
+ EXEEXT=${EXEEXT}; export EXEEXT; \
|
|
||||||
+ $(NULL)
|
|
||||||
+
|
|
||||||
+SH_LOG_COMPILER = sh
|
|
||||||
+
|
|
||||||
TESTS=run-test.sh
|
|
||||||
|
|
||||||
TESTDATA=4x6.pcf 8x16.pcf out.expected fonts.conf.in
|
|
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Font configuration and customization library
|
Summary: Font configuration and customization library
|
||||||
Name: fontconfig
|
Name: fontconfig
|
||||||
Version: 2.10.91
|
Version: 2.10.92
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# src/ftglue.[ch] is in Public Domain
|
# src/ftglue.[ch] is in Public Domain
|
||||||
# src/fccache.c contains Public Domain code
|
# src/fccache.c contains Public Domain code
|
||||||
# fc-case/CaseFolding.txt is in the UCD
|
# fc-case/CaseFolding.txt is in the UCD
|
||||||
@ -16,12 +16,9 @@ Source1: 25-no-bitmap-fedora.conf
|
|||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=140335
|
# https://bugzilla.redhat.com/show_bug.cgi?id=140335
|
||||||
Patch0: fontconfig-2.8.0-sleep-less.patch
|
Patch0: fontconfig-2.8.0-sleep-less.patch
|
||||||
# http://cgit.freedesktop.org/fontconfig/commit/?id=96220a5ed9d1d761b14a7ac516ac6786c132f280
|
|
||||||
Patch1: fontconfig-automake-1.13.patch
|
|
||||||
|
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: freetype-devel >= %{freetype_version}
|
BuildRequires: freetype-devel >= %{freetype_version}
|
||||||
BuildRequires: autoconf automake libtool
|
|
||||||
BuildRequires: fontpackages-devel
|
BuildRequires: fontpackages-devel
|
||||||
|
|
||||||
Requires: fontpackages-filesystem
|
Requires: fontpackages-filesystem
|
||||||
@ -60,13 +57,8 @@ which is useful for developing applications that uses fontconfig.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .sleep-less
|
%patch0 -p1 -b .sleep-less
|
||||||
%patch1 -p1 -b .1-automake113
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# update autotools stuff to avoid rpath definition.
|
|
||||||
libtoolize -f
|
|
||||||
autoreconf -f -i
|
|
||||||
|
|
||||||
# We don't want to rebuild the docs, but we want to install the included ones.
|
# We don't want to rebuild the docs, but we want to install the included ones.
|
||||||
export HASDOCBOOK=no
|
export HASDOCBOOK=no
|
||||||
|
|
||||||
@ -141,6 +133,9 @@ fi
|
|||||||
%doc fontconfig-devel.txt fontconfig-devel
|
%doc fontconfig-devel.txt fontconfig-devel
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 29 2013 Akira TAGOH <tagoh@redhat.com> - 2.10.92-1
|
||||||
|
- New upstream release.
|
||||||
|
|
||||||
* Tue Feb 12 2013 Akira TAGOH <tagoh@redhat.com> - 2.10.91-3
|
* Tue Feb 12 2013 Akira TAGOH <tagoh@redhat.com> - 2.10.91-3
|
||||||
- Improve the spec to meet the latest packaging guidelines (#225759)
|
- Improve the spec to meet the latest packaging guidelines (#225759)
|
||||||
- add -devel-doc subpackage.
|
- add -devel-doc subpackage.
|
||||||
|
Loading…
Reference in New Issue
Block a user