New upstream release (#803559)
- Update ks.orth (#790471) - Add brx.orth (#790460) - Update ur.orth (#757985) - No Apple Roman cmap support anymore. should works. (#681808) - Update ne.orth (#586763) - Add a workaround for ZapfDingbats. (#562952, #497648, #468565) - clean up the spec file. - Add BR: fontpackages-devel. - Add R: fontpackages-filesystem.
This commit is contained in:
parent
ee326b4fea
commit
89aa83ab30
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
fontconfig-2.8.0.tar.gz
|
fontconfig-2.8.0.tar.gz
|
||||||
|
/fontconfig-2.9.0.tar.gz
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
Super lame. Drop me once fontconfig learns how to ignore spaces.
|
|
||||||
|
|
||||||
diff -up fontconfig-2.8.0/conf.d/30-urw-aliases.conf.jx fontconfig-2.8.0/conf.d/30-urw-aliases.conf
|
|
||||||
--- fontconfig-2.8.0/conf.d/30-urw-aliases.conf.jx 2009-11-16 12:24:52.000000000 -0500
|
|
||||||
+++ fontconfig-2.8.0/conf.d/30-urw-aliases.conf 2011-05-31 16:00:06.162549910 -0400
|
|
||||||
@@ -29,6 +29,10 @@
|
|
||||||
<family>Zapf Dingbats</family>
|
|
||||||
<accept><family>Dingbats</family></accept>
|
|
||||||
</alias>
|
|
||||||
+ <alias binding="same">
|
|
||||||
+ <family>ZapfDingbats</family>
|
|
||||||
+ <accept><family>Dingbats</family></accept>
|
|
||||||
+ </alias>
|
|
||||||
<match target="pattern">
|
|
||||||
<test name="family">
|
|
||||||
<string>Symbol</string>
|
|
@ -1,12 +1,12 @@
|
|||||||
diff -up fontconfig-2.8.0/fc-cache/fc-cache.c.jx fontconfig-2.8.0/fc-cache/fc-cache.c
|
diff -pruN fontconfig-2.8.90.orig/fc-cache/fc-cache.c fontconfig-2.8.90/fc-cache/fc-cache.c
|
||||||
--- fontconfig-2.8.0/fc-cache/fc-cache.c.jx 2009-11-16 12:24:52.000000000 -0500
|
--- fontconfig-2.8.90.orig/fc-cache/fc-cache.c 2012-02-20 12:49:18.000000000 +0900
|
||||||
+++ fontconfig-2.8.0/fc-cache/fc-cache.c 2010-06-24 15:10:04.000000000 -0400
|
+++ fontconfig-2.8.90/fc-cache/fc-cache.c 2012-03-06 12:28:26.000000000 +0900
|
||||||
@@ -461,7 +461,7 @@ main (int argc, char **argv)
|
@@ -465,7 +465,7 @@ main (int argc, char **argv)
|
||||||
*/
|
|
||||||
FcConfigDestroy (config);
|
FcConfigDestroy (config);
|
||||||
FcFini ();
|
FcFini ();
|
||||||
- sleep (2);
|
if (changed)
|
||||||
+ sleep (1);
|
- sleep (2);
|
||||||
|
+ sleep (1);
|
||||||
if (verbose)
|
if (verbose)
|
||||||
printf ("%s: %s\n", argv[0], ret ? "failed" : "succeeded");
|
printf ("%s: %s\n", argv[0], ret ? "failed" : "succeeded");
|
||||||
return ret;
|
return ret;
|
||||||
|
120
fontconfig.spec
120
fontconfig.spec
@ -1,44 +1,38 @@
|
|||||||
%global freetype_version 2.1.4
|
%global freetype_version 2.1.4
|
||||||
|
|
||||||
Summary: Font configuration and customization library
|
Summary: Font configuration and customization library
|
||||||
Name: fontconfig
|
Name: fontconfig
|
||||||
Version: 2.8.0
|
Version: 2.9.0
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
|
Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
|
||||||
URL: http://fontconfig.org
|
URL: http://fontconfig.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
Source1: 25-no-bitmap-fedora.conf
|
||||||
Source1: 25-no-bitmap-fedora.conf
|
|
||||||
|
|
||||||
Patch0: fontconfig-2.8.0-sleep-less.patch
|
Patch0: fontconfig-2.8.0-sleep-less.patch
|
||||||
Patch1: fontconfig-2.8.0-dingbats.patch
|
|
||||||
|
|
||||||
BuildRequires: gawk
|
BuildRequires: expat-devel
|
||||||
BuildRequires: expat-devel
|
BuildRequires: freetype-devel >= %{freetype_version}
|
||||||
BuildRequires: freetype-devel >= %{freetype_version}
|
BuildRequires: autoconf automake libtool
|
||||||
BuildRequires: perl
|
BuildRequires: fontpackages-devel
|
||||||
|
|
||||||
PreReq: freetype >= %{freetype_version}, coreutils
|
Requires: fontpackages-filesystem
|
||||||
# Hebrew fonts referenced in fonts.conf changed names in fonts-hebrew-0.100
|
Requires(pre): freetype
|
||||||
Conflicts: fonts-hebrew < 0.100
|
|
||||||
# Conflict with pre-modular X fonts, because they moved and we
|
|
||||||
# reference the new path in %%configure
|
|
||||||
Conflicts: fonts-xorg-base, fonts-xorg-syriac
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Fontconfig is designed to locate fonts within the
|
Fontconfig is designed to locate fonts within the
|
||||||
system and select them according to requirements specified by
|
system and select them according to requirements specified by
|
||||||
applications.
|
applications.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Font configuration and customization library
|
Summary: Font configuration and customization library
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: fontconfig = %{version}-%{release}
|
Requires: fontconfig = %{version}-%{release}
|
||||||
Requires: freetype-devel >= %{freetype_version}
|
Requires: freetype-devel >= %{freetype_version}
|
||||||
Requires: pkgconfig
|
Requires: pkgconfig
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The fontconfig-devel package includes the header files,
|
The fontconfig-devel package includes the header files,
|
||||||
and developer docs for the fontconfig package.
|
and developer docs for the fontconfig package.
|
||||||
|
|
||||||
@ -48,41 +42,35 @@ will use fontconfig.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .sleep-less
|
%patch0 -p1 -b .sleep-less
|
||||||
%patch1 -p1 -b .dingbats
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# update autotools stuff to avoid rpath definition.
|
||||||
|
libtoolize -f
|
||||||
|
autoreconf -f
|
||||||
|
|
||||||
# We don't want to rebuild the docs, but we want to install the included ones.
|
# We don't want to rebuild the docs, but we want to install the included ones.
|
||||||
export HASDOCBOOK=no
|
export HASDOCBOOK=no
|
||||||
|
|
||||||
%configure --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
|
%configure --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts \
|
||||||
|
--disable-static
|
||||||
|
|
||||||
make
|
make %{?_smp_mflags}
|
||||||
make check
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
|
install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
|
||||||
ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
|
ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_fontconfig_confdir}/
|
||||||
|
|
||||||
# move installed doc files back to build directory to package themm
|
# move installed doc files back to build directory to package themm
|
||||||
# in the right place
|
# in the right place
|
||||||
mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
|
mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
|
||||||
rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
|
rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
|
||||||
|
|
||||||
# All font packages depend on this package, so we create
|
%check
|
||||||
# and own /usr/share/fonts
|
make check
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
|
|
||||||
|
|
||||||
# Remove unpackaged files
|
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/*.la
|
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/*.a
|
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
@ -102,30 +90,30 @@ fi
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root, -)
|
||||||
%doc README AUTHORS COPYING
|
%doc README AUTHORS COPYING
|
||||||
%doc fontconfig-user.txt fontconfig-user.html
|
%doc fontconfig-user.txt fontconfig-user.html
|
||||||
|
%doc %{_fontconfig_confdir}/README
|
||||||
%{_libdir}/libfontconfig.so.*
|
%{_libdir}/libfontconfig.so.*
|
||||||
%{_bindir}/fc-cache
|
%{_bindir}/fc-cache
|
||||||
%{_bindir}/fc-cat
|
%{_bindir}/fc-cat
|
||||||
%{_bindir}/fc-list
|
%{_bindir}/fc-list
|
||||||
%{_bindir}/fc-match
|
%{_bindir}/fc-match
|
||||||
|
%{_bindir}/fc-pattern
|
||||||
%{_bindir}/fc-query
|
%{_bindir}/fc-query
|
||||||
%{_bindir}/fc-scan
|
%{_bindir}/fc-scan
|
||||||
%dir %{_sysconfdir}/fonts/conf.avail
|
%dir %{_fontconfig_masterdir}/conf.avail
|
||||||
%dir %{_datadir}/fonts
|
%{_fontconfig_masterdir}/fonts.dtd
|
||||||
%{_sysconfdir}/fonts/fonts.dtd
|
%config %{_fontconfig_masterdir}/fonts.conf
|
||||||
%config %{_sysconfdir}/fonts/fonts.conf
|
%config %{_fontconfig_masterdir}/conf.avail/*.conf
|
||||||
%doc %{_sysconfdir}/fonts/conf.d/README
|
%config(noreplace) %{_fontconfig_confdir}/*.conf
|
||||||
%config %{_sysconfdir}/fonts/conf.avail/*.conf
|
|
||||||
%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
|
|
||||||
%dir %{_localstatedir}/cache/fontconfig
|
%dir %{_localstatedir}/cache/fontconfig
|
||||||
|
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root, -)
|
||||||
%doc fontconfig-devel.txt fontconfig-devel
|
%doc fontconfig-devel.txt fontconfig-devel
|
||||||
%{_libdir}/libfontconfig.so
|
%{_libdir}/libfontconfig.so
|
||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
@ -133,6 +121,18 @@ fi
|
|||||||
%{_mandir}/man3/*
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 21 2012 Akira TAGOH <tagoh@redhat.com> - 2.9.0-1
|
||||||
|
- New upstream release (#803559)
|
||||||
|
- Update ks.orth (#790471)
|
||||||
|
- Add brx.orth (#790460)
|
||||||
|
- Update ur.orth (#757985)
|
||||||
|
- No Apple Roman cmap support anymore. should works. (#681808)
|
||||||
|
- Update ne.orth (#586763)
|
||||||
|
- Add a workaround for ZapfDingbats. (#562952, #497648, #468565)
|
||||||
|
- clean up the spec file.
|
||||||
|
- Add BR: fontpackages-devel.
|
||||||
|
- Add R: fontpackages-filesystem.
|
||||||
|
|
||||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.0-5
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.0-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
@ -318,7 +318,7 @@ fi
|
|||||||
- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
|
- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
|
||||||
|
|
||||||
* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
|
* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
|
||||||
- use "%5x" instead of " %4x" to support 64k instead of
|
- use "%%5x" instead of " %%4x" to support 64k instead of
|
||||||
clamping. Idea from Behdad.
|
clamping. Idea from Behdad.
|
||||||
|
|
||||||
* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
|
* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
|
||||||
@ -407,8 +407,8 @@ fi
|
|||||||
|
|
||||||
* Fri Dec 9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
|
* Fri Dec 9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
|
||||||
- Add two new Chinese font names to the default fonts.conf file:
|
- Add two new Chinese font names to the default fonts.conf file:
|
||||||
AR PL ShanHeiSun Uni
|
AR PL ShanHeiSun Uni
|
||||||
AR PL Zenkai Uni
|
AR PL Zenkai Uni
|
||||||
|
|
||||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||||
- rebuilt
|
- rebuilt
|
||||||
|
Loading…
Reference in New Issue
Block a user