New upstream release.
This commit is contained in:
parent
d5e37249ef
commit
518193d777
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ fontconfig-2.8.0.tar.gz
|
||||
/fontconfig-2.11.95.tar.bz2
|
||||
/fontconfig-2.12.0.tar.bz2
|
||||
/fontconfig-2.12.1.tar.bz2
|
||||
/fontconfig-2.12.2.tar.bz2
|
||||
|
@ -1,19 +0,0 @@
|
||||
diff --git a/test/out.expected b/test/out.expected
|
||||
index 39634c5..d069723 100644
|
||||
--- a/test/out.expected
|
||||
+++ b/test/out.expected
|
||||
@@ -1,8 +1,8 @@
|
||||
-Fixed:pixelsize=16
|
||||
-Fixed:pixelsize=6
|
||||
+Misc Fixed:pixelsize=6
|
||||
+Sony Fixed:pixelsize=16
|
||||
=
|
||||
-Fixed:pixelsize=16
|
||||
-Fixed:pixelsize=6
|
||||
+Misc Fixed:pixelsize=6
|
||||
+Sony Fixed:pixelsize=16
|
||||
=
|
||||
-Fixed:pixelsize=16
|
||||
-Fixed:pixelsize=6
|
||||
+Misc Fixed:pixelsize=6
|
||||
+Sony Fixed:pixelsize=16
|
@ -1,47 +0,0 @@
|
||||
From 1ab5258f7c2abfafcd63a760ca08bf93591912da Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Wed, 14 Dec 2016 16:11:05 -0800
|
||||
Subject: [PATCH] Avoid conflicts with integer width macros from TS
|
||||
18661-1:2014
|
||||
|
||||
glibc 2.25+ has now defined these macros in <limits.h>
|
||||
https://sourceware.org/git/?p=glibc.git;a=commit;h=5b17fd0da62bf923cb61d1bb7b08cf2e1f1f9c1a
|
||||
|
||||
Create an alias for FC_CHAR_WIDTH for ABI compatibility
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
fontconfig/fontconfig.h | 3 ++-
|
||||
src/fcobjs.h | 2 +-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/fontconfig/fontconfig.h b/fontconfig/fontconfig.h
|
||||
index 5c72b22..070a557 100644
|
||||
--- a/fontconfig/fontconfig.h
|
||||
+++ b/fontconfig/fontconfig.h
|
||||
@@ -128,7 +128,8 @@ typedef int FcBool;
|
||||
#define FC_USER_CACHE_FILE ".fonts.cache-" FC_CACHE_VERSION
|
||||
|
||||
/* Adjust outline rasterizer */
|
||||
-#define FC_CHAR_WIDTH "charwidth" /* Int */
|
||||
+#define FC_CHARWIDTH "charwidth" /* Int */
|
||||
+#define FC_CHAR_WIDTH FC_CHARWIDTH
|
||||
#define FC_CHAR_HEIGHT "charheight"/* Int */
|
||||
#define FC_MATRIX "matrix" /* FcMatrix */
|
||||
|
||||
diff --git a/src/fcobjs.h b/src/fcobjs.h
|
||||
index 1fc4f65..d27864b 100644
|
||||
--- a/src/fcobjs.h
|
||||
+++ b/src/fcobjs.h
|
||||
@@ -51,7 +51,7 @@ FC_OBJECT (DPI, FcTypeDouble, NULL)
|
||||
FC_OBJECT (RGBA, FcTypeInteger, NULL)
|
||||
FC_OBJECT (SCALE, FcTypeDouble, NULL)
|
||||
FC_OBJECT (MINSPACE, FcTypeBool, NULL)
|
||||
-FC_OBJECT (CHAR_WIDTH, FcTypeInteger, NULL)
|
||||
+FC_OBJECT (CHARWIDTH, FcTypeInteger, NULL)
|
||||
FC_OBJECT (CHAR_HEIGHT, FcTypeInteger, NULL)
|
||||
FC_OBJECT (MATRIX, FcTypeMatrix, NULL)
|
||||
FC_OBJECT (CHARSET, FcTypeCharSet, FcCompareCharSet)
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,65 +0,0 @@
|
||||
From 9878b306f6c673d3d6cd9db487f67eb426cc03df Mon Sep 17 00:00:00 2001
|
||||
From: Akira TAGOH <akira@tagoh.org>
|
||||
Date: Thu, 23 Feb 2017 21:39:10 +0900
|
||||
Subject: [PATCH] Fix the build issue with gperf 3.1
|
||||
|
||||
To support the one of changes in gperf 3.1:
|
||||
* The 'len' parameter of the hash function and of the lookup function is now
|
||||
of type 'size_t' instead of 'unsigned int'. This makes it safe to call these
|
||||
functions with strings of length > 4 GB, on 64-bit machines.
|
||||
---
|
||||
configure.ac | 20 ++++++++++++++++++++
|
||||
src/fcobjs.c | 4 ++--
|
||||
2 files changed, 22 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4948816..8fbf3d3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -193,6 +193,26 @@ fi
|
||||
AC_CHECK_MEMBERS([struct dirent.d_type],,,
|
||||
[#include <dirent.h>])
|
||||
|
||||
+# Check the argument type of the gperf hash/lookup function
|
||||
+AC_MSG_CHECKING([The type of len parameter of gperf hash/lookup function])
|
||||
+fc_gperf_test="$(echo 'foo' | gperf -L ANSI-C)"
|
||||
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
|
||||
+ #include <string.h>
|
||||
+
|
||||
+ const char *in_word_set(register const char *, register size_t);
|
||||
+ $fc_gperf_test
|
||||
+ ]])], [FC_GPERF_SIZE_T=size_t],
|
||||
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
|
||||
+ #include <string.h>
|
||||
+
|
||||
+ const char *in_word_set(register const char *, register unsigned int);
|
||||
+ $fc_gperf_test
|
||||
+ ]])], [FC_GPERF_SIZE_T="unsigned int"],
|
||||
+ [AC_MSG_ERROR([Unable to determine the type of the len parameter of the gperf hash/lookup function])]
|
||||
+)])
|
||||
+AC_DEFINE_UNQUOTED(FC_GPERF_SIZE_T, $FC_GPERF_SIZE_T, [The type of len parameter of the gperf hash/lookup function])
|
||||
+AC_MSG_RESULT($FC_GPERF_SIZE_T)
|
||||
+
|
||||
#
|
||||
# Checks for iconv
|
||||
#
|
||||
diff --git a/src/fcobjs.c b/src/fcobjs.c
|
||||
index 16ff31c..33bba8d 100644
|
||||
--- a/src/fcobjs.c
|
||||
+++ b/src/fcobjs.c
|
||||
@@ -25,10 +25,10 @@
|
||||
#include "fcint.h"
|
||||
|
||||
static unsigned int
|
||||
-FcObjectTypeHash (register const char *str, register unsigned int len);
|
||||
+FcObjectTypeHash (register const char *str, register FC_GPERF_SIZE_T len);
|
||||
|
||||
static const struct FcObjectTypeInfo *
|
||||
-FcObjectTypeLookup (register const char *str, register unsigned int len);
|
||||
+FcObjectTypeLookup (register const char *str, register FC_GPERF_SIZE_T len);
|
||||
|
||||
#include "fcobjshash.h"
|
||||
|
||||
--
|
||||
2.9.3
|
||||
|
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Font configuration and customization library
|
||||
Name: fontconfig
|
||||
Version: 2.12.1
|
||||
Release: 4%{?dist}
|
||||
Version: 2.12.2
|
||||
Release: 1%{?dist}
|
||||
# src/ftglue.[ch] is in Public Domain
|
||||
# src/fccache.c contains Public Domain code
|
||||
# fc-case/CaseFolding.txt is in the UCD
|
||||
@ -15,9 +15,6 @@ Source1: 25-no-bitmap-fedora.conf
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=140335
|
||||
Patch0: %{name}-sleep-less.patch
|
||||
Patch1: %{name}-glibc-limits.patch
|
||||
Patch2: %{name}-gperf-3.1.patch
|
||||
Patch3: %{name}-freetype-2.7.1.patch
|
||||
|
||||
BuildRequires: expat-devel
|
||||
BuildRequires: freetype-devel >= %{freetype_version}
|
||||
@ -62,9 +59,6 @@ which is useful for developing applications that uses fontconfig.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .sleep-less
|
||||
%patch1 -p1 -b .glibc-limits
|
||||
%patch2 -p1 -b .gperf
|
||||
%patch3 -p1 -b .freetype
|
||||
|
||||
%build
|
||||
# We don't want to rebuild the docs, but we want to install the included ones.
|
||||
@ -151,6 +145,9 @@ HOME=/root /usr/bin/fc-cache -s
|
||||
%doc fontconfig-devel.txt fontconfig-devel
|
||||
|
||||
%changelog
|
||||
* Wed May 31 2017 Akira TAGOH <tagoh@redhat.com> - 2.12.2-1
|
||||
- New upstream release.
|
||||
|
||||
* Thu Feb 23 2017 Akira TAGOH <tagoh@redhat.com> - 2.12.1-4
|
||||
- Move the cache files into /usr/lib/fontconfig/cache (#1377367, #1416380)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user