add missing file

This commit is contained in:
Akira TAGOH 2013-02-12 19:31:28 +09:00
parent 9a86d5d29f
commit 246209d89b

View File

@ -0,0 +1,81 @@
diff -pruN fontconfig-2.10.91.orig/Makefile.am fontconfig-2.10.91/Makefile.am
--- fontconfig-2.10.91.orig/Makefile.am 2013-01-09 13:16:35.000000000 +0900
+++ fontconfig-2.10.91/Makefile.am 2013-02-12 18:35:05.000000000 +0900
@@ -31,7 +31,6 @@ else
DIST_SUBDIRS = $(SUBDIRS) doc
endif
-AUTOMAKE_OPTIONS = dist-bzip2
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
diff -pruN fontconfig-2.10.91.orig/configure.ac fontconfig-2.10.91/configure.ac
--- fontconfig-2.10.91.orig/configure.ac 2013-01-10 17:57:12.000000000 +0900
+++ fontconfig-2.10.91/configure.ac 2013-02-12 18:35:05.000000000 +0900
@@ -24,7 +24,6 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ(2.61)
-AC_INIT(fonts.dtd)
dnl ==========================================================================
dnl Versioning
@@ -34,7 +33,8 @@ dnl This is the package version number,
dnl version. This same version number must appear in fontconfig/fontconfig.h
dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
dnl not possible to extract the version number here from fontconfig.h
-AM_INIT_AUTOMAKE(fontconfig, 2.10.91)
+AC_INIT([fontconfig], [2.10.91], [https://bugs.freedesktop.org/enger_bug.cgi?product=fontconfig])
+AM_INIT_AUTOMAKE([1.11 parallel-tests dist-bzip2])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
dnl libtool versioning
@@ -680,7 +680,7 @@ dnl include the header file for workarou
dnl particularly for fat binaries
AH_BOTTOM([#include "config-fixups.h"])
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
fontconfig/Makefile
fc-lang/Makefile
@@ -703,3 +703,4 @@ fontconfig.spec
fontconfig.pc
fontconfig-zip
])
+AC_OUTPUT
diff -pruN fontconfig-2.10.91.orig/doc/Makefile.am fontconfig-2.10.91/doc/Makefile.am
--- fontconfig-2.10.91.orig/doc/Makefile.am 2013-01-04 10:47:59.000000000 +0900
+++ fontconfig-2.10.91/doc/Makefile.am 2013-02-12 18:35:05.000000000 +0900
@@ -53,7 +53,10 @@ SUFFIXES = \
TESTS = \
check-missing-doc \
$(NULL)
-TESTS_ENVIRONMENT=top_srcdir=${top_srcdir} sh
+TESTS_ENVIRONMENT = \
+ top_srcdir=${top_srcdir}; export top_srcdir; \
+ $(NULL)
+LOG_COMPILER = sh
#
DOC2HTML = docbook2html
DOC2TXT = docbook2txt
diff -pruN fontconfig-2.10.91.orig/test/Makefile.am fontconfig-2.10.91/test/Makefile.am
--- fontconfig-2.10.91.orig/test/Makefile.am 2013-01-09 11:26:45.000000000 +0900
+++ fontconfig-2.10.91/test/Makefile.am 2013-02-12 18:35:05.000000000 +0900
@@ -1,5 +1,15 @@
check_SCRIPTS=run-test.sh
-TESTS_ENVIRONMENT=src=${srcdir} EXEEXT=${EXEEXT} sh
+TEST_EXTENSIONS = \
+ .sh \
+ $(NULL)
+
+AM_TESTS_ENVIRONMENT= \
+ src=${srcdir}; export src; \
+ EXEEXT=${EXEEXT}; export EXEEXT; \
+ $(NULL)
+
+SH_LOG_COMPILER = sh
+
TESTS=run-test.sh
TESTDATA=4x6.pcf 8x16.pcf out.expected fonts.conf.in