Update to 1.15.3 (#2120890)

This commit is contained in:
David King 2023-02-23 12:14:47 +00:00
parent 0a10f11a8b
commit 6614399d84
4 changed files with 8 additions and 64 deletions

1
.gitignore vendored
View File

@ -108,3 +108,4 @@
/flatpak-1.14.0.tar.xz /flatpak-1.14.0.tar.xz
/flatpak-1.14.1.tar.xz /flatpak-1.14.1.tar.xz
/flatpak-1.15.1.tar.xz /flatpak-1.15.1.tar.xz
/flatpak-1.15.3.tar.xz

View File

@ -1,51 +0,0 @@
From 48f7921a0818356e7d7d694bbc3aeef620667cda Mon Sep 17 00:00:00 2001
From: David King <amigadave@amigadave.com>
Date: Wed, 14 Dec 2022 11:17:31 +0000
Subject: [PATCH 1/2] selinux: Install when using meson
With custom_target, providing build_by_default is not enough to install
the output, which must be explicitly requested.
---
selinux/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/selinux/meson.build b/selinux/meson.build
index 0c3174bf..7dfa79d6 100644
--- a/selinux/meson.build
+++ b/selinux/meson.build
@@ -11,6 +11,7 @@ custom_target(
'@OUTPUT0@',
'@INPUT@',
],
+ install : true,
install_dir : get_option('datadir') / 'selinux' / 'packages',
)
--
2.38.1
From f8aca54c5556463b2b42a4e8f48c005f661b86ec Mon Sep 17 00:00:00 2001
From: David King <amigadave@amigadave.com>
Date: Wed, 14 Dec 2022 17:26:54 +0000
Subject: [PATCH 2/2] selinux: Install to previous location
Install flatpak.if to the same location for Autotools and meson.
---
selinux/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/selinux/meson.build b/selinux/meson.build
index 7dfa79d6..238a46f1 100644
--- a/selinux/meson.build
+++ b/selinux/meson.build
@@ -17,5 +17,5 @@ custom_target(
install_data(
'flatpak.if',
- install_dir : get_option('datadir') / 'selinux' / 'include' / 'contrib',
+ install_dir : get_option('datadir') / 'selinux' / 'devel' / 'include' / 'contrib',
)
--
2.38.1

View File

@ -5,11 +5,11 @@
%global ostree_version 2020.8 %global ostree_version 2020.8
Name: flatpak Name: flatpak
Version: 1.15.1 Version: 1.15.3
Release: 3%{?dist} Release: 1%{?dist}
Summary: Application deployment framework for desktop apps Summary: Application deployment framework for desktop apps
License: LGPLv2+ License: LGPL-2.1-or-later
URL: https://flatpak.org/ URL: https://flatpak.org/
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
@ -22,9 +22,6 @@ Source1: flatpak-add-fedora-repos.service
# with the config from upstream sources. # with the config from upstream sources.
Source2: flatpak.sysusers.conf Source2: flatpak.sysusers.conf
# https://github.com/flatpak/flatpak/pull/5217
Patch0: flatpak-1.15.1-install-selinux.patch
BuildRequires: pkgconfig(appstream) >= %{appstream_version} BuildRequires: pkgconfig(appstream) >= %{appstream_version}
BuildRequires: pkgconfig(dconf) BuildRequires: pkgconfig(dconf)
BuildRequires: pkgconfig(fuse3) BuildRequires: pkgconfig(fuse3)
@ -89,7 +86,6 @@ more information.
%package devel %package devel
Summary: Development files for %{name} Summary: Development files for %{name}
License: LGPLv2+
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} Requires: %{name}-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
@ -98,7 +94,6 @@ This package contains the pkg-config file and development headers for %{name}.
%package libs %package libs
Summary: Libraries for %{name} Summary: Libraries for %{name}
License: LGPLv2+
Requires: bubblewrap >= %{bubblewrap_version} Requires: bubblewrap >= %{bubblewrap_version}
Requires: ostree%{?_isa} >= %{ostree_version} Requires: ostree%{?_isa} >= %{ostree_version}
@ -107,7 +102,6 @@ This package contains libflatpak.
%package selinux %package selinux
Summary: SELinux policy module for %{name} Summary: SELinux policy module for %{name}
License: LGPLv2+
BuildRequires: selinux-policy BuildRequires: selinux-policy
BuildRequires: selinux-policy-devel BuildRequires: selinux-policy-devel
BuildRequires: make BuildRequires: make
@ -119,7 +113,6 @@ This package contains the SELinux policy module for %{name}.
%package session-helper %package session-helper
Summary: User D-Bus service used by %{name} and others Summary: User D-Bus service used by %{name} and others
License: LGPLv2+
Conflicts: flatpak < 1.4.1-2 Conflicts: flatpak < 1.4.1-2
Requires: systemd Requires: systemd
@ -129,7 +122,6 @@ that's used by %{name} and other packages.
%package tests %package tests
Summary: Tests for %{name} Summary: Tests for %{name}
License: LGPLv2+
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} Requires: %{name}-libs%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-session-helper%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} Requires: %{name}-session-helper%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
@ -158,7 +150,6 @@ install -pm 644 NEWS README.md %{buildroot}/%{_pkgdocdir}
# The system repo is not installed by the flatpak build system. # The system repo is not installed by the flatpak build system.
install -d %{buildroot}%{_localstatedir}/lib/flatpak install -d %{buildroot}%{_localstatedir}/lib/flatpak
install -d %{buildroot}%{_sysconfdir}/flatpak/remotes.d install -d %{buildroot}%{_sysconfdir}/flatpak/remotes.d
rm -f %{buildroot}%{_libdir}/libflatpak.la
%if 0%{?fedora} %if 0%{?fedora}
install -D -t %{buildroot}%{_unitdir} %{SOURCE1} install -D -t %{buildroot}%{_unitdir} %{SOURCE1}
@ -273,6 +264,9 @@ fi
%changelog %changelog
* Thu Feb 23 2023 David King <amigadave@amigadave.com> - 1.15.3-1
- Update to 1.15.3 (#2120890)
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.1-3 * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (flatpak-1.15.1.tar.xz) = 807bc318d13882aa20d43282204661b02853464a88544588f1692bce675ade9d0ebb74b29fa6d243f0cd77f5fe725879db0baf7bf0169d30a9fe69b5df3d4b52 SHA512 (flatpak-1.15.3.tar.xz) = 7d9d62852ac61ab417e25e9e75dcf17186762e4537659c095f498089f5f2ccb2aff95d37c69fc754c477c5c162c344f9d5eaaddd6d66dce373538091002f6119