52 lines
1.4 KiB
Diff
52 lines
1.4 KiB
Diff
From 48f7921a0818356e7d7d694bbc3aeef620667cda Mon Sep 17 00:00:00 2001
|
|
From: David King <amigadave@amigadave.com>
|
|
Date: Wed, 14 Dec 2022 11:17:31 +0000
|
|
Subject: [PATCH 1/2] selinux: Install when using meson
|
|
|
|
With custom_target, providing build_by_default is not enough to install
|
|
the output, which must be explicitly requested.
|
|
---
|
|
selinux/meson.build | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/selinux/meson.build b/selinux/meson.build
|
|
index 0c3174bf..7dfa79d6 100644
|
|
--- a/selinux/meson.build
|
|
+++ b/selinux/meson.build
|
|
@@ -11,6 +11,7 @@ custom_target(
|
|
'@OUTPUT0@',
|
|
'@INPUT@',
|
|
],
|
|
+ install : true,
|
|
install_dir : get_option('datadir') / 'selinux' / 'packages',
|
|
)
|
|
|
|
--
|
|
2.38.1
|
|
|
|
|
|
From f8aca54c5556463b2b42a4e8f48c005f661b86ec Mon Sep 17 00:00:00 2001
|
|
From: David King <amigadave@amigadave.com>
|
|
Date: Wed, 14 Dec 2022 17:26:54 +0000
|
|
Subject: [PATCH 2/2] selinux: Install to previous location
|
|
|
|
Install flatpak.if to the same location for Autotools and meson.
|
|
---
|
|
selinux/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/selinux/meson.build b/selinux/meson.build
|
|
index 7dfa79d6..238a46f1 100644
|
|
--- a/selinux/meson.build
|
|
+++ b/selinux/meson.build
|
|
@@ -17,5 +17,5 @@ custom_target(
|
|
|
|
install_data(
|
|
'flatpak.if',
|
|
- install_dir : get_option('datadir') / 'selinux' / 'include' / 'contrib',
|
|
+ install_dir : get_option('datadir') / 'selinux' / 'devel' / 'include' / 'contrib',
|
|
)
|
|
--
|
|
2.38.1
|
|
|