New upstream version v3.29
Required two local fix-up patches, sent upstream
This commit is contained in:
parent
12a03d2341
commit
f522f10886
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@
|
||||
/fio-3.27.tar.bz2.asc
|
||||
/fio-3.28.tar.bz2
|
||||
/fio-3.28.tar.bz2.asc
|
||||
/fio-3.29.tar.bz2
|
||||
|
21
fio-3.29-link-t-io_uring-with-libaio.patch
Normal file
21
fio-3.29-link-t-io_uring-with-libaio.patch
Normal file
@ -0,0 +1,21 @@
|
||||
[PATCH 1/2] t/io_uring: link with libaio when necessary
|
||||
|
||||
When CONFIG_LIBAIO is enabled, we need t/io_uring to link with it.
|
||||
(libaio_LIBS only affects the aio engine, AFAICT.)
|
||||
|
||||
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
||||
---
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5d17bca..00e7953 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -99,6 +99,7 @@ endif
|
||||
ifdef CONFIG_LIBAIO
|
||||
libaio_SRCS = engines/libaio.c
|
||||
cmdprio_SRCS = engines/cmdprio.c
|
||||
+ LIBS += -laio
|
||||
libaio_LIBS = -laio
|
||||
ENGINES += libaio
|
||||
endif
|
||||
|
20
fio-3.29-use-LDFLAGS-for-dynamic-engines.patch
Normal file
20
fio-3.29-use-LDFLAGS-for-dynamic-engines.patch
Normal file
@ -0,0 +1,20 @@
|
||||
[PATCH 2/2] fio: use LDFLAGS when linking dynamic engines
|
||||
|
||||
Without this, locally defined LDFLAGS won't be applied when
|
||||
linking the dynamically loaded IO engines.
|
||||
|
||||
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
||||
---
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5d17bca..00e7953 100644
|
||||
@@ -294,7 +295,7 @@ define engine_template =
|
||||
$(1)_OBJS := $$($(1)_SRCS:.c=.o)
|
||||
$$($(1)_OBJS): CFLAGS := -fPIC $$($(1)_CFLAGS) $(CFLAGS)
|
||||
engines/fio-$(1).so: $$($(1)_OBJS)
|
||||
- $$(QUIET_LINK)$(CC) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
||||
+ $$(QUIET_LINK)$(CC) $(LDFLAGS) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
||||
ENGS_OBJS += engines/fio-$(1).so
|
||||
endef
|
||||
else # !CONFIG_DYNAMIC_ENGINES
|
||||
|
12
fio.spec
12
fio.spec
@ -1,6 +1,6 @@
|
||||
Name: fio
|
||||
Version: 3.28
|
||||
Release: 3%{?dist}
|
||||
Version: 3.29
|
||||
Release: 1%{?dist}
|
||||
Summary: Multithreaded IO generation tool
|
||||
|
||||
License: GPLv2
|
||||
@ -9,6 +9,9 @@ Source0: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
|
||||
Source1: https://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2.asc
|
||||
Source2: https://git.kernel.org/pub/scm/docs/kernel/pgpkeys.git/plain/keys/F7D358FB2971E0A6.asc
|
||||
|
||||
Patch0: fio-3.29-link-t-io_uring-with-libaio.patch
|
||||
Patch1: fio-3.29-use-LDFLAGS-for-dynamic-engines.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gnupg2
|
||||
BuildRequires: libaio-devel
|
||||
@ -211,13 +214,16 @@ make install prefix=%{_prefix} mandir=%{_mandir} libdir=%{_libdir}/fio DESTDIR=$
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 26 2022 Eric Sandeen <sandeen@redhat.com> 3.29-1
|
||||
- New upstream version
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.28-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.28-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Thu Sep 092021 Eric Sandeen <sandeen@redhat.com> 3.28-1
|
||||
* Thu Sep 09 2021 Eric Sandeen <sandeen@redhat.com> 3.28-1
|
||||
- New upstream version
|
||||
|
||||
* Mon Aug 23 2021 Eric Sandeen <sandeen@redhat.com> 3.27-3
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (fio-3.28.tar.bz2) = 1f6d125ad22bfb5b64e850c8efa220a8d9bed3ec5294323fdbb74321f8ba23f3e13e8d98a14be82851ee2d9704846a1d1d5ce256859b21fdffaed193a9210318
|
||||
SHA512 (fio-3.28.tar.bz2.asc) = 34c17f27546eabfc57b14698bddce5a2d59f6ad575e1c6bbdcc9e518a772a2e9d67ddf5ea378e91d8f916cb861970183d20c6627f8f04d9b0826ae979795731b
|
||||
SHA512 (fio-3.29.tar.bz2) = 546ff7f376396667336e5c0b37f5233399de24dcbc825f74062f88a5aca9f44ea2ce80e9b1450234486e8364f03936b0e105d0ddce72851cc5130b3f75fbf052
|
||||
|
Loading…
Reference in New Issue
Block a user