Bump to 0.4.5
Resolves: rhbz#2065405 Resolves: rhbz#2065404 Signed-off-by: Antonio Murdaca <runcom@linux.com>
This commit is contained in:
parent
89549152e1
commit
c5db3d825a
6
.gitignore
vendored
6
.gitignore
vendored
@ -5,3 +5,9 @@
|
||||
/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||
/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||
/fido-device-onboard-rs-0.4.0.tar.gz
|
||||
/fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535.tar.gz
|
||||
/fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-vendor.tar.gz
|
||||
/fido-device-onboard-rs-61145c33f1e58be9bf07ee59812c077bd0647b55.tar.gz
|
||||
/fido-device-onboard-rs-61145c33f1e58be9bf07ee59812c077bd0647b55-vendor.tar.gz
|
||||
/fido-device-onboard-rs-0.4.5.tar.gz
|
||||
/fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --color -ru fido-device-onboard-rs-0.4.0-orig/Cargo.toml fido-device-onboard-rs-0.4.0/Cargo.toml
|
||||
--- fido-device-onboard-rs-0.4.0-orig/Cargo.toml 2022-02-24 20:44:38.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.4.0/Cargo.toml 2022-02-24 21:53:32.785864178 +0100
|
||||
diff --color -ru fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml
|
||||
--- fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml 2022-03-17 16:38:49.000000000 +0100
|
||||
+++ fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml 2022-03-28 12:03:59.101029855 +0200
|
||||
@@ -17,3 +17,6 @@
|
||||
"serviceinfo-api-dev-server",
|
||||
|
||||
"integration-tests",
|
||||
]
|
||||
+
|
||||
|
@ -4,7 +4,7 @@
|
||||
%global __cargo_is_lib() false
|
||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||
|
||||
Version: 0.4.0
|
||||
Version: 0.4.5
|
||||
|
||||
%forgemeta
|
||||
|
||||
@ -33,9 +33,11 @@ BuildRequires: rust-toolset
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: openssl-devel >= 3.0.1-12
|
||||
BuildRequires: golang
|
||||
BuildRequires: tpm2-tss-devel
|
||||
BuildRequires: cryptsetup-devel
|
||||
BuildRequires: clang-devel
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
@ -65,10 +67,15 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufacturing-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-serviceinfo-api-server
|
||||
# duplicates as needed by AIO command
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-admin-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
||||
# 52fdo
|
||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
||||
@ -77,7 +84,7 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/m
|
||||
|
||||
%package -n fdo-init
|
||||
Summary: dracut module for device initialization
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
%description -n fdo-init
|
||||
%{summary}
|
||||
|
||||
@ -88,24 +95,30 @@ Requires: openssl-devel >= 3.0.1-12
|
||||
|
||||
%package -n fdo-owner-onboarding-server
|
||||
Summary: FDO Owner Onboarding Server implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
%description -n fdo-owner-onboarding-server
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-owner-onboarding-server
|
||||
%license LICENSE
|
||||
%{_libexecdir}/fdo/fdo-owner-onboarding-server
|
||||
%{_libexecdir}/fdo/fdo-serviceinfo-api-server
|
||||
%{_docdir}/fdo/serviceinfo-api-server.yml
|
||||
%{_unitdir}/fdo-serviceinfo-api-server.service
|
||||
%{_docdir}/fdo/owner-onboarding-server.yml
|
||||
%{_unitdir}/fdo-owner-onboarding-server.service
|
||||
|
||||
%post -n fdo-owner-onboarding-server
|
||||
%systemd_post fdo-owner-onboarding-server.service
|
||||
%systemd_post fdo-serviceinfo-api-server.service
|
||||
|
||||
%preun -n fdo-owner-onboarding-server
|
||||
%systemd_preun fdo-owner-onboarding-server.service
|
||||
%systemd_post fdo-serviceinfo-api-server.service
|
||||
|
||||
%postun -n fdo-owner-onboarding-server
|
||||
%systemd_postun_with_restart fdo-owner-onboarding-server.service
|
||||
%systemd_postun_with_restart fdo-serviceinfo-api-server.service
|
||||
|
||||
%package -n fdo-rendezvous-server
|
||||
Summary: FDO Rendezvous Server implementation
|
||||
@ -129,7 +142,7 @@ Summary: FDO Rendezvous Server implementation
|
||||
|
||||
%package -n fdo-manufacturing-server
|
||||
Summary: FDO Manufacturing Server implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
%description -n fdo-manufacturing-server
|
||||
%{summary}
|
||||
|
||||
@ -150,7 +163,10 @@ Requires: openssl-devel >= 3.0.1-12
|
||||
|
||||
%package -n fdo-client
|
||||
Summary: FDO Client implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
Requires: clevis
|
||||
Requires: clevis-luks
|
||||
Requires: cryptsetup
|
||||
%description -n fdo-client
|
||||
%{summary}
|
||||
|
||||
@ -166,28 +182,52 @@ Requires: openssl-devel >= 3.0.1-12
|
||||
%systemd_preun fdo-client-linuxapp.service
|
||||
|
||||
%postun -n fdo-client
|
||||
%systemd_postun_with_restart fdo-client.linuxapp.service
|
||||
%systemd_postun_with_restart fdo-client-linuxapp.service
|
||||
|
||||
%package -n fdo-owner-cli
|
||||
Summary: FDO Owner tools implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-owner-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-owner-cli
|
||||
%license LICENSE
|
||||
%{_bindir}/fdo-owner-tool
|
||||
%{_libexecdir}/fdo/fdo-owner-tool
|
||||
|
||||
%package -n fdo-admin-cli
|
||||
Summary: FDO admin tools implementation
|
||||
Requires: fdo-manufacturing-server
|
||||
Requires: fdo-init
|
||||
Requires: fdo-client
|
||||
Requires: fdo-rendezvous-server
|
||||
Requires: fdo-owner-onboarding-server
|
||||
Requires: fdo-owner-cli
|
||||
%description -n fdo-admin-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-admin-cli
|
||||
%license LICENSE
|
||||
%{_bindir}/fdo-admin-tool
|
||||
%{_libexecdir}/fdo/fdo-admin-tool
|
||||
%{_unitdir}/fdo-aio.service
|
||||
%dir %{_sysconfdir}/fdo
|
||||
|
||||
%post -n fdo-admin-cli
|
||||
%systemd_post fdo-aio.service
|
||||
|
||||
%preun -n fdo-admin-cli
|
||||
%systemd_preun fdo-aio.service
|
||||
|
||||
%postun -n fdo-admin-cli
|
||||
%systemd_postun_with_restart fdo-aio.service
|
||||
|
||||
%changelog
|
||||
* Tue Mar 29 2022 Antonio Murdaca <runcom@linux.com> - 0.4.5-1
|
||||
- bump to 0.4.5
|
||||
|
||||
* Mon Feb 28 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-2
|
||||
- fix runtime requirements to use openssl-libs and not -devel
|
||||
|
||||
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
||||
- upgrade to 0.4.0
|
||||
|
||||
|
6
sources
6
sources
@ -5,3 +5,9 @@ SHA512 (fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz) = 09e23118a29fff2159
|
||||
SHA512 (fido-device-onboard-rs-0.3.0.tar.gz) = 73174dee1571b13db45314b41a12c0879583238e326b94713163b2158354cd68ac253566453c108a86cd5082b3217a20d179f8de3ab02267abd6fa895c8a5626
|
||||
SHA512 (fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz) = 50db064451da4b3f6d3ab842e2e9aa4a8c14ede8d733aeddfaa5f683b548c6e3e7b6b09e431cc5b8e928b3a5b994f6dd5a47a2fd38a3dcb70bce5c2ec0b64ef2
|
||||
SHA512 (fido-device-onboard-rs-0.4.0.tar.gz) = aa9e295fd3b27f7b81b1b40a9560fedf1ca53e23ac6ab952f29a385b663007db0b9fd003e5d2cacb36893b530e5ab8e02a2518df8643c84e960838302d048db9
|
||||
SHA512 (fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535.tar.gz) = 3a66a987cc067d0bfad37d51d66d6333225ae49a476b0dd7139beb61c5a942da9182bf408c45f6cec708d287abd9e1bb9f319902257efcd8f3efde60299c929c
|
||||
SHA512 (fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-vendor.tar.gz) = 6720652df8fc417a88dccea393f42a2b17ee5ef749a436d6814f43055fed0b9bdaa2a76c3c82f9a9293393a9fdc1c6fef0dc27ce12c61af222015844eb991193
|
||||
SHA512 (fido-device-onboard-rs-61145c33f1e58be9bf07ee59812c077bd0647b55.tar.gz) = 0d032c14e68b60e9e4205c0bef12b61a75853428328cbc5ee1fa9501d3bf367872d1615fef2366a82aece5bdbb6ba339888013dae797707e466c0be06bac8e0e
|
||||
SHA512 (fido-device-onboard-rs-61145c33f1e58be9bf07ee59812c077bd0647b55-vendor.tar.gz) = ef4d9e16d158c7dcecd2aacb8b6da0ea09c59663dd4bb63b7a4213dc546f96517df202e7a93e7afaed925881d4ea2348bd08e074e3caea2235ba55675f58c507
|
||||
SHA512 (fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz) = e7daf460dedfbfd9a453f77e23c4c9160b1681f3ef82946fe2dd8595244829fc20bb5bb67c19b05cc982e37096dc7cf427040e3dc3b7fed9f3a3c877d3870664
|
||||
SHA512 (fido-device-onboard-rs-0.4.5.tar.gz) = c1328d69d628212f3927daac1aaa220c4a16c89856f405e97f5d26d01a625cf0398e50894b88d8e5f0c271aaafcf7e2a9fd35198efdf093372fe1425150303f6
|
||||
|
Loading…
Reference in New Issue
Block a user