upgrade to 0.4.0
Resolves: rhbz#1989923 Signed-off-by: Antonio Murdaca <runcom@linux.com>
This commit is contained in:
parent
7ce3755006
commit
89549152e1
2
.gitignore
vendored
2
.gitignore
vendored
@ -3,3 +3,5 @@
|
||||
/fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz
|
||||
/fido-device-onboard-rs-0.3.0.tar.gz
|
||||
/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||
/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||
/fido-device-onboard-rs-0.4.0.tar.gz
|
||||
|
9
README
Normal file
9
README
Normal file
@ -0,0 +1,9 @@
|
||||
cleanup windows proprietary files from vendor/
|
||||
|
||||
rm -rf target/vendor/winapi/src/*
|
||||
touch target/winapi/src/lib.rs
|
||||
cd target/vendor
|
||||
rm -rf winapi-x86_64-pc-windows-gnu/lib/*
|
||||
rm -rf winapi-i686-pc-windows-gnu/lib/*
|
||||
rm -rf vcpkg/test-data
|
||||
|
10
debug-profile.patch
Normal file
10
debug-profile.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff --color -ru fido-device-onboard-rs-0.4.0-orig/Cargo.toml fido-device-onboard-rs-0.4.0/Cargo.toml
|
||||
--- fido-device-onboard-rs-0.4.0-orig/Cargo.toml 2022-02-24 20:44:38.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.4.0/Cargo.toml 2022-02-24 21:53:32.785864178 +0100
|
||||
@@ -17,3 +17,6 @@
|
||||
"serviceinfo-api-dev-server",
|
||||
"integration-tests",
|
||||
]
|
||||
+
|
||||
+[profile.release]
|
||||
+debug = true
|
@ -4,7 +4,7 @@
|
||||
%global __cargo_is_lib() false
|
||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||
|
||||
Version: 0.3.0
|
||||
Version: 0.4.0
|
||||
|
||||
%forgemeta
|
||||
|
||||
@ -21,7 +21,7 @@ Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
||||
%endif
|
||||
|
||||
Patch0: kdf.patch
|
||||
Patch0: debug-profile.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
# RHBZ 1869980
|
||||
@ -35,6 +35,7 @@ BuildRequires: rust-packaging
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: golang
|
||||
BuildRequires: tpm2-tss-devel
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
@ -56,7 +57,7 @@ EOF
|
||||
%endif
|
||||
|
||||
%build
|
||||
%{__cargo} build --release --features openssl-kdf/deny_custom,fdo-data-formats/use_noninteroperable_kdf
|
||||
%{__cargo} build --release --features openssl-kdf/deny_custom
|
||||
|
||||
%install
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
||||
@ -65,6 +66,7 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||
# 52fdo
|
||||
@ -75,6 +77,7 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/m
|
||||
|
||||
%package -n fdo-init
|
||||
Summary: dracut module for device initialization
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-init
|
||||
%{summary}
|
||||
|
||||
@ -85,6 +88,7 @@ Summary: dracut module for device initialization
|
||||
|
||||
%package -n fdo-owner-onboarding-server
|
||||
Summary: FDO Owner Onboarding Server implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-owner-onboarding-server
|
||||
%{summary}
|
||||
|
||||
@ -125,6 +129,7 @@ Summary: FDO Rendezvous Server implementation
|
||||
|
||||
%package -n fdo-manufacturing-server
|
||||
Summary: FDO Manufacturing Server implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-manufacturing-server
|
||||
%{summary}
|
||||
|
||||
@ -132,7 +137,6 @@ Summary: FDO Manufacturing Server implementation
|
||||
%license LICENSE
|
||||
%{_libexecdir}/fdo/fdo-manufacturing-server
|
||||
%{_docdir}/fdo/manufacturing-server.yml
|
||||
%{_docdir}/fdo/rendezvous-info.yml
|
||||
%{_unitdir}/fdo-manufacturing-server.service
|
||||
|
||||
%post -n fdo-manufacturing-server
|
||||
@ -146,6 +150,7 @@ Summary: FDO Manufacturing Server implementation
|
||||
|
||||
%package -n fdo-client
|
||||
Summary: FDO Client implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-client
|
||||
%{summary}
|
||||
|
||||
@ -165,15 +170,27 @@ Summary: FDO Client implementation
|
||||
|
||||
%package -n fdo-owner-cli
|
||||
Summary: FDO Owner tools implementation
|
||||
Requires: openssl-devel >= 3.0.1-12
|
||||
%description -n fdo-owner-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-owner-cli
|
||||
%license LICENSE
|
||||
%{_bindir}/fdo-owner-tool
|
||||
%{_docdir}/fdo/owner-addresses.yml
|
||||
|
||||
%package -n fdo-admin-cli
|
||||
Summary: FDO admin tools implementation
|
||||
%description -n fdo-admin-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-admin-cli
|
||||
%license LICENSE
|
||||
%{_bindir}/fdo-admin-tool
|
||||
|
||||
%changelog
|
||||
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
||||
- upgrade to 0.4.0
|
||||
|
||||
* Tue Feb 01 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-1
|
||||
- bump to 0.3.0
|
||||
|
||||
|
37
kdf.patch
37
kdf.patch
@ -1,37 +0,0 @@
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
||||
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
||||
@@ -15,3 +15,7 @@
|
||||
|
||||
"integration-tests",
|
||||
]
|
||||
+
|
||||
+[profile.release]
|
||||
+debug = true
|
||||
+
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
||||
@@ -5,6 +5,7 @@
|
||||
[Service]
|
||||
Type=oneshot
|
||||
EnvironmentFile=-/boot/fdo-client-env
|
||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||
Environment=LOG_LEVEL=info
|
||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
||||
@@ -4,8 +4,9 @@
|
||||
|
||||
[Service]
|
||||
Environment=LOG_LEVEL=info
|
||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
||||
# restart and failure condition
|
||||
|
||||
[Install]
|
||||
-WantedBy=multi-user.target
|
||||
\ No newline at end of file
|
||||
+WantedBy=multi-user.target
|
2
sources
2
sources
@ -3,3 +3,5 @@ SHA512 (fido-device-onboard-rs-0.2.0.tar.gz) = 9d6be123d2b0dc90172600a736a2fedbf
|
||||
SHA512 (fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz) = 2ff9d97a067fd62dd3cdcb9535fe2a6715ad13ed54df787510b028cd135bc99d64a06cc4f0395b27a2476860509e1dfe7711592986f89f62acb42c2f61d7ea67
|
||||
SHA512 (fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz) = 09e23118a29fff21593d6e4f024b050e3df3049a39d796a3c2299a20282f60c54d43c7ac48010b0f08bbb08955be45bf0b50c92e5543cbb3b77ecaa0fcaacdc7
|
||||
SHA512 (fido-device-onboard-rs-0.3.0.tar.gz) = 73174dee1571b13db45314b41a12c0879583238e326b94713163b2158354cd68ac253566453c108a86cd5082b3217a20d179f8de3ab02267abd6fa895c8a5626
|
||||
SHA512 (fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz) = 50db064451da4b3f6d3ab842e2e9aa4a8c14ede8d733aeddfaa5f683b548c6e3e7b6b09e431cc5b8e928b3a5b994f6dd5a47a2fd38a3dcb70bce5c2ec0b64ef2
|
||||
SHA512 (fido-device-onboard-rs-0.4.0.tar.gz) = aa9e295fd3b27f7b81b1b40a9560fedf1ca53e23ac6ab952f29a385b663007db0b9fd003e5d2cacb36893b530e5ab8e02a2518df8643c84e960838302d048db9
|
||||
|
Loading…
Reference in New Issue
Block a user