7ce3755006
Resolves: rhbz#1989923 Signed-off-by: Antonio Murdaca <runcom@linux.com>
38 lines
1.7 KiB
Diff
38 lines
1.7 KiB
Diff
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
|
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
|
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
|
@@ -15,3 +15,7 @@
|
|
|
|
"integration-tests",
|
|
]
|
|
+
|
|
+[profile.release]
|
|
+debug = true
|
|
+
|
|
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
|
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
|
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
|
@@ -5,6 +5,7 @@
|
|
[Service]
|
|
Type=oneshot
|
|
EnvironmentFile=-/boot/fdo-client-env
|
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
Environment=LOG_LEVEL=info
|
|
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
|
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
|
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
|
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
|
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
|
@@ -4,8 +4,9 @@
|
|
|
|
[Service]
|
|
Environment=LOG_LEVEL=info
|
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
|
# restart and failure condition
|
|
|
|
[Install]
|
|
-WantedBy=multi-user.target
|
|
\ No newline at end of file
|
|
+WantedBy=multi-user.target
|