import fido-device-onboard-0.4.0-8.el8
This commit is contained in:
parent
ba442eb8f7
commit
3f694ce5e0
@ -1,2 +1,2 @@
|
|||||||
35944215160d00af8d8553bd85bd9bf7c6129e8b SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
49d6a159dc3e0b2369ffb6ac11bcf41a2c773ac9 SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||||
a1e98d6d0b85fd3f2ab81d9c6179e2cfc5e30d4f SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
a8e4a64065bf7ae103a6bb903c6884a01f07bffb SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||||
SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
||||||
|
57
SOURCES/kdf-debug-profile.patch
Normal file
57
SOURCES/kdf-debug-profile.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/Cargo.toml fido-device-onboard-rs-0.4.0/Cargo.toml
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/Cargo.toml 2022-02-24 20:44:38.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/Cargo.toml 2022-02-25 15:02:08.945332612 +0100
|
||||||
|
@@ -17,3 +17,7 @@
|
||||||
|
"serviceinfo-api-dev-server",
|
||||||
|
"integration-tests",
|
||||||
|
]
|
||||||
|
+
|
||||||
|
+[profile.release]
|
||||||
|
+debug = true
|
||||||
|
+
|
||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.4.0/examples/systemd/fdo-client-linuxapp.service
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-24 20:44:38.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/examples/systemd/fdo-client-linuxapp.service 2022-02-25 15:05:29.705471465 +0100
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
[Service]
|
||||||
|
Type=oneshot
|
||||||
|
EnvironmentFile=-/boot/fdo-client-env
|
||||||
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||||
|
Environment=LOG_LEVEL=info
|
||||||
|
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||||
|
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.4.0/examples/systemd/fdo-owner-onboarding-server.service
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-24 20:44:38.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-25 15:03:10.817375407 +0100
|
||||||
|
@@ -4,8 +4,9 @@
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Environment=LOG_LEVEL=info
|
||||||
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||||
|
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
||||||
|
# restart and failure condition
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
-WantedBy=multi-user.target
|
||||||
|
\ No newline at end of file
|
||||||
|
+WantedBy=multi-user.target
|
||||||
|
Only in fido-device-onboard-rs-0.4.0: kdf-debug-profile.patch
|
||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/vendor/tss-esapi-sys/build.rs fido-device-onboard-rs-0.4.0/vendor/tss-esapi-sys/build.rs
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/vendor/tss-esapi-sys/build.rs 2022-02-25 14:59:52.024237824 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/vendor/tss-esapi-sys/build.rs 2022-02-25 15:01:34.660308864 +0100
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
#[cfg(feature = "generate-bindings")]
|
||||||
|
use std::path::PathBuf;
|
||||||
|
|
||||||
|
-const MINIMUM_VERSION: &str = "2.3.3";
|
||||||
|
+const MINIMUM_VERSION: &str = "2.3.2";
|
||||||
|
|
||||||
|
fn main() {
|
||||||
|
if std::env::var("DOCS_RS").is_ok() {
|
||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/vendor/tss-esapi-sys/.cargo-checksum.json fido-device-onboard-rs-0.4.0/vendor/tss-esapi-sys/.cargo-checksum.json
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/vendor/tss-esapi-sys/.cargo-checksum.json 2022-02-25 14:59:52.025237825 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/vendor/tss-esapi-sys/.cargo-checksum.json 2022-02-25 15:04:18.844422454 +0100
|
||||||
|
@@ -1 +1 @@
|
||||||
|
-{"files":{"Cargo.toml":"cb816c6cd69d7eb4e712c63575fed05fb120ffaf14a6d462dae7e22d86341721","LICENSE":"cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30","README.md":"2cb476d1db06c323503dc6d15e0f5ed5d6f31b940ee19fb6a1267d26ca2ea109","build.rs":"6cc37b07c069d8e4a532922f4f816c51269a3947bc1d64b1ac5c13330da9422c","regenerate-bindings.sh":"adfc0001d4837ea2e82dadb0455b5dd1da24c728e2526ceef9e1774f2dac3174","src/bindings/aarch64-unknown-linux-gnu.rs":"fbeeefd5706344fb9b37e670f0a3ccb410d3686012f64f9b9b25038f3683f9a2","src/bindings/arm-unknown-linux-gnueabi.rs":"17dc8ad101cbec08ba9a9ef55c3c7d101164c35d19cfd694dca7e25a324101bf","src/bindings/x86_64-unknown-darwin.rs":"1a1f2cd427ebb4d4bf102204507f1fa9e2973ecb7ee7f3e27be61f7ae21a9e43","src/bindings/x86_64-unknown-linux-gnu.rs":"31473ca2a2f853acd091dad98605ee02dcdb521b70023fa8e34822b9bac4bdde","src/lib.rs":"d03e402ccd471f25acca136550af86caa33af7714290424b24b236f1ac9e450f"},"package":"0e2f37914ec4d494d145cfa18bb8429498b238d63c47a08b89d09c1ec2545ff0"}
|
||||||
|
\ No newline at end of file
|
||||||
|
+{"files":{"Cargo.toml":"cb816c6cd69d7eb4e712c63575fed05fb120ffaf14a6d462dae7e22d86341721","LICENSE":"cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30","README.md":"2cb476d1db06c323503dc6d15e0f5ed5d6f31b940ee19fb6a1267d26ca2ea109","build.rs":"4c8649e92bafa9834c7db410c08bd5da8017708dec46a7ddbc526a8f86e91f11","regenerate-bindings.sh":"adfc0001d4837ea2e82dadb0455b5dd1da24c728e2526ceef9e1774f2dac3174","src/bindings/aarch64-unknown-linux-gnu.rs":"fbeeefd5706344fb9b37e670f0a3ccb410d3686012f64f9b9b25038f3683f9a2","src/bindings/arm-unknown-linux-gnueabi.rs":"17dc8ad101cbec08ba9a9ef55c3c7d101164c35d19cfd694dca7e25a324101bf","src/bindings/x86_64-unknown-darwin.rs":"1a1f2cd427ebb4d4bf102204507f1fa9e2973ecb7ee7f3e27be61f7ae21a9e43","src/bindings/x86_64-unknown-linux-gnu.rs":"31473ca2a2f853acd091dad98605ee02dcdb521b70023fa8e34822b9bac4bdde","src/lib.rs":"d03e402ccd471f25acca136550af86caa33af7714290424b24b236f1ac9e450f"},"package":"0e2f37914ec4d494d145cfa18bb8429498b238d63c47a08b89d09c1ec2545ff0"}
|
@ -1,37 +0,0 @@
|
|||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
|
||||||
@@ -15,3 +15,7 @@
|
|
||||||
|
|
||||||
"integration-tests",
|
|
||||||
]
|
|
||||||
+
|
|
||||||
+[profile.release]
|
|
||||||
+debug = true
|
|
||||||
+
|
|
||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
[Service]
|
|
||||||
Type=oneshot
|
|
||||||
EnvironmentFile=-/boot/fdo-client-env
|
|
||||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
|
||||||
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
|
||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
|
||||||
@@ -4,8 +4,9 @@
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
|
||||||
# restart and failure condition
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
-WantedBy=multi-user.target
|
|
||||||
\ No newline at end of file
|
|
||||||
+WantedBy=multi-user.target
|
|
@ -4,12 +4,12 @@
|
|||||||
%global __cargo_is_lib() false
|
%global __cargo_is_lib() false
|
||||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
|
|
||||||
Version: 0.3.0
|
Version: 0.4.0
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
Name: fido-device-onboard
|
Name: fido-device-onboard
|
||||||
Release: 4%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -21,7 +21,7 @@ Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
|||||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch0: kdf.patch
|
Patch0: kdf-debug-profile.patch
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
# RHBZ 1869980
|
# RHBZ 1869980
|
||||||
@ -35,18 +35,19 @@ BuildRequires: rust-packaging
|
|||||||
BuildRequires: systemd-rpm-macros
|
BuildRequires: systemd-rpm-macros
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: golang
|
BuildRequires: golang
|
||||||
|
BuildRequires: tpm2-tss-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%forgesetup
|
%forgesetup
|
||||||
%patch0 -p1
|
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
%cargo_prep -V 1
|
%cargo_prep -V 1
|
||||||
%else
|
%else
|
||||||
%cargo_prep
|
%cargo_prep
|
||||||
%endif
|
%endif
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__cargo} build --release --features "openssl-kdf/deny_custom,fdo-data-formats/use_noninteroperable_kdf"
|
%{__cargo} build --release --features "openssl-kdf/deny_custom,fdo-data-formats/use_noninteroperable_kdf"
|
||||||
@ -58,6 +59,7 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
|||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||||
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||||
# 52fdo
|
# 52fdo
|
||||||
@ -125,7 +127,6 @@ Summary: FDO Manufacturing Server implementation
|
|||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_libexecdir}/fdo/fdo-manufacturing-server
|
%{_libexecdir}/fdo/fdo-manufacturing-server
|
||||||
%{_docdir}/fdo/manufacturing-server.yml
|
%{_docdir}/fdo/manufacturing-server.yml
|
||||||
%{_docdir}/fdo/rendezvous-info.yml
|
|
||||||
%{_unitdir}/fdo-manufacturing-server.service
|
%{_unitdir}/fdo-manufacturing-server.service
|
||||||
|
|
||||||
%post -n fdo-manufacturing-server
|
%post -n fdo-manufacturing-server
|
||||||
@ -164,9 +165,41 @@ Summary: FDO Owner tools implementation
|
|||||||
%files -n fdo-owner-cli
|
%files -n fdo-owner-cli
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/fdo-owner-tool
|
%{_bindir}/fdo-owner-tool
|
||||||
%{_docdir}/fdo/owner-addresses.yml
|
|
||||||
|
%package -n fdo-admin-cli
|
||||||
|
Summary: FDO admin tools implementation
|
||||||
|
%description -n fdo-admin-cli
|
||||||
|
%{summary}
|
||||||
|
|
||||||
|
%files -n fdo-admin-cli
|
||||||
|
%license LICENSE
|
||||||
|
%{_bindir}/fdo-admin-tool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 25 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-8
|
||||||
|
- attempt #1 to fix checksums
|
||||||
|
|
||||||
|
* Fri Feb 25 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-7
|
||||||
|
- patch the right vendor/tss-esapi-sys
|
||||||
|
|
||||||
|
* Fri Feb 25 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-6
|
||||||
|
- patch Cargo.toml to ignore Cargo.lock for hash checks of tss-esapi-sys
|
||||||
|
|
||||||
|
* Fri Feb 25 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-5
|
||||||
|
- patch tss-esapi-sys/build.rs to require 2.3.2
|
||||||
|
|
||||||
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-4
|
||||||
|
- rebuilt with tpm2-tss-devel build require
|
||||||
|
|
||||||
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-3
|
||||||
|
- rebuilt to use the correct patch for the 0.4.0 source
|
||||||
|
|
||||||
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-2
|
||||||
|
- rebuilt to use the correct 0.4.0 source archive
|
||||||
|
|
||||||
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
||||||
|
- upgrade to 0.4.0
|
||||||
|
|
||||||
* Thu Feb 03 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-4
|
* Thu Feb 03 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-4
|
||||||
- revert and add missing %patch call
|
- revert and add missing %patch call
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user