import fido-device-onboard-0.3.0-4.el8
This commit is contained in:
parent
189a4cd51d
commit
ba442eb8f7
@ -1,2 +1,2 @@
|
||||
d87f6f6fe5179e4b756d48f5a4785f76efa44047 SOURCES/fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz
|
||||
fd0c6fbe8f2ae8b411093ac8d6e1a7f96a1e082a SOURCES/fido-device-onboard-rs-0.2.0.tar.gz
|
||||
35944215160d00af8d8553bd85bd9bf7c6129e8b SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||
a1e98d6d0b85fd3f2ab81d9c6179e2cfc5e30d4f SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz
|
||||
SOURCES/fido-device-onboard-rs-0.2.0.tar.gz
|
||||
SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||
SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
||||
|
@ -1,39 +0,0 @@
|
||||
From 1926138487c4e903f42b8bb1a015d81f0da74193 Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Murdaca <runcom@linux.com>
|
||||
Date: Fri, 10 Dec 2021 14:55:01 +0100
|
||||
Subject: [PATCH] chore: add ALLOW_NONINTEROPABLE_KDF for client and onboarding
|
||||
unit
|
||||
|
||||
Signed-off-by: Antonio Murdaca <runcom@linux.com>
|
||||
---
|
||||
examples/systemd/fdo-client-linuxapp.service | 1 +
|
||||
examples/systemd/fdo-owner-onboarding-server.service | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/examples/systemd/fdo-client-linuxapp.service b/examples/systemd/fdo-client-linuxapp.service
|
||||
index 4a4d8a2..9b78dde 100644
|
||||
--- a/examples/systemd/fdo-client-linuxapp.service
|
||||
+++ b/examples/systemd/fdo-client-linuxapp.service
|
||||
@@ -7,6 +7,7 @@ After=network-online.target
|
||||
Type=oneshot
|
||||
Environment=DEVICE_CREDENTIAL=/boot/device-credentials
|
||||
Environment=LOG_LEVEL=info
|
||||
+Environment=ALLOW_NONINTEROPABLE_KDF=1
|
||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||
ExecStartPost=/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||
|
||||
diff --git a/examples/systemd/fdo-owner-onboarding-server.service b/examples/systemd/fdo-owner-onboarding-server.service
|
||||
index 97d3ee4..48ce0c2 100644
|
||||
--- a/examples/systemd/fdo-owner-onboarding-server.service
|
||||
+++ b/examples/systemd/fdo-owner-onboarding-server.service
|
||||
@@ -4,6 +4,7 @@ After=network-online.target
|
||||
|
||||
[Service]
|
||||
Environment=LOG_LEVEL=info
|
||||
+Environment=ALLOW_NONINTEROPABLE_KDF=1
|
||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
||||
# restart and failure condition
|
||||
|
||||
--
|
||||
2.33.1
|
||||
|
37
SOURCES/kdf.patch
Normal file
37
SOURCES/kdf.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
||||
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
||||
@@ -15,3 +15,7 @@
|
||||
|
||||
"integration-tests",
|
||||
]
|
||||
+
|
||||
+[profile.release]
|
||||
+debug = true
|
||||
+
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
||||
@@ -5,6 +5,7 @@
|
||||
[Service]
|
||||
Type=oneshot
|
||||
EnvironmentFile=-/boot/fdo-client-env
|
||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||
Environment=LOG_LEVEL=info
|
||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
||||
@@ -4,8 +4,9 @@
|
||||
|
||||
[Service]
|
||||
Environment=LOG_LEVEL=info
|
||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
||||
# restart and failure condition
|
||||
|
||||
[Install]
|
||||
-WantedBy=multi-user.target
|
||||
\ No newline at end of file
|
||||
+WantedBy=multi-user.target
|
@ -4,25 +4,24 @@
|
||||
%global __cargo_is_lib() false
|
||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||
|
||||
Version: 0.2.0
|
||||
Version: 0.3.0
|
||||
|
||||
%forgemeta
|
||||
|
||||
Name: fido-device-onboard
|
||||
Release: 5%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
||||
|
||||
License: BSD 3
|
||||
License: BSD
|
||||
URL: %{forgeurl}
|
||||
Source: %{forgesource}
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
%if "%{?commit}" != ""
|
||||
Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
||||
%else
|
||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
||||
%endif
|
||||
%endif
|
||||
Patch0: 0001-chore-add-ALLOW_NONINTEROPABLE_KDF-for-client-and-on.patch
|
||||
|
||||
Patch0: kdf.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
# RHBZ 1869980
|
||||
@ -42,6 +41,7 @@ BuildRequires: golang
|
||||
|
||||
%prep
|
||||
%forgesetup
|
||||
%patch0 -p1
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
%cargo_prep -V 1
|
||||
%else
|
||||
@ -167,6 +167,18 @@ Summary: FDO Owner tools implementation
|
||||
%{_docdir}/fdo/owner-addresses.yml
|
||||
|
||||
%changelog
|
||||
* Thu Feb 03 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-4
|
||||
- revert and add missing %patch call
|
||||
|
||||
* Thu Feb 03 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-3
|
||||
- rebuilt to drop commit conditional or patch doesn't work
|
||||
|
||||
* Thu Feb 03 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-2
|
||||
- rebuilt to drop faulty conditional
|
||||
|
||||
* Tue Feb 01 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-1
|
||||
- bump to v0.3.0
|
||||
|
||||
* Mon Jan 10 2022 Antonio Murdaca <runcom@linux.com> - 0.2.0-5
|
||||
- rebuilt dropping vendored exe(s) files (dll and .a)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user