- fence_mpath: add support for hex-key format (used in multipath.conf)
Resolves: RHEL-56138 - fence_scsi/fence_mpath: add support for SPC-4 disks Resolves: RHEL-76298
This commit is contained in:
parent
be11154c5e
commit
8c35d22f8b
10
RHEL-56138-fence_mpath-support-hex-key-format.patch
Normal file
10
RHEL-56138-fence_mpath-support-hex-key-format.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/agents/mpath/fence_mpath.py 2024-10-09 14:56:07.688665678 +0200
|
||||
+++ b/agents/mpath/fence_mpath.py 2024-10-09 14:56:12.639780798 +0200
|
||||
@@ -323,6 +323,7 @@
|
||||
fail_usage("Failed: No devices found")
|
||||
|
||||
options["devices"] = [d for d in re.split("\s*,\s*|\s+", options["--devices"].strip()) if d]
|
||||
+ options["--plug"] = re.sub(r"^0x0*|^0+", "", options["--plug"])
|
||||
# Input control END
|
||||
|
||||
result = fence_action(None, options, set_status, get_status)
|
@ -57,7 +57,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.10.0
|
||||
Release: 77%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 78%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
||||
@ -242,6 +242,7 @@ Patch55: RHEL-25256-fence_vmware_rest-detect-user-sufficient-rights.patch
|
||||
Patch56: RHEL-43235-fence_aws-1-list-add-instance-name-status.patch
|
||||
Patch57: RHEL-43235-fence_aws-2-log-error-for-unknown-states.patch
|
||||
Patch58: RHEL-59878-fence_scsi-only-preempt-once-for-mpath-devices.patch
|
||||
Patch59: RHEL-56138-fence_mpath-support-hex-key-format.patch
|
||||
|
||||
### HA support libs/utils ###
|
||||
# all archs
|
||||
@ -422,6 +423,7 @@ BuildRequires: %{systemd_units}
|
||||
%patch -p1 -P 56
|
||||
%patch -p1 -P 57
|
||||
%patch -p1 -P 58
|
||||
%patch -p1 -P 59
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1505,6 +1507,12 @@ are located on corosync cluster nodes.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 9 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-78
|
||||
- fence_mpath: add support for hex-key format (used in multipath.conf)
|
||||
Resolves: RHEL-56138
|
||||
- fence_scsi/fence_mpath: add support for SPC-4 disks
|
||||
Resolves: RHEL-76298
|
||||
|
||||
* Wed Sep 25 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-77
|
||||
- fence_scsi: preempt clears all devices on the mpath device, so only
|
||||
run it for the first device
|
||||
|
Loading…
Reference in New Issue
Block a user