- fence_scsi: preempt clears all devices on the mpath device, so only

run it for the first device
  Resolves: RHEL-59878
- ha-cloud-support: remove bundled awscli and use awscli2 package
  instead
  Resolves: RHEL-60020
This commit is contained in:
Oyvind Albrigtsen 2024-09-25 14:53:01 +02:00
parent 421662a524
commit be11154c5e
5 changed files with 138 additions and 159 deletions

View File

@ -15,22 +15,6 @@ Subject: [PATCH] Merge pull request from GHSA-34jh-p97f-mpxf
test/with_dummyserver/test_poolmanager.py | 27 ++++++++++++++++++++---
4 files changed, 37 insertions(+), 5 deletions(-)
diff --git a/awscli/urllib3/util/retry.py b/awscli/urllib3/util/retry.py
index 7a76a4a6ad..0456cceba4 100644
--- a/awscli/urllib3/util/retry.py
+++ b/awscli/urllib3/util/retry.py
@@ -189,7 +189,9 @@ class Retry:
RETRY_AFTER_STATUS_CODES = frozenset([413, 429, 503])
#: Default headers to be used for ``remove_headers_on_redirect``
- DEFAULT_REMOVE_HEADERS_ON_REDIRECT = frozenset(["Cookie", "Authorization"])
+ DEFAULT_REMOVE_HEADERS_ON_REDIRECT = frozenset(
+ ["Cookie", "Authorization", "Proxy-Authorization"]
+ )
#: Default maximum backoff time.
DEFAULT_BACKOFF_MAX = 120
diff --git a/aws/urllib3/util/retry.py b/aws/urllib3/util/retry.py
index 7a76a4a6ad..0456cceba4 100644
--- a/aws/urllib3/util/retry.py

View File

@ -0,0 +1,40 @@
From cb57f1c2ee734a40d01249305965ea4ecdf02039 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Thu, 5 Sep 2024 09:06:34 +0200
Subject: [PATCH] fence_scsi: preempt clears all devices on the mpath device,
so only run it for the first device
---
agents/scsi/fence_scsi.py | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/agents/scsi/fence_scsi.py b/agents/scsi/fence_scsi.py
index a1598411c..12f7fb49b 100644
--- a/agents/scsi/fence_scsi.py
+++ b/agents/scsi/fence_scsi.py
@@ -131,11 +131,13 @@ def reset_dev(options, dev):
return run_cmd(options, options["--sg_turs-path"] + " " + dev)["rc"]
-def register_dev(options, dev, key):
+def register_dev(options, dev, key, do_preempt=True):
dev = os.path.realpath(dev)
if re.search(r"^dm", dev[5:]):
- for slave in get_mpath_slaves(dev):
- register_dev(options, slave, key)
+ devices = get_mpath_slaves(dev)
+ register_dev(options, devices[0], key)
+ for device in devices[1:]:
+ register_dev(options, device, key, False)
return True
# Check if any registration exists for the key already. We track this in
@@ -153,7 +155,7 @@ def register_dev(options, dev, key):
# If key matches, make sure it matches with the connection that
# exists right now. To do this, we can issue a preempt with same key
# which should replace the old invalid entries from the target.
- if not preempt(options, key, dev, key):
+ if do_preempt and not preempt(options, key, dev, key):
return False
# If there was no reservation, we need to issue another registration

View File

@ -15,23 +15,6 @@
_run_zic(zonedir, filepaths)
--- a/awscli/dateutil/zoneinfo/rebuild.py 2023-01-26 16:29:30.000000000 +0100
+++ b/awscli/dateutil/zoneinfo/rebuild.py 2023-07-19 10:12:42.277559948 +0200
@@ -21,7 +21,12 @@
try:
with TarFile.open(filename) as tf:
for name in zonegroups:
- tf.extract(name, tmpdir)
+ if hasattr(tarfile, 'data_filter'):
+ # Python with CVE-2007-4559 mitigation (PEP 706)
+ tf.extract(name, tmpdir, filter='data')
+ else:
+ # Fallback to a possibly dangerous extraction (before PEP 706)
+ tf.extract(name, tmpdir)
filepaths = [os.path.join(tmpdir, n) for n in zonegroups]
_run_zic(zonedir, filepaths)
--- a/azure/dateutil/zoneinfo/rebuild.py 2023-01-26 16:29:30.000000000 +0100
+++ b/azure/dateutil/zoneinfo/rebuild.py 2023-07-19 10:12:42.277559948 +0200
@@ -21,7 +21,12 @@

View File

@ -57,7 +57,7 @@
Name: fence-agents
Summary: Set of unified programs capable of host isolation ("fencing")
Version: 4.10.0
Release: 76%{?alphatag:.%{alphatag}}%{?dist}
Release: 77%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2+ and LGPLv2+
URL: https://github.com/ClusterLabs/fence-agents
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
@ -68,10 +68,6 @@ Source102: requirements-azure.txt
Source103: requirements-google.txt
Source104: requirements-common.txt
### HA support libs/utils ###
# awscli 2+ is only available from github (and needs to be renamed from aws-cli... to awscli)
Source900: awscli-2.2.15.tar.gz
# From awscli's requirements.txt: https://github.com/boto/botocore/zipball/v2#egg=botocore
Source901: botocore-2.0.0dev123.zip
# update with ./update-ha-support.sh and replace lines below with output
### BEGIN ###
# aliyun
@ -92,108 +88,99 @@ Source2000: aliyun-cli-3.0.198.tar.gz
Source2001: aliyun-openapi-meta-5cf98b660.tar.gz
## go mod vendor
Source2002: aliyun-cli-go-vendor.tar.gz
# awscli
Source1008: awscrt-0.11.13-cp39-cp39-manylinux2014_x86_64.whl
Source1009: colorama-0.4.3-py2.py3-none-any.whl
Source1010: cryptography-3.3.2-cp36-abi3-manylinux2010_x86_64.whl
Source1011: distro-1.5.0-py2.py3-none-any.whl
Source1012: docutils-0.15.2-py3-none-any.whl
Source1013: prompt_toolkit-2.0.10-py3-none-any.whl
Source1014: ruamel.yaml-0.15.100.tar.gz
Source1015: six-1.16.0-py2.py3-none-any.whl
Source1016: wcwidth-0.1.9-py2.py3-none-any.whl
# aws
Source1017: boto3-1.17.102-py2.py3-none-any.whl
Source1018: botocore-1.20.102-py2.py3-none-any.whl
Source1019: python_dateutil-2.8.1-py2.py3-none-any.whl
Source1020: s3transfer-0.4.2-py2.py3-none-any.whl
Source1021: urllib3-1.26.18.tar.gz
Source1007: boto3-1.17.102-py2.py3-none-any.whl
Source1008: botocore-1.20.102-py2.py3-none-any.whl
Source1009: python_dateutil-2.8.1-py2.py3-none-any.whl
Source1010: s3transfer-0.4.2-py2.py3-none-any.whl
Source1011: urllib3-1.26.18.tar.gz
# azure
Source1022: adal-1.2.7-py2.py3-none-any.whl
Source1023: azure_common-1.1.27-py2.py3-none-any.whl
Source1024: azure_core-1.15.0-py2.py3-none-any.whl
Source1025: azure_mgmt_compute-21.0.0-py2.py3-none-any.whl
Source1026: azure_mgmt_core-1.2.2-py2.py3-none-any.whl
Source1027: azure_mgmt_network-19.0.0-py2.py3-none-any.whl
Source1028: azure-identity-1.10.0.zip
Source1029: chardet-4.0.0-py2.py3-none-any.whl
Source1030: idna-2.10-py2.py3-none-any.whl
Source1031: isodate-0.6.0-py2.py3-none-any.whl
Source1032: msrest-0.6.21-py2.py3-none-any.whl
Source1033: msrestazure-0.6.4-py2.py3-none-any.whl
Source1034: %{oauthlib}-%{oauthlib_version}.tar.gz
Source1035: PyJWT-2.1.0-py3-none-any.whl
Source1036: requests-2.25.1-py2.py3-none-any.whl
Source1037: requests_oauthlib-1.3.0-py2.py3-none-any.whl
Source1038: msal-1.18.0.tar.gz
Source1039: msal-extensions-1.0.0.tar.gz
Source1040: portalocker-2.5.1.tar.gz
Source1012: adal-1.2.7-py2.py3-none-any.whl
Source1013: azure_common-1.1.27-py2.py3-none-any.whl
Source1014: azure_core-1.15.0-py2.py3-none-any.whl
Source1015: azure_mgmt_compute-21.0.0-py2.py3-none-any.whl
Source1016: azure_mgmt_core-1.2.2-py2.py3-none-any.whl
Source1017: azure_mgmt_network-19.0.0-py2.py3-none-any.whl
Source1018: azure-identity-1.10.0.zip
Source1019: chardet-4.0.0-py2.py3-none-any.whl
Source1020: idna-2.10-py2.py3-none-any.whl
Source1021: isodate-0.6.0-py2.py3-none-any.whl
Source1022: msrest-0.6.21-py2.py3-none-any.whl
Source1023: msrestazure-0.6.4-py2.py3-none-any.whl
Source1024: %{oauthlib}-%{oauthlib_version}.tar.gz
Source1025: PyJWT-2.1.0-py3-none-any.whl
Source1026: requests-2.25.1-py2.py3-none-any.whl
Source1027: requests_oauthlib-1.3.0-py2.py3-none-any.whl
Source1028: msal-1.18.0.tar.gz
Source1029: msal-extensions-1.0.0.tar.gz
Source1030: portalocker-2.5.1.tar.gz
Source1031: cryptography-3.3.2-cp36-abi3-manylinux2010_x86_64.whl
# google
Source1041: cachetools-4.2.2-py3-none-any.whl
Source1042: chardet-3.0.4-py2.py3-none-any.whl
Source1043: google_api_core-1.30.0-py2.py3-none-any.whl
Source1044: google_api_python_client-1.12.8-py2.py3-none-any.whl
Source1045: googleapis_common_protos-1.53.0-py2.py3-none-any.whl
Source1046: google_auth-1.32.0-py2.py3-none-any.whl
Source1047: google_auth_httplib2-0.1.0-py2.py3-none-any.whl
Source1048: httplib2-0.19.1-py3-none-any.whl
Source1049: packaging-20.9-py2.py3-none-any.whl
Source1050: protobuf-3.17.3-cp39-cp39-manylinux_2_5_x86_64.manylinux1_x86_64.whl
Source1051: pyasn1-0.4.8-py2.py3-none-any.whl
Source1052: pyasn1_modules-0.2.8-py2.py3-none-any.whl
Source1053: pyparsing-2.4.7-py2.py3-none-any.whl
Source1054: pyroute2-0.7.12.tar.gz
Source1055: pyroute2.core-0.6.13.tar.gz
Source1056: pyroute2.ethtool-0.6.13.tar.gz
Source1057: pyroute2.ipdb-0.6.13.tar.gz
Source1058: pyroute2.ipset-0.6.13.tar.gz
Source1059: pyroute2.ndb-0.6.13.tar.gz
Source1060: pyroute2.nftables-0.6.13.tar.gz
Source1061: pyroute2.nslink-0.6.13.tar.gz
Source1062: pytz-2021.1-py2.py3-none-any.whl
Source1063: rsa-4.7.2-py3-none-any.whl
Source1064: setuptools-71.1.0.tar.gz
Source1065: uritemplate-3.0.1-py2.py3-none-any.whl
Source1032: cachetools-4.2.2-py3-none-any.whl
Source1033: chardet-3.0.4-py2.py3-none-any.whl
Source1034: google_api_core-1.30.0-py2.py3-none-any.whl
Source1035: google_api_python_client-1.12.8-py2.py3-none-any.whl
Source1036: googleapis_common_protos-1.53.0-py2.py3-none-any.whl
Source1037: google_auth-1.32.0-py2.py3-none-any.whl
Source1038: google_auth_httplib2-0.1.0-py2.py3-none-any.whl
Source1039: httplib2-0.19.1-py3-none-any.whl
Source1040: packaging-20.9-py2.py3-none-any.whl
Source1041: protobuf-3.17.3-cp39-cp39-manylinux_2_5_x86_64.manylinux1_x86_64.whl
Source1042: pyasn1-0.4.8-py2.py3-none-any.whl
Source1043: pyasn1_modules-0.2.8-py2.py3-none-any.whl
Source1044: pyparsing-2.4.7-py2.py3-none-any.whl
Source1045: pyroute2-0.7.12.tar.gz
Source1046: pyroute2.core-0.6.13.tar.gz
Source1047: pyroute2.ethtool-0.6.13.tar.gz
Source1048: pyroute2.ipdb-0.6.13.tar.gz
Source1049: pyroute2.ipset-0.6.13.tar.gz
Source1050: pyroute2.ndb-0.6.13.tar.gz
Source1051: pyroute2.nftables-0.6.13.tar.gz
Source1052: pyroute2.nslink-0.6.13.tar.gz
Source1053: pytz-2021.1-py2.py3-none-any.whl
Source1054: rsa-4.7.2-py3-none-any.whl
Source1055: setuptools-71.1.0.tar.gz
Source1056: uritemplate-3.0.1-py2.py3-none-any.whl
# common (pexpect / suds)
Source1066: pexpect-4.8.0-py2.py3-none-any.whl
Source1067: ptyprocess-0.7.0-py2.py3-none-any.whl
Source1068: suds_community-0.8.5-py3-none-any.whl
Source1057: pexpect-4.8.0-py2.py3-none-any.whl
Source1058: ptyprocess-0.7.0-py2.py3-none-any.whl
Source1059: suds_community-0.8.5-py3-none-any.whl
### END ###
# kubevirt
## pip download --no-binary :all: openshift "ruamel.yaml.clib>=0.1.2"
### BEGIN
Source1069: %{openshift}-%{openshift_version}.tar.gz
Source1070: %{ruamelyamlclib}-%{ruamelyamlclib_version}.tar.gz
Source1071: %{kubernetes}-%{kubernetes_version}.tar.gz
Source1072: %{certifi}-%{certifi_version}.tar.gz
Source1073: %{googleauth}-%{googleauth_version}.tar.gz
Source1074: %{cachetools}-%{cachetools_version}.tar.gz
Source1075: %{pyasn1modules}-%{pyasn1modules_version}.tar.gz
Source1076: %{pyasn1}-%{pyasn1_version}.tar.gz
Source1077: python-%{dateutil}-%{dateutil_version}.tar.gz
Source1078: %{pyyaml}-%{pyyaml_version}.tar.gz
Source1060: %{openshift}-%{openshift_version}.tar.gz
Source1061: %{ruamelyamlclib}-%{ruamelyamlclib_version}.tar.gz
Source1062: %{kubernetes}-%{kubernetes_version}.tar.gz
Source1063: %{certifi}-%{certifi_version}.tar.gz
Source1064: %{googleauth}-%{googleauth_version}.tar.gz
Source1065: %{cachetools}-%{cachetools_version}.tar.gz
Source1066: %{pyasn1modules}-%{pyasn1modules_version}.tar.gz
Source1067: %{pyasn1}-%{pyasn1_version}.tar.gz
Source1068: python-%{dateutil}-%{dateutil_version}.tar.gz
Source1069: %{pyyaml}-%{pyyaml_version}.tar.gz
## rsa is dependency for "pip install",
## but gets removed to use cryptography lib instead
Source1079: rsa-4.7.2.tar.gz
Source1080: %{six}-%{six_version}.tar.gz
Source1081: %{websocketclient}-%{websocketclient_version}.tar.gz
Source1082: %{jinja2}-%{jinja2_version}.tar.gz
Source1083: %{markupsafe}-%{markupsafe_version}.tar.gz
Source1084: python-%{stringutils}-%{stringutils_version}.tar.gz
Source1085: %{requests}-%{requests_version}.tar.gz
Source1086: %{chrstnormalizer}-%{chrstnormalizer_version}.tar.gz
Source1087: %{idna}-%{idna_version}.tar.gz
Source1088: %{reqstsoauthlib}-%{reqstsoauthlib_version}.tar.gz
Source1089: %{ruamelyaml}-%{ruamelyaml_version}.tar.gz
Source1070: rsa-4.7.2.tar.gz
Source1071: %{six}-%{six_version}.tar.gz
Source1072: %{websocketclient}-%{websocketclient_version}.tar.gz
Source1073: %{jinja2}-%{jinja2_version}.tar.gz
Source1074: %{markupsafe}-%{markupsafe_version}.tar.gz
Source1075: python-%{stringutils}-%{stringutils_version}.tar.gz
Source1076: %{requests}-%{requests_version}.tar.gz
Source1077: %{chrstnormalizer}-%{chrstnormalizer_version}.tar.gz
Source1078: %{idna}-%{idna_version}.tar.gz
Source1079: %{reqstsoauthlib}-%{reqstsoauthlib_version}.tar.gz
Source1080: %{ruamelyaml}-%{ruamelyaml_version}.tar.gz
## required for installation
Source1090: setuptools_scm-8.1.0.tar.gz
Source1091: packaging-21.2-py3-none-any.whl
Source1092: poetry-core-1.0.7.tar.gz
Source1093: pyparsing-3.0.1.tar.gz
Source1094: tomli-2.0.1.tar.gz
Source1095: flit_core-3.9.0.tar.gz
Source1096: typing_extensions-4.12.2.tar.gz
Source1097: wheel-0.37.0-py2.py3-none-any.whl
Source1081: setuptools_scm-8.1.0.tar.gz
Source1082: packaging-21.2-py3-none-any.whl
Source1083: poetry-core-1.0.7.tar.gz
Source1084: pyparsing-3.0.1.tar.gz
Source1085: tomli-2.0.1.tar.gz
Source1086: flit_core-3.9.0.tar.gz
Source1087: typing_extensions-4.12.2.tar.gz
Source1088: wheel-0.37.0-py2.py3-none-any.whl
### END
Patch0: ha-cloud-support-aliyun.patch
@ -254,13 +241,14 @@ Patch54: RHEL-35263-fence_eps-add-fence_epsr2-for-ePowerSwitch-R2-and-newer.patc
Patch55: RHEL-25256-fence_vmware_rest-detect-user-sufficient-rights.patch
Patch56: RHEL-43235-fence_aws-1-list-add-instance-name-status.patch
Patch57: RHEL-43235-fence_aws-2-log-error-for-unknown-states.patch
Patch58: RHEL-59878-fence_scsi-only-preempt-once-for-mpath-devices.patch
### HA support libs/utils ###
# all archs
Patch1000: bz2217902-1-kubevirt-fix-bundled-dateutil-CVE-2007-4559.patch
Patch1001: RHEL-35649-kubevirt-fix-bundled-jinja2-CVE-2024-34064.patch
# cloud (x86_64 only)
Patch2000: bz2217902-2-aws-awscli-azure-fix-bundled-dateutil-CVE-2007-4559.patch
Patch2000: bz2217902-2-aws-azure-fix-bundled-dateutil-CVE-2007-4559.patch
Patch2001: RHEL-43562-fix-bundled-urllib3-CVE-2024-37891.patch
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
@ -433,6 +421,7 @@ BuildRequires: %{systemd_units}
%patch -p1 -P 55
%patch -p1 -P 56
%patch -p1 -P 57
%patch -p1 -P 58
# prevent compilation of something that won't get used anyway
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
@ -463,7 +452,6 @@ popd
# support libs
%ifarch x86_64
LIBS="%{_sourcedir}/requirements-*.txt"
echo "awscli" >> %{_sourcedir}/requirements-awscli.txt
%endif
%ifnarch x86_64
LIBS="%{_sourcedir}/requirements-common.txt"
@ -474,11 +462,7 @@ done
# fix incorrect #! detected by CI
%ifarch x86_64
sed -i -e "/^#\!\/Users/c#\!%{__python3}" support/aws/bin/jp support/awscli/bin/jp
%endif
%ifarch x86_64
sed -i -e "/^import awscli.clidriver/isys.path.insert(0, '/usr/lib/%{name}/support/awscli')" support/awscli/bin/aws
sed -i -e "/^#\!\/Users/c#\!%{__python3}" support/aws/bin/jp
%endif
# kubevirt
@ -619,6 +603,7 @@ This package contains support files including the Python fencing library.
%package -n ha-cloud-support
License: GPL-2.0-or-later AND LGPL-2.0-or-later AND LGPL-2.1-or-later AND Apache-2.0 AND MIT AND BSD-2-Clause AND BSD-3-Clause AND MPL-2.0 AND Apache-2.0 AND PSF-2.0 AND Unlicense AND ISC
Summary: Support libraries for HA Cloud agents
Requires: awscli2
# aliyun
Provides: bundled(python-aliyun-python-sdk-core) = 2.11.5
Provides: bundled(python-aliyun-python-sdk-ecs) = 4.24.7
@ -629,17 +614,6 @@ Provides: bundled(python-pycryptodome) = 3.20.0
Provides: bundled(python-pycparser) = 2.20
Provides: bundled(aliyun-cli) = 3.0.198
Provides: bundled(aliyun-openapi-meta) = 5cf98b660
# awscli
Provides: bundled(awscli) = 2.2.15
Provides: bundled(python-awscrt) = 0.11.13
Provides: bundled(python-colorama) = 0.4.3
Provides: bundled(python-cryptography) = 3.3.2
Provides: bundled(python-distro) = 1.5.0
Provides: bundled(python-docutils) = 0.15.2
Provides: bundled(python-prompt-toolkit) = 2.0.10
Provides: bundled(python-ruamel-yaml) = 0.15.100
Provides: bundled(python-six) = 1.16.0
Provides: bundled(python-wcwidth) = 0.1.9
# aws
Provides: bundled(python-boto3) = 1.17.102
Provides: bundled(python-botocore) = 1.20.102
@ -655,6 +629,7 @@ Provides: bundled(python-azure-mgmt-core) = 1.2.2
Provides: bundled(python-azure-mgmt-network) = 19.0.0
Provides: bundled(python-certifi) = %{certifi_version}
Provides: bundled(python-chardet) = 4.0.0
Provides: bundled(python-cryptography) = 3.3.2
Provides: bundled(python-idna) = 2.10
Provides: bundled(python-isodate) = 0.6.0
Provides: bundled(python-msrest) = 0.6.21
@ -1530,9 +1505,16 @@ are located on corosync cluster nodes.
%endif
%changelog
* Wed Sep 25 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-77
- fence_scsi: preempt clears all devices on the mpath device, so only
run it for the first device
Resolves: RHEL-59878
- ha-cloud-support: remove bundled awscli and use awscli2 package
instead
Resolves: RHEL-60020
* Tue Jul 23 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-76
- bundled setuptools: fix CVE-2024-6345
Resolves: RHEL-49658
* Fri Jun 21 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-75

12
sources
View File

@ -1,6 +1,4 @@
SHA512 (fence-agents-4.10.0.tar.gz) = 9b867c420730106c07c8d9352b5d17c473642443bb0ff9bd94597722198b295c3b41663fa5c8267bdf44153dbbafe644c3701728b39293fcb9a67b9734d488c2
SHA512 (awscli-2.2.15.tar.gz) = 4fe4f360e7b25ab3fa7b6659a7300875cf7a9c0bad2c9dbcbec25b85bda6ccb25511a44d24ebc60db8eee59de81fe586254f2990339bda8dcab93f9f1253e39e
SHA512 (botocore-2.0.0dev123.zip) = 72e436421010f54b45aeb7d0b9dd2c22f4273f2ba702b30a214288a0c83d9a6da99ecb70f6d9aeb054c536acd0bb9ce9e9a89bf794de81020fea75d0eae16eca
SHA512 (requirements-aliyun.txt) = 0c4f89de63246c406535ee73310232f3986b37dedbeed52f25000386d73af6735e1bf8e7ecaa97419df98f55058d76e4ff289d856b815afaaaf69744c5924f7e
SHA512 (requirements-aws.txt) = ca39604d09f4b05589ddaa437be13b7f5d1868218745df107564d73a6c32efb7e4761436197a69653edc47a78f40dd7d5f0894935ec21b8f23b7c7bc71dfd0d1
SHA512 (requirements-azure.txt) = 8071c96bb3e2b82852b10fd68b77b69a7fce6153ab315298ceb07456fe66f3aca056d3273f11eb87ff30049759e8b4fddf62e39acb91953d36e933e44dce8c9b
@ -16,15 +14,6 @@ SHA512 (pycparser-2.20-py2.py3-none-any.whl) = 06dc9cefdcde6b97c96d0452a77db42a6
SHA512 (aliyun-cli-3.0.198.tar.gz) = d39f36205c1325ab7596da836d59db458beb877f870ddb9e61e85bc6a2be07c1db9042417fc0ef0edd82d307b0f45577ca62f977f37701215f50a806a4dc6473
SHA512 (aliyun-cli-go-vendor.tar.gz) = 0e545d545245051efc10acdb3d0f22d3b81f60c5946f8479e5a0df16a8bcb390763212ca59ff9298633432434ebb221cce9a35e1bf00db9245eba32bfb84eb23
SHA512 (aliyun-openapi-meta-5cf98b660.tar.gz) = 0476feef9085f77a60ef80ae06ca703af0be807d3bdf1a9a7dfffb415409c1c45fcd184c86346c22a48b5794f84cebc410eeee2dfbf7dcef91c79c6fea8e15b9
SHA512 (awscrt-0.11.13-cp39-cp39-manylinux2014_x86_64.whl) = f071293fd9710e8661f2a3a3ac4ad63748ab922fa8f9914be3b67844570c0b6f58696dd3335958369a828c35467312f1e77970039917923057624e5821cd68fa
SHA512 (colorama-0.4.3-py2.py3-none-any.whl) = 7cb2e248fbda31049e23431a921c71d3ecca650011ba25290ce0bfabb616faa0f0185e49deda10a9a358d3b9355392864b51ef764a4020c33d0980af97a33024
SHA512 (cryptography-3.3.2-cp36-abi3-manylinux2010_x86_64.whl) = d6cb4ee14cdfbf17226c5caec3ee182c1e812b6630dcab07dc5869d29a828f0fded2c2e2d85be2c5952dc2b1c0a0cedcd01d520f3e1c4aa385badb07a17d62c4
SHA512 (distro-1.5.0-py2.py3-none-any.whl) = 2a416b7e9455484bb99c94c5513a078e112010497fda68a21e7a0eb91a4d72f924f58741f1ffd33176003c1f85b1b4dcd15c416b9db1d0e24242fba876d618c6
SHA512 (docutils-0.15.2-py3-none-any.whl) = d9680d716663c8a64e7d8f7b4709974f780600d025d76d9b74363ed42d4935346f642a820a5c3ee9507b047956bc1304816835d750b65ca1dde8f6e3180e1f5b
SHA512 (prompt_toolkit-2.0.10-py3-none-any.whl) = d51471b9de11386c64c4a006d83a242765017b42efc05ff8a7737ae42c7680f56f3943252e0271e94fdc98bdf5f4b7a9783559f2172a6c20fe98c2c324e374b9
SHA512 (ruamel.yaml-0.15.100.tar.gz) = b4112d85337aa88e8df3c9142b881a17ccc254d79b58124d360bc3f0bba2177870af252abc4821617916f566b923ad794782795dfa71e9e3ff87252b586434fe
SHA512 (six-1.16.0-py2.py3-none-any.whl) = 656b010ed36d7486c07891c0247c7258faf0d1a68c5fb0a35db9c5b670eb712d5e470b023ffd568d7617e0ae77340820397014790d14fda4d13593fa2bd1c76f
SHA512 (wcwidth-0.1.9-py2.py3-none-any.whl) = ffd01979026512e8b249245dc4ac3b24d60b25c58ae013787dea36bc955e5949171e50b6102937c0b58cbcfcf3116f55b78e6499d4680886ef404f445e2dc813
SHA512 (boto3-1.17.102-py2.py3-none-any.whl) = 528b6d80aecca78076600f62f2cdcec3d8404b4091c556964927f9a2cd3f64d13575093cfc4ec177217e4e3e1b3e49f3a3770ac4c4197b4b6e69ccbf24990c99
SHA512 (botocore-1.20.102-py2.py3-none-any.whl) = 067d5828bfdafe72f5f641e2141fa61e1f995e6bbde6c68060028e33bd19f835c42d70b0fd519b0e6ac516ed5ab530af3b5a50154ab77a235bdb32bc8e9b5e8d
SHA512 (python_dateutil-2.8.1-py2.py3-none-any.whl) = ff083825ef3c8a3c6887ceae79a4249b938f529b72d0b931b1e30c81856ec7c8ee0adf0e29e2a41d3c76ab4e1faabc1c4161fe977d14589d346a658e343aa122
@ -46,6 +35,7 @@ SHA512 (msrestazure-0.6.4-py2.py3-none-any.whl) = aa4329e3a6ba639d0061c1eb0712b9
SHA512 (msal-1.18.0.tar.gz) = 70e7753dd9a218589c6082c2c706365e421e65476c5775db4abca52e1ca88ec02fd800fe885e3849a91ba2f4690d4acc8736d99e4320fad012c8ba411b0ef068
SHA512 (msal-extensions-1.0.0.tar.gz) = 5dc22a64a535ac9c7488d0d1e85e2f8320cb5c9e4cb5891599c8fc07060ff1eac310fe93ef42416142600ade8666ac4f0a3614a3e81950311f6d752cac5de959
SHA512 (portalocker-2.5.1.tar.gz) = a1aeea4cb09a05d4fc65a346965b5af509963f84c6b440bed974770576cab8d5c94c8535f2debd72613f3c603cf9fe3cc236fac6bec2fd69d7d48d206ba4c344
SHA512 (cryptography-3.3.2-cp36-abi3-manylinux2010_x86_64.whl) = d6cb4ee14cdfbf17226c5caec3ee182c1e812b6630dcab07dc5869d29a828f0fded2c2e2d85be2c5952dc2b1c0a0cedcd01d520f3e1c4aa385badb07a17d62c4
SHA512 (oauthlib-3.2.2.tar.gz) = c147b96e0ab0d1a8845f525e80831cfd04495134dd1f17fd95eac62f3a95c91e6dca9d38e34206537d77f3c12dd5b553252239318ba39546979c350e96536b8b
SHA512 (PyJWT-2.1.0-py3-none-any.whl) = d2f632379ecb3eb9c02d67f6da30d0c363f439936b5a6bc1172a0a33dc7e4784ee8b10c258d24ac40b5efbb252e7921c0842699f4b2d40eff99333557b531fcc
SHA512 (requests-2.25.1-py2.py3-none-any.whl) = cc0afada76d46295c685ac060d15a1ccb9af671522cb7b4fa0ad11988853715d1b7c31d42fa1e72a576cbd775db174da5bc03ab25c1e31c234c37740a63a6bcf