- all agents: unify ssl parameters to avoid having to use --ssl when
using --ssl-secure/--ssl-insecure for some agents Resolves: rhbz#2072420
This commit is contained in:
parent
5bb174648d
commit
1a21744d97
30
bz2072420-2-fence_zvmip-connect-error.patch
Normal file
30
bz2072420-2-fence_zvmip-connect-error.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 6430104318b4bf349425b08636183bf839812e04 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Tue, 31 May 2022 08:55:25 +0200
|
||||
Subject: [PATCH] fence_zvmip: show unable to connect error instead of full
|
||||
stacktrace, e.g. when not using --ssl for SSL devices
|
||||
|
||||
---
|
||||
agents/zvm/fence_zvmip.py | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/agents/zvm/fence_zvmip.py b/agents/zvm/fence_zvmip.py
|
||||
index 90ca95d45..4f538e10d 100644
|
||||
--- a/agents/zvm/fence_zvmip.py
|
||||
+++ b/agents/zvm/fence_zvmip.py
|
||||
@@ -127,8 +127,13 @@ def get_list_of_images(options, command, data_as_plug):
|
||||
|
||||
conn.send(packet)
|
||||
|
||||
- request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
- (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ try:
|
||||
+ request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
+ (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ except struct.error:
|
||||
+ logging.debug(sys.exc_info())
|
||||
+ fail_usage("Failed: Unable to connect to {} port: {} SSL: {} \n".format(options["--ip"], options["--ipport"], bool("--ssl" in options)))
|
||||
+
|
||||
images = set()
|
||||
|
||||
if output_len > 3*INT4:
|
@ -59,7 +59,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.10.0
|
||||
Release: 24%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 25%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
||||
@ -234,10 +234,11 @@ Patch17: bz2041933-bz2041935-2-fence_openstack-clouds-openrc.patch
|
||||
Patch18: bz2042496-fence_ibm_vpc-fence_ibm_powervs.patch
|
||||
Patch19: bz2022334-fence_zvmip-add-disable-ssl.patch
|
||||
Patch20: bz2065114-fence_lpar-refactor.patch
|
||||
Patch21: bz2072420-all-agents-unify-ssl-parameters.patch
|
||||
Patch21: bz2072420-1-all-agents-unify-ssl-parameters.patch
|
||||
Patch22: bz2079889-fence_gce-update.patch
|
||||
Patch23: bz2081235-fence_ibm_vpc-fix-parameters.patch
|
||||
Patch24: bz2086559-fence_apc-fence_ilo_moonshot-import-logging.patch
|
||||
Patch25: bz2072420-2-fence_zvmip-connect-error.patch
|
||||
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
%ifarch x86_64
|
||||
@ -373,6 +374,7 @@ BuildRequires: %{systemd_units}
|
||||
%patch22 -p1
|
||||
%patch23 -p1
|
||||
%patch24 -p1
|
||||
%patch25 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1464,6 +1466,11 @@ are located on corosync cluster nodes.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 31 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-25
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072420
|
||||
|
||||
* Tue May 17 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-24
|
||||
- fence_apc/fence_ilo_moonshot: add missing "import logging"
|
||||
Resolves: rhbz#2086559
|
||||
@ -1474,9 +1481,6 @@ are located on corosync cluster nodes.
|
||||
Resolves: rhbz#2081235
|
||||
|
||||
* Fri Apr 29 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-22
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072420
|
||||
- fence_gce: update fence agent
|
||||
Resolves: rhbz#2079889
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user