- fence_apc/fence_ilo_moonshot: add missing "import logging"

Resolves: rhbz#2086559
This commit is contained in:
Oyvind Albrigtsen 2022-05-17 11:41:02 +02:00
parent 26067c4c48
commit 5bb174648d
2 changed files with 41 additions and 1 deletions

View File

@ -0,0 +1,34 @@
From 6ea2c6b5d1cc51e93fa7084d76d9272512461e58 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Mon, 16 May 2022 11:01:21 +0200
Subject: [PATCH] fence_apc/fence_ilo_moonshot: add missing "import logging"
---
agents/apc/fence_apc.py | 1 +
agents/ilo_moonshot/fence_ilo_moonshot.py | 1 +
2 files changed, 2 insertions(+)
diff --git a/agents/apc/fence_apc.py b/agents/apc/fence_apc.py
index 901aad25e..3ea0f37d6 100644
--- a/agents/apc/fence_apc.py
+++ b/agents/apc/fence_apc.py
@@ -15,6 +15,7 @@
#####
import sys, re, time
+import logging
import atexit
sys.path.append("@FENCEAGENTSLIBDIR@")
from fencing import *
diff --git a/agents/ilo_moonshot/fence_ilo_moonshot.py b/agents/ilo_moonshot/fence_ilo_moonshot.py
index 6f5cca320..1923eeb1c 100644
--- a/agents/ilo_moonshot/fence_ilo_moonshot.py
+++ b/agents/ilo_moonshot/fence_ilo_moonshot.py
@@ -1,6 +1,7 @@
#!@PYTHON@ -tt
import sys
+import logging
import atexit
sys.path.append("@FENCEAGENTSLIBDIR@")
from fencing import *

View File

@ -59,7 +59,7 @@
Name: fence-agents
Summary: Set of unified programs capable of host isolation ("fencing")
Version: 4.10.0
Release: 23%{?alphatag:.%{alphatag}}%{?dist}
Release: 24%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2+ and LGPLv2+
URL: https://github.com/ClusterLabs/fence-agents
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
@ -237,6 +237,7 @@ Patch20: bz2065114-fence_lpar-refactor.patch
Patch21: bz2072420-all-agents-unify-ssl-parameters.patch
Patch22: bz2079889-fence_gce-update.patch
Patch23: bz2081235-fence_ibm_vpc-fix-parameters.patch
Patch24: bz2086559-fence_apc-fence_ilo_moonshot-import-logging.patch
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
%ifarch x86_64
@ -371,6 +372,7 @@ BuildRequires: %{systemd_units}
%patch21 -p1
%patch22 -p1
%patch23 -p1
%patch24 -p1
# prevent compilation of something that won't get used anyway
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
@ -1462,6 +1464,10 @@ are located on corosync cluster nodes.
%endif
%changelog
* Tue May 17 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-24
- fence_apc/fence_ilo_moonshot: add missing "import logging"
Resolves: rhbz#2086559
* Thu May 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-23
- fence_ibm_vpc: remove unused instance parameter and make limit
optional