- fence_ibm_powervs: improve defaults
Resolves: rhbz#2136191
This commit is contained in:
parent
66b01df22a
commit
15b4478071
46
bz2136191-fence_ibm_powervs-improve-defaults.patch
Normal file
46
bz2136191-fence_ibm_powervs-improve-defaults.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
From 3373431dc49d6e429bbf613765385cb33a56e917 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Tue, 25 Oct 2022 10:39:29 +0200
|
||||||
|
Subject: [PATCH] fence_ibm_powervs: improve defaults based on testing
|
||||||
|
|
||||||
|
---
|
||||||
|
agents/ibm_powervs/fence_ibm_powervs.py | 4 ++--
|
||||||
|
tests/data/metadata/fence_ibm_powervs.xml | 4 ++--
|
||||||
|
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/agents/ibm_powervs/fence_ibm_powervs.py b/agents/ibm_powervs/fence_ibm_powervs.py
|
||||||
|
index b0caed7c5..183893616 100755
|
||||||
|
--- a/agents/ibm_powervs/fence_ibm_powervs.py
|
||||||
|
+++ b/agents/ibm_powervs/fence_ibm_powervs.py
|
||||||
|
@@ -232,10 +232,10 @@ def main():
|
||||||
|
atexit.register(atexit_handler)
|
||||||
|
define_new_opts()
|
||||||
|
|
||||||
|
- all_opt["shell_timeout"]["default"] = "15"
|
||||||
|
+ all_opt["shell_timeout"]["default"] = "500"
|
||||||
|
all_opt["power_timeout"]["default"] = "30"
|
||||||
|
all_opt["power_wait"]["default"] = "1"
|
||||||
|
- all_opt["stonith_status_sleep"]["default"] = "3"
|
||||||
|
+ all_opt["stonith_status_sleep"]["default"] = "2"
|
||||||
|
all_opt["api-type"]["default"] = "private"
|
||||||
|
all_opt["proxy"]["default"] = ""
|
||||||
|
|
||||||
|
diff --git a/tests/data/metadata/fence_ibm_powervs.xml b/tests/data/metadata/fence_ibm_powervs.xml
|
||||||
|
index 40c494110..326bc2378 100644
|
||||||
|
--- a/tests/data/metadata/fence_ibm_powervs.xml
|
||||||
|
+++ b/tests/data/metadata/fence_ibm_powervs.xml
|
||||||
|
@@ -119,12 +119,12 @@
|
||||||
|
</parameter>
|
||||||
|
<parameter name="shell_timeout" unique="0" required="0">
|
||||||
|
<getopt mixed="--shell-timeout=[seconds]" />
|
||||||
|
- <content type="second" default="15" />
|
||||||
|
+ <content type="second" default="500" />
|
||||||
|
<shortdesc lang="en">Wait X seconds for cmd prompt after issuing command</shortdesc>
|
||||||
|
</parameter>
|
||||||
|
<parameter name="stonith_status_sleep" unique="0" required="0">
|
||||||
|
<getopt mixed="--stonith-status-sleep=[seconds]" />
|
||||||
|
- <content type="second" default="3" />
|
||||||
|
+ <content type="second" default="2" />
|
||||||
|
<shortdesc lang="en">Sleep X seconds between status calls during a STONITH action</shortdesc>
|
||||||
|
</parameter>
|
||||||
|
<parameter name="retry_on" unique="0" required="0">
|
@ -59,7 +59,7 @@
|
|||||||
Name: fence-agents
|
Name: fence-agents
|
||||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||||
Version: 4.10.0
|
Version: 4.10.0
|
||||||
Release: 34%{?alphatag:.%{alphatag}}%{?dist}
|
Release: 35%{?alphatag:.%{alphatag}}%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: https://github.com/ClusterLabs/fence-agents
|
URL: https://github.com/ClusterLabs/fence-agents
|
||||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
||||||
@ -223,6 +223,7 @@ Patch28: bz2122944-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
|
|||||||
Patch29: bz2111998-fence_ibm_vpc-add-token-cache-support.patch
|
Patch29: bz2111998-fence_ibm_vpc-add-token-cache-support.patch
|
||||||
Patch30: bz2132008-fence_virt-add-note-reboot-action.patch
|
Patch30: bz2132008-fence_virt-add-note-reboot-action.patch
|
||||||
Patch31: bz2134015-fence_lpar-only-output-additional-info-on-debug.patch
|
Patch31: bz2134015-fence_lpar-only-output-additional-info-on-debug.patch
|
||||||
|
Patch32: bz2136191-fence_ibm_powervs-improve-defaults.patch
|
||||||
|
|
||||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
@ -365,6 +366,7 @@ BuildRequires: %{systemd_units}
|
|||||||
%patch29 -p1
|
%patch29 -p1
|
||||||
%patch30 -p1
|
%patch30 -p1
|
||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
|
%patch32 -p1
|
||||||
|
|
||||||
# prevent compilation of something that won't get used anyway
|
# prevent compilation of something that won't get used anyway
|
||||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||||
@ -1431,6 +1433,10 @@ are located on corosync cluster nodes.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 25 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-35
|
||||||
|
- fence_ibm_powervs: improve defaults
|
||||||
|
Resolves: rhbz#2136191
|
||||||
|
|
||||||
* Wed Oct 12 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-34
|
* Wed Oct 12 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-34
|
||||||
- fence_lpar: only output additional output info on DEBUG level
|
- fence_lpar: only output additional output info on DEBUG level
|
||||||
Resolves: rhbz#2134015
|
Resolves: rhbz#2134015
|
||||||
|
Loading…
Reference in New Issue
Block a user