- fence_lpar: only output additional output info on DEBUG level

Resolves: rhbz#2134015
This commit is contained in:
Oyvind Albrigtsen 2022-10-12 14:35:32 +02:00
parent 5249461e2b
commit 66b01df22a
2 changed files with 40 additions and 1 deletions

View File

@ -0,0 +1,33 @@
From 46f94d4dbad868afc70b96bd612323221991d06e Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Tue, 11 Oct 2022 09:51:24 +0200
Subject: [PATCH] fence_lpar: only output additional error output on DEBUG
level
Without this patch we get ERROR logged with trace info when doing
status-action for nodes that doesnt exist.
---
agents/lpar/fence_lpar.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/agents/lpar/fence_lpar.py b/agents/lpar/fence_lpar.py
index 2046b0e4e..975971a57 100644
--- a/agents/lpar/fence_lpar.py
+++ b/agents/lpar/fence_lpar.py
@@ -12,6 +12,7 @@
import sys, re
import atexit
+import logging
sys.path.append("@FENCEAGENTSLIBDIR@")
from fencing import *
from fencing import fail, fail_usage, EC_STATUS_HMC
@@ -48,7 +49,7 @@ def get_power_status(conn, options):
elif options["--hmc-version"] in ["4", "IVM"]:
status = re.compile(",state=(.*?),", re.IGNORECASE).search(conn.before).group(1)
except AttributeError as e:
- fail_usage("Command on HMC failed: {}\n{}".format(command, str(e)), False)
+ logging.debug("Command on HMC failed: {}\n{}".format(command, str(e)))
fail(EC_STATUS_HMC)
return _normalize_status(status)

View File

@ -59,7 +59,7 @@
Name: fence-agents
Summary: Set of unified programs capable of host isolation ("fencing")
Version: 4.10.0
Release: 33%{?alphatag:.%{alphatag}}%{?dist}
Release: 34%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2+ and LGPLv2+
URL: https://github.com/ClusterLabs/fence-agents
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
@ -222,6 +222,7 @@ Patch27: bz2041933-bz2041935-3-fencing-source_env-dont-process-empty-lines.patch
Patch28: bz2122944-fence_vmware_soap-set-timeout-cleanup-tmp-dirs.patch
Patch29: bz2111998-fence_ibm_vpc-add-token-cache-support.patch
Patch30: bz2132008-fence_virt-add-note-reboot-action.patch
Patch31: bz2134015-fence_lpar-only-output-additional-info-on-debug.patch
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
%ifarch x86_64
@ -363,6 +364,7 @@ BuildRequires: %{systemd_units}
%patch28 -p1
%patch29 -p1
%patch30 -p1
%patch31 -p1
# prevent compilation of something that won't get used anyway
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
@ -1429,6 +1431,10 @@ are located on corosync cluster nodes.
%endif
%changelog
* Wed Oct 12 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-34
- fence_lpar: only output additional output info on DEBUG level
Resolves: rhbz#2134015
* Wed Oct 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-33
- fence_virt: add note that reboot-action doesnt power on nodes that
are powered off