fix expect/tcl8.5 compatibility
This commit is contained in:
parent
6b7bbf1f06
commit
89a8d8baca
@ -5,7 +5,7 @@
|
||||
|
||||
EXP_BUILD_LIB_SPEC="-L`pwd` -lexpect${EXP_LIB_VERSION}${DBGX}"
|
||||
-EXP_LIB_SPEC="-L\${INSTALL_ROOT}\${exec_prefix}/lib -lexpect${EXP_LIB_VERSION}${DBGX}"
|
||||
+EXP_LIB_SPEC="-L\${libdir}/.. -lexpect${EXP_LIB_VERSION}${DBGX}"
|
||||
+EXP_LIB_SPEC="-L\${libdir}/../.. -lexpect${EXP_LIB_VERSION}${DBGX}"
|
||||
EXP_UNSHARED_LIB_FILE=libexpect${EXP_LIB_VERSION}${DBGX}.a
|
||||
|
||||
# The TCL_SHARED_LIB_SUFFIX macro below relies on the DBGX macro,
|
||||
|
31
expect-5.43.0-pkgpath.patch
Normal file
31
expect-5.43.0-pkgpath.patch
Normal file
@ -0,0 +1,31 @@
|
||||
--- pkgIndex.in.orig 2007-02-10 21:07:34.000000000 -0800
|
||||
+++ pkgIndex.in 2007-02-10 21:07:43.000000000 -0800
|
||||
@@ -7,4 +7,4 @@
|
||||
# script is sourced, the variable $dir must contain the
|
||||
# full path name of this file's directory.
|
||||
|
||||
-package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. @EXP_SHARED_LIB_FILE@]]
|
||||
+package ifneeded Expect @EXP_VERSION_FULL@ [list load [file join $dir .. .. @EXP_SHARED_LIB_FILE@]]
|
||||
--- configure.in.orig 2007-02-10 21:30:13.000000000 -0800
|
||||
+++ configure.in 2007-02-10 21:30:23.000000000 -0800
|
||||
@@ -1260,6 +1260,7 @@
|
||||
AC_SUBST(UNSHARED_RANLIB)
|
||||
AC_SUBST(DEFAULT_STTY_ARGS)
|
||||
AC_SUBST(STTY_BIN)
|
||||
+AC_SUBST(TCL_VERSION)
|
||||
AC_OUTPUT([Makefile \
|
||||
pkgIndex],
|
||||
chmod +x ${srcdir}/install-sh ${srcdir}/mkinstalldirs)
|
||||
--- Makefile.in.orig 2007-02-10 21:34:28.000000000 -0800
|
||||
+++ Makefile.in 2007-02-10 22:23:14.000000000 -0800
|
||||
@@ -173,8 +173,8 @@
|
||||
bindir = $(INSTALL_ROOT)@bindir@
|
||||
bindir_arch_indep = $(INSTALL_ROOT)$(prefix)/bin
|
||||
tcl_libdir = $(INSTALL_ROOT)@libdir@
|
||||
-libdir = $(INSTALL_ROOT)@libdir@/expect$(VERSION)
|
||||
-libdir_arch_indep = $(INSTALL_ROOT)$(prefix)/lib/expect$(VERSION)
|
||||
+libdir = $(INSTALL_ROOT)@libdir@/tcl@TCL_VERSION@/expect$(VERSION)
|
||||
+libdir_arch_indep = $(INSTALL_ROOT)@datadir@/tcl@TCL_VERSION@/expect$(VERSION)
|
||||
|
||||
mandir = $(INSTALL_ROOT)@mandir@
|
||||
man1dir = $(mandir)/man1
|
18
expect.spec
18
expect.spec
@ -1,9 +1,11 @@
|
||||
%{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
|
||||
%{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
|
||||
%define majorver 5.43
|
||||
|
||||
Summary: A program-script interaction and testing utility
|
||||
Name: expect
|
||||
Version: %{majorver}.0
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: Public Domain
|
||||
Group: Development/Languages
|
||||
URL: http://expect.nist.gov/
|
||||
@ -20,6 +22,8 @@ Patch6: expect-5.43.0-pkgIndex-x.patch
|
||||
# examples patches
|
||||
Patch100: expect-5.32.2-random.patch
|
||||
Patch101: unbuffer-child-flush-143963.patch
|
||||
# Fix install location for tcl 8.5
|
||||
Patch200: expect-5.43.0-pkgpath.patch
|
||||
|
||||
%description
|
||||
Expect is a tcl application for automating and testing
|
||||
@ -67,7 +71,8 @@ This package contains expectk and some scripts that use it.
|
||||
# examples fixes
|
||||
%patch100 -p1 -b .random
|
||||
%patch101 -p1 -b .unbuffer
|
||||
# *-lib-spec.patch and *-tcl8.5.patch touch configure.in
|
||||
%patch200 -p0 -b .pkgpath
|
||||
# *-lib-spec.patch and *-tcl8.5.patch and -pkgpath.patch touch configure.in
|
||||
aclocal
|
||||
autoconf
|
||||
( cd testsuite
|
||||
@ -115,8 +120,8 @@ rm -rf "$RPM_BUILD_ROOT"
|
||||
%{_bindir}/unbuffer
|
||||
%{_bindir}/weather
|
||||
%{_bindir}/xkibitz
|
||||
%dir %{_libdir}/expect%{majorver}
|
||||
%{_libdir}/expect%{majorver}/pkgIndex.tcl
|
||||
%dir %{tcl_sitearch}/expect%{majorver}
|
||||
%{tcl_sitearch}/expect%{majorver}/pkgIndex.tcl
|
||||
%{_libdir}/libexpect%{majorver}.so
|
||||
%{_mandir}/man1/autoexpect.1.gz
|
||||
%{_mandir}/man1/dislocate.1.gz
|
||||
@ -130,7 +135,7 @@ rm -rf "$RPM_BUILD_ROOT"
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
|
||||
%exclude %{tcl_sitearch}/expect%{majorver}/libexpect%{majorver}.a
|
||||
%exclude %{_libdir}/libexpect%{majorver}.a
|
||||
%{_libdir}/libexpect.so
|
||||
%{_mandir}/man3/libexpect.3*
|
||||
@ -148,6 +153,9 @@ rm -rf "$RPM_BUILD_ROOT"
|
||||
%{_mandir}/man1/tknewsbiff.1*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 14 2008 Wart <wart@kobold.org> - 5.43.0-12
|
||||
- Update install locations to reflect updated auto_path in the tcl 8.5 package
|
||||
|
||||
* Mon Jan 07 2008 Adam Tkac <atkac redhat com> - 5.43.0-11
|
||||
- updated "tcl8.5" patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user