- updated "tcl8.5" patch

This commit is contained in:
Adam Tkac 2008-01-07 09:42:59 +00:00
parent 857d088293
commit 6b7bbf1f06
2 changed files with 22 additions and 61 deletions

View File

@ -1,65 +1,23 @@
--- expect-5.43/exp_command.h.tcl8.5 2007-02-03 01:00:05.000000000 +0100
+++ expect-5.43/exp_command.h 2007-02-03 01:02:18.000000000 +0100
@@ -23,7 +23,12 @@
# undef panic
#endif
diff -up expect-5.43/tests/all.tcl expect-5.43/tests/all
diff -up expect-5.43/Dbg.c.tcl expect-5.43/Dbg.c
--- expect-5.43/Dbg.c.tcl 2008-01-04 19:25:02.000000000 +0100
+++ expect-5.43/Dbg.c 2008-01-04 19:25:25.000000000 +0100
@@ -10,6 +10,7 @@ would appreciate credit if this program
-#include <tclPort.h>
+#include "tcl.h"
+#if TCL_MAJOR_VERSION < 8 || TCL_MINOR_VERSION < 5
+# include <tclPort.h>
+#else
+# include <tclInt.h>
+#endif
#define EXP_CHANNELNAMELEN (16 + TCL_INTEGER_SPACE)
--- expect-5.43/aclocal.m4.tcl8.5 2002-02-12 03:00:55.000000000 +0100
+++ expect-5.43/aclocal.m4 2007-02-03 01:00:05.000000000 +0100
@@ -150,11 +150,20 @@
TCLHDIRDASHI=""
TCL_LIBRARY=""
else
- AC_MSG_RESULT([found in ${ac_cv_c_tclh}])
+ dirs=${ac_cv_c_tclh}
+ stem=${dirs%/generic}
+ if test x"${dirs}" != x"$stem" && test -d "$stem/unix"; then
+ dirs="$dirs $stem/unix"
+ fi
+ dashi=''
+ for dir in $dirs; do
+ dashi="$dashi -I$dir"
+ done
+ AC_MSG_RESULT([found in ${dirs}])
# this hack is cause the TCLHDIR won't print if there is a "-I" in it.
- TCLHDIR="${ac_cv_c_tclh}"
- TCLHDIRDASHI="-I${ac_cv_c_tclh}"
- TCL_LIBRARY=`echo $TCLHDIR | sed -e 's/generic//'`library
+ TCLHDIR="${dirs}"
+ TCLHDIRDASHI="${dashi# }"
+ TCL_LIBRARY=`echo ${dirs% *} | sed -e 's/generic//'`library
fi
fi
--- expect-5.43/Dbg.c.tcl8.5 2002-03-23 05:11:54.000000000 +0100
+++ expect-5.43/Dbg.c 2007-02-03 01:00:05.000000000 +0100
@@ -11,6 +11,7 @@
#include <stdio.h>
#include "tcldbgcf.h"
+#include "expect_cf.h"
#include "tcldbgcf.h"
#if 0
/* tclInt.h drags in stdlib. By claiming no-stdlib, force it to drag in */
/* Tcl's compat version. This avoids having to test for its presence */
--- expect-5.43/configure.in.tcl8.5 2007-02-03 01:00:05.000000000 +0100
+++ expect-5.43/configure.in 2007-02-03 01:00:05.000000000 +0100
@@ -368,7 +368,8 @@
cp ${srcdir}/Dbgconfigure ${srcdir}/tcldbg.h ${srcdir}/tcldbgcf.h.in ${srcdir}/install-sh ${tmpdir}
cp $srcdir/DbgMkfl.in ${tmpdir}/Makefile.in
cp $srcdir/DbgpkgInd.in ${tmpdir}/pkgIndex.in
-(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=$TCLHDIR $dbg_config_flags)
+# Drop .../unix from tclinclude if present, CY_AC_PATH_TCLH will add it again.
+(cd $tmpdir; ${CONFIG_SHELL-/bin/sh} Dbgconfigure --with-tclinclude=${TCLHDIR%% *} $dbg_config_flags)
cp ${tmpdir}/tcldbgcf.h .
rm -rf $tmpdir
test -n "$verbose" && echo "configured Tcl debugger"
diff -up expect-5.43/exp_inter.c.tcl expect-5.43/exp_inter.c
--- expect-5.43/exp_inter.c.tcl 2008-01-04 19:23:47.000000000 +0100
+++ expect-5.43/exp_inter.c 2008-01-04 19:24:24.000000000 +0100
@@ -36,6 +36,7 @@ would appreciate credit if this program
#include <ctype.h>
#include "tcl.h"
+#include "tclInt.h"
#include "string.h"
#include "exp_tty_in.h"

View File

@ -3,7 +3,7 @@
Summary: A program-script interaction and testing utility
Name: expect
Version: %{majorver}.0
Release: 10%{?dist}
Release: 11%{?dist}
License: Public Domain
Group: Development/Languages
URL: http://expect.nist.gov/
@ -62,7 +62,7 @@ This package contains expectk and some scripts that use it.
%patch2 -p1 -b .lib-spec
%patch3 -p1 -b .libdir
%patch4 -p1 -b .log_file
#%patch5 -p1 -b .tcl8.5
%patch5 -p1 -b .tcl8.5
%patch6 -p1 -b .pkgIndex-x
# examples fixes
%patch100 -p1 -b .random
@ -148,6 +148,9 @@ rm -rf "$RPM_BUILD_ROOT"
%{_mandir}/man1/tknewsbiff.1*
%changelog
* Mon Jan 07 2008 Adam Tkac <atkac redhat com> - 5.43.0-11
- updated "tcl8.5" patch
* Sat Jan 5 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 5.43.0-10
- Rebuild for new Tcl 8.5