Change specfile according to Sebastian Pippings suggestions

This commit is contained in:
Tomas Korbar 2022-01-18 09:18:27 +01:00
parent d9cba035ee
commit 7e67bec57c
2 changed files with 6 additions and 17 deletions

View File

@ -1,14 +0,0 @@
https://github.com/libexpat/libexpat/pull/109
--- libexpat-R_2_2_3/expat/tests/runtests.c.fixtests
+++ libexpat-R_2_2_3/expat/tests/runtests.c
@@ -5671,7 +5671,7 @@ static int XMLCALL
prefix_converter(void *UNUSED_P(data), const char *s)
{
/* If the first byte is 0xff, raise an error */
- if (s[0] == -1)
+ if (s[0] == (char)-1)
return -1;
/* Just add the low bits of the first byte to the second */
return (s[1] + (s[0] & 0x7f)) & 0x01ff;

View File

@ -3,7 +3,7 @@
Summary: An XML parser library
Name: expat
Version: %(echo %{unversion} | sed 's/_/./g')
Release: 1%{?dist}
Release: 2%{?dist}
Source: https://github.com/libexpat/libexpat/archive/R_%{unversion}.tar.gz#/expat-%{version}.tar.gz
URL: https://libexpat.github.io/
License: MIT
@ -41,7 +41,7 @@ sed -i 's/install-data-hook/do-nothing-please/' lib/Makefile.am
%build
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
export DOCBOOK_TO_MAN="xmlto man --skip-validation"
export DOCBOOK_TO_MAN="xmlto man"
%configure
%make_build
@ -63,7 +63,7 @@ make check
%{_mandir}/*/*
%files devel
%doc doc/reference.html doc/*.png doc/*.css examples/*.c
%doc doc/reference.html doc/*.css examples/*.c
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*.h
@ -73,6 +73,9 @@ make check
%{_libdir}/lib*.a
%changelog
* Tue Jan 18 2022 Tomas Korbar <tkorbar@redhat.com> - 2.4.3-2
- Change specfile according to Sebastian Pippings suggestions
* Mon Jan 17 2022 Tomas Korbar <tkorbar@redhat.com> - 2.4.3-1
- Rebase to version 2.4.3