update to 2.1.0 (#806602)

Resolves: rhbz#806602
This commit is contained in:
Joe Orton 2012-03-26 10:57:12 +01:00
parent 684fb2b499
commit 1aae02c2dc
7 changed files with 11 additions and 58 deletions

3
.gitignore vendored
View File

@ -3,3 +3,6 @@ i386
*.rpm
clog
expat-2.0.1.tar.gz
/results_expat
/expat-2.?.?
/expat-2.1.0.tar.gz

View File

@ -1,11 +0,0 @@
--- expat-1.95.8/lib/xmltok_impl.c.cve3720
+++ expat-1.95.8/lib/xmltok_impl.c
@@ -1741,7 +1741,7 @@ PREFIX(updatePosition)(const ENCODING *e
const char *end,
POSITION *pos)
{
- while (ptr != end) {
+ while (ptr < end) {
switch (BYTE_TYPE(enc, ptr)) {
#define LEAD_CASE(n) \
case BT_LEAD ## n: \

View File

@ -1,11 +0,0 @@
--- expat-1.95.8/lib/expat.h.pedantic
+++ expat-1.95.8/lib/expat.h
@@ -43,7 +43,7 @@
#define XML_STATUS_ERROR XML_STATUS_ERROR
XML_STATUS_OK = 1,
#define XML_STATUS_OK XML_STATUS_OK
- XML_STATUS_SUSPENDED = 2,
+ XML_STATUS_SUSPENDED = 2
#define XML_STATUS_SUSPENDED XML_STATUS_SUSPENDED
};

View File

@ -1,12 +0,0 @@
--- expat-2.0.1/lib/xmlparse.c.newcve3560
+++ expat-2.0.1/lib/xmlparse.c
@@ -3703,6 +3703,9 @@ doProlog(XML_Parser parser,
return XML_ERROR_UNCLOSED_TOKEN;
case XML_TOK_PARTIAL_CHAR:
return XML_ERROR_PARTIAL_CHAR;
+ case -XML_TOK_PROLOG_S:
+ tok = -tok;
+ break;
case XML_TOK_NONE:
#ifdef XML_DTD
/* for internal PE NOT referenced between declarations */

View File

@ -1,13 +0,0 @@
Configure for C++ too so the testsuite works.
--- expat-2.0.1/configure.in.confcxx
+++ expat-2.0.1/configure.in
@@ -62,6 +62,7 @@ AC_SUBST(LIBAGE)
dnl Checks for programs.
AC_PROG_CC
+AC_PROG_CXX
AC_PROG_INSTALL
if test "$GCC" = yes ; then

View File

@ -1,12 +1,9 @@
Summary: An XML parser library
Name: expat
Version: 2.0.1
Release: 12%{?dist}
Version: 2.1.0
Release: 1%{?dist}
Group: System Environment/Libraries
Source: http://downloads.sourceforge.net/expat/expat-%{version}.tar.gz
Patch1: expat-2.0.1-confcxx.patch
Patch2: expat-2.0.1-CVE-2009-3560-revised.patch
Patch3: expat-1.95.8-CVE-2009-3720.patch
URL: http://www.libexpat.org/
License: MIT
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -31,13 +28,9 @@ to develop XML applications with expat.
%prep
%setup -q
%patch1 -p1 -b .confcxx
%patch2 -p1 -b .newcve3560
%patch3 -p1 -b .cve3720
%build
rm -rf autom4te*.cache
rm conftools/libtool.m4
libtoolize --copy --force --automake && aclocal && autoheader && autoconf
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
%configure --libdir=/%{_lib} --disable-static
@ -54,7 +47,8 @@ make install DESTDIR=$RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_libdir}
mv $RPM_BUILD_ROOT/%{_lib}/libexpat.so $RPM_BUILD_ROOT%{_libdir}
rm -f $RPM_BUILD_ROOT/%{_lib}/libexpat.la
rm -f $RPM_BUILD_ROOT/%{_lib}/libexpat.la \
$RPM_BUILD_ROOT/%{_lib}/pkgconfig/*.pc
lib=`echo $RPM_BUILD_ROOT/%{_lib}/libexpat.so.*.*`
ln -sf ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/libexpat.so
@ -82,6 +76,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_includedir}/*.h
%changelog
* Mon Mar 26 2012 Joe Orton <jorton@redhat.com> - 2.1.0-1
- update to 2.1.0 (#806602)
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

View File

@ -1 +1 @@
ee8b492592568805593f81f8cdf2a04c expat-2.0.1.tar.gz
dd7dab7a5fea97d2a6a43f511449b7cd expat-2.1.0.tar.gz