- regenerate configure/libtool correctly (#199361)
- strip DSP files from examples (#186889) - fix expat.h compilation with g++ -pedantic (#190244)
This commit is contained in:
parent
a8575c0585
commit
17207d999c
11
expat-1.95.8-pedantic.patch
Normal file
11
expat-1.95.8-pedantic.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- expat-1.95.8/lib/expat.h.pedantic
|
||||||
|
+++ expat-1.95.8/lib/expat.h
|
||||||
|
@@ -43,7 +43,7 @@
|
||||||
|
#define XML_STATUS_ERROR XML_STATUS_ERROR
|
||||||
|
XML_STATUS_OK = 1,
|
||||||
|
#define XML_STATUS_OK XML_STATUS_OK
|
||||||
|
- XML_STATUS_SUSPENDED = 2,
|
||||||
|
+ XML_STATUS_SUSPENDED = 2
|
||||||
|
#define XML_STATUS_SUSPENDED XML_STATUS_SUSPENDED
|
||||||
|
};
|
||||||
|
|
22
expat.spec
22
expat.spec
@ -1,9 +1,10 @@
|
|||||||
Summary: A library for parsing XML.
|
Summary: A library for parsing XML.
|
||||||
Name: expat
|
Name: expat
|
||||||
Version: 1.95.8
|
Version: 1.95.8
|
||||||
Release: 8.2.1
|
Release: 9
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.sourceforge.net/expat/expat-%{version}.tar.gz
|
Source: http://download.sourceforge.net/expat/expat-%{version}.tar.gz
|
||||||
|
Patch0: expat-1.95.8-pedantic.patch
|
||||||
URL: http://www.libexpat.org/
|
URL: http://www.libexpat.org/
|
||||||
License: BSD
|
License: BSD
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
@ -27,8 +28,12 @@ to develop XML applications with expat.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .pedantic
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
rm -rf autom4te*.cache
|
||||||
|
cp `aclocal --print-ac-dir`/libtool.m4 conftools || exit 1
|
||||||
|
libtoolize --copy --force --automake && aclocal && autoheader && autoconf
|
||||||
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -36,18 +41,16 @@ make %{?_smp_mflags}
|
|||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
|
rm -f examples/*.dsp
|
||||||
|
|
||||||
%makeinstall man1dir=$RPM_BUILD_ROOT/%{_mandir}/man1 \
|
%makeinstall man1dir=$RPM_BUILD_ROOT/%{_mandir}/man1 \
|
||||||
libdir=$RPM_BUILD_ROOT/%{_lib}
|
libdir=$RPM_BUILD_ROOT/%{_lib}
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}
|
mkdir -p $RPM_BUILD_ROOT%{_libdir}
|
||||||
|
mv $RPM_BUILD_ROOT/%{_lib}/libexpat.{so,a,la} $RPM_BUILD_ROOT%{_libdir}
|
||||||
|
|
||||||
lib=`echo $RPM_BUILD_ROOT/%{_lib}/libexpat.so.*.*`
|
lib=`echo $RPM_BUILD_ROOT/%{_lib}/libexpat.so.*.*`
|
||||||
|
ln -sf ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/libexpat.so
|
||||||
ln -s ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/libexpat.so
|
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/*.so
|
|
||||||
|
|
||||||
mv $RPM_BUILD_ROOT/%{_lib}/*.*a $RPM_BUILD_ROOT%{_libdir}/
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
@ -70,6 +73,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_includedir}/*.h
|
%{_includedir}/*.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 30 2007 Joe Orton <jorton@redhat.com> 1.95.8-9
|
||||||
|
- regenerate configure/libtool correctly (#199361)
|
||||||
|
- strip DSP files from examples (#186889)
|
||||||
|
- fix expat.h compilation with g++ -pedantic (#190244)
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.95.8-8.2.1
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.95.8-8.2.1
|
||||||
- rebuild
|
- rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user