- exiv2-0.20
This commit is contained in:
parent
59ed2177f9
commit
a763e9a57e
@ -1 +1 @@
|
||||
exiv2-0.19.tar.gz
|
||||
exiv2-0.20.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
diff -up exiv2-0.18-pre2/src/Makefile.deps exiv2-0.18-pre2/src/Makefile
|
||||
--- exiv2-0.18-pre2/src/Makefile.deps 2008-09-18 05:26:58.000000000 -0500
|
||||
+++ exiv2-0.18-pre2/src/Makefile 2008-11-29 05:46:14.000000000 -0600
|
||||
@@ -192,11 +192,19 @@ $(CCOBJ): %.o: %.cpp
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -DEXV_BUILDING_LIB=1 -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+# The dependancies here are wrong. It generates .lo output,
|
||||
+# so things are rebuilt *every* time 'make' is called.
|
||||
+# Let's try a quick-n-dirty hack -- Rex
|
||||
+ touch $@
|
||||
|
||||
$(COBJ): %.o: %.c
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.c) -DEXV_BUILDING_LIB=1 -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+# The dependancies here are wrong. It generates .lo output,
|
||||
+# so things are rebuilt *every* time 'make' is called.
|
||||
+# Let's try a quick-n-dirty hack -- Rex
|
||||
+ touch $@
|
||||
|
||||
$(sort $(BINOBJ) $(EXIV2OBJ) $(MCOBJ) path-test.o): %.o: %.cpp
|
||||
$(COMPILE.cc) -o $@ $<
|
37
exiv2-0.20-deps.patch
Normal file
37
exiv2-0.20-deps.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff -up exiv2-0.20/src/Makefile.deps exiv2-0.20/src/Makefile
|
||||
--- exiv2-0.20/src/Makefile.deps 2010-05-25 10:25:02.000000000 -0500
|
||||
+++ exiv2-0.20/src/Makefile 2010-05-30 13:33:38.181957187 -0500
|
||||
@@ -195,11 +195,19 @@ $(CCOBJ): %.o: %.cpp
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -DEXV_BUILDING_LIB=1 -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+# The dependancies here are wrong. It generates .lo output,
|
||||
+# so things are rebuilt *every* time 'make' is called.
|
||||
+# Let's try a quick-n-dirty hack -- Rex
|
||||
+ touch $@
|
||||
|
||||
$(COBJ): %.o: %.c
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.c) -DEXV_BUILDING_LIB=1 -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+# The dependancies here are wrong. It generates .lo output,
|
||||
+# so things are rebuilt *every* time 'make' is called.
|
||||
+# Let's try a quick-n-dirty hack -- Rex
|
||||
+ touch $@
|
||||
|
||||
$(sort $(BINOBJ) $(EXIV2OBJ) $(MCOBJ) path-test.o): %.o: %.cpp
|
||||
$(COMPILE.cc) -o $@ $<
|
||||
diff -up exiv2-0.20/xmpsdk/src/Makefile.deps exiv2-0.20/xmpsdk/src/Makefile
|
||||
--- exiv2-0.20/xmpsdk/src/Makefile.deps 2010-04-03 02:53:30.000000000 -0500
|
||||
+++ exiv2-0.20/xmpsdk/src/Makefile 2010-05-30 13:36:16.004947131 -0500
|
||||
@@ -108,6 +108,10 @@ $(CCOBJ): %.o: %.cpp
|
||||
@$(LIBTOOL) --mode=compile $(COMPILE.cc) -o $@ $<
|
||||
@$(MAKEDEPEND)
|
||||
@$(POSTDEPEND)
|
||||
+ # The dependancies here are wrong. It generates .lo output,
|
||||
+ # so things are rebuilt *every* time 'make' is called.
|
||||
+ # Let's try a quick-n-dirty hack -- Rex
|
||||
+ @touch $@
|
||||
|
||||
%.ii: %.cpp
|
||||
set -e; \
|
26
exiv2.spec
26
exiv2.spec
@ -1,7 +1,7 @@
|
||||
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
Name: exiv2
|
||||
Version: 0.19
|
||||
Version: 0.20
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
@ -18,7 +18,7 @@ BuildRequires: zlib-devel
|
||||
# docs
|
||||
#BuildRequires: doxygen graphviz libxslt
|
||||
|
||||
Patch1: exiv2-0.18-deps.patch
|
||||
Patch1: exiv2-0.20-deps.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
@ -59,10 +59,6 @@ methods for Exif thumbnails, classes to access Ifd and so on.
|
||||
|
||||
mkdir doc/html
|
||||
|
||||
%if "%{_libdir}" != "/usr/lib"
|
||||
sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -79,17 +75,22 @@ make install DESTDIR=%{buildroot}
|
||||
|
||||
%find_lang exiv2
|
||||
|
||||
# Unpackaged files
|
||||
## Unpackaged files
|
||||
rm -f %{buildroot}%{_libdir}/lib*.la
|
||||
|
||||
# fix perms on installed lib
|
||||
## fix perms on installed lib
|
||||
chmod 755 %{buildroot}%{_libdir}/lib*.so*
|
||||
|
||||
# nuke rpaths
|
||||
chrpath --list %{buildroot}%{_bindir}/exiv2
|
||||
## nuke rpaths
|
||||
chrpath --list %{buildroot}%{_bindir}/exiv2 && \
|
||||
chrpath --delete %{buildroot}%{_bindir}/exiv2
|
||||
|
||||
|
||||
%check
|
||||
export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
|
||||
test "$(pkg-config --modversion exiv2)" = "%{version}"
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
@ -107,7 +108,7 @@ rm -rf %{buildroot}
|
||||
|
||||
%files libs -f exiv2.lang
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libexiv2.so.6*
|
||||
%{_libdir}/libexiv2.so.9*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -118,6 +119,9 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun May 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.20-1
|
||||
- exiv2-0.20
|
||||
|
||||
* Wed Dec 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.19-1
|
||||
- exiv2-0.19 (#552275)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user