- exiv2-0.19 (#552275)
This commit is contained in:
parent
046172a1b0
commit
59ed2177f9
@ -1 +1 @@
|
||||
exiv2-0.18.2.tar.gz
|
||||
exiv2-0.19.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up exiv2-0.18.1/config/configure.ac.visibility exiv2-0.18.1/config/configure.ac
|
||||
--- exiv2-0.18.1/config/configure.ac.visibility 2009-04-03 10:52:50.000000000 -0500
|
||||
+++ exiv2-0.18.1/config/configure.ac 2009-04-17 14:36:01.000000000 -0500
|
||||
@@ -111,9 +111,9 @@ AC_ARG_ENABLE(visibility,
|
||||
GXX_VISIBILITY=$enableval, GXX_VISIBILITY=yes)
|
||||
AC_MSG_RESULT($GXX_VISIBILITY)
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- AX_CXX_CHECK_FLAG(-fvisibility-inlines-hidden,[],[],[GXX_VISIBILITY=yes],[GXX_VISIBILITY=no])
|
||||
+ AX_CXX_CHECK_FLAG(-fvisibility=hidden,[],[],[GXX_VISIBILITY=yes],[GXX_VISIBILITY=no])
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- CXXFLAGS="${CXXFLAGS} -fvisibility=hidden -fvisibility-inlines-hidden"
|
||||
+ CXXFLAGS="${CXXFLAGS} -fvisibility=hidden"
|
||||
AC_DEFINE(HAVE_GXXCLASSVISIBILITY,1)
|
||||
fi
|
||||
if test "$enable_shared" = "yes"; then
|
||||
diff -up exiv2-0.18.1/configure.visibility exiv2-0.18.1/configure
|
||||
--- exiv2-0.18.1/configure.visibility 2009-04-05 10:50:29.000000000 -0500
|
||||
+++ exiv2-0.18.1/configure 2009-04-17 14:48:51.000000000 -0500
|
||||
@@ -23905,7 +23905,7 @@ fi
|
||||
|
||||
|
||||
if test "$GXX_VISIBILITY" = "yes"; then
|
||||
- CXXFLAGS="${CXXFLAGS} -fvisibility=hidden -fvisibility-inlines-hidden"
|
||||
+ CXXFLAGS="${CXXFLAGS} -fvisibility=hidden"
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_GXXCLASSVISIBILITY 1
|
||||
_ACEOF
|
44
exiv2.spec
44
exiv2.spec
@ -1,13 +1,8 @@
|
||||
|
||||
%if 0%{?fedora} > 7
|
||||
# make -libs subpkg
|
||||
%define libs 1
|
||||
%endif
|
||||
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
Name: exiv2
|
||||
Version: 0.18.2
|
||||
Release: 2%{?dist}
|
||||
Version: 0.19
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
Group: Applications/Multimedia
|
||||
@ -24,14 +19,8 @@ BuildRequires: zlib-devel
|
||||
#BuildRequires: doxygen graphviz libxslt
|
||||
|
||||
Patch1: exiv2-0.18-deps.patch
|
||||
Patch2: exiv2-0.18.1-visibility.patch
|
||||
|
||||
%if 0%{?libs}
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
%else
|
||||
Obsoletes: %{name}-libs < %{version}-%{release}
|
||||
Provides: %{name}-libs = %{version}-%{release}
|
||||
%endif
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
|
||||
%description
|
||||
@ -49,12 +38,11 @@ A command line utility to access image metadata, allowing one to:
|
||||
%package devel
|
||||
Summary: Header files, libraries and development documentation for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
%if 0%{?libs}
|
||||
%package libs
|
||||
Summary: Exif and Iptc metadata manipulation library
|
||||
Group: System Environment/Libraries
|
||||
@ -62,18 +50,19 @@ Group: System Environment/Libraries
|
||||
A C++ library to access image metadata, supporting full read and write access
|
||||
to the Exif and Iptc metadata, Exif MakerNote support, extract and delete
|
||||
methods for Exif thumbnails, classes to access Ifd and so on.
|
||||
%endif
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?pre:-%{pre}}
|
||||
|
||||
%patch1 -p1 -b .deps
|
||||
## drop for now, seems no longer needed as of 0.18.2
|
||||
%patch2 -p1 -b .visibility
|
||||
|
||||
mkdir doc/html
|
||||
|
||||
%if "%{_libdir}" != "/usr/lib"
|
||||
sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -105,22 +94,20 @@ chrpath --delete %{buildroot}%{_bindir}/exiv2
|
||||
rm -rf %{buildroot}
|
||||
|
||||
|
||||
%post %{?libs:libs} -p /sbin/ldconfig
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun %{?libs:libs} -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files %{!?libs:-f exiv2.lang}
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README
|
||||
%{_bindir}/exiv2
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%if 0%{?libs}
|
||||
%files libs -f exiv2.lang
|
||||
%defattr(-,root,root,-)
|
||||
%endif
|
||||
%{_libdir}/libexiv2.so.5*
|
||||
%{_libdir}/libexiv2.so.6*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -131,6 +118,13 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.19-1
|
||||
- exiv2-0.19 (#552275)
|
||||
|
||||
* Sun Dec 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.2-3
|
||||
- -libs unconditional
|
||||
- tighten deps using %%?_isa
|
||||
|
||||
* Fri Aug 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.18.2-2
|
||||
- (again) drop -fvisibility-inlines-hidden (#496050)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user