- Update to 2.7.1
- Bump evo_major from 2.6 to 2.8 - Upstream evolution.desktop renamed evolution-%{evo_major}.desktop. - Upstream evolution.keys renamed evolution-%{evo_major}.keys. - Upstream evolution.mime renamed evolution-%{evo_major}.mime. - Update line numbers in evolution-2.5.2-no-gnome-common.patch and evolution-2.5.5.1-notification-cleanups.patch and rename them to version 2.7.1.
This commit is contained in:
parent
6e154befcd
commit
59a721b515
@ -1,2 +1 @@
|
||||
evolution-2.6.0.tar.bz2
|
||||
evolution-2.6.1.tar.bz2
|
||||
evolution-2.7.1.tar.bz2
|
||||
|
41
evolution-2.7.1-no-gnome-common.patch
Normal file
41
evolution-2.7.1-no-gnome-common.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- evolution-2.7.1/configure.in.no-gnome-common 2006-04-24 07:17:07.000000000 -0400
|
||||
+++ evolution-2.7.1/configure.in 2006-05-12 14:46:29.000000000 -0400
|
||||
@@ -747,16 +747,24 @@
|
||||
check_manually="no"
|
||||
fi
|
||||
|
||||
- if test "x${check_manually}" = "xno" && `$PKG_CONFIG --exists mozilla-nss`; then
|
||||
- PKG_CHECK_MODULES(NSS, mozilla-nss, have_nss="yes")
|
||||
+ if test "x${check_manually}" = "xno"; then
|
||||
+ if `$PKG_CONFIG --exists mozilla-nss`; then
|
||||
+ PKG_CHECK_MODULES(NSS, mozilla-nss, have_nss="yes")
|
||||
+ mozilla_nspr="mozilla-nspr"
|
||||
+ mozilla_nss="mozilla-nss"
|
||||
+ else
|
||||
+ if `$PKG_CONFIG --exists nss`; then
|
||||
+ PKG_CHECK_MODULES(NSS, nss, have_nss="yes")
|
||||
+ mozilla_nspr="nspr"
|
||||
+ mozilla_nss="nss"
|
||||
+ fi
|
||||
+ fi
|
||||
if test "x${have_nss}" = "xyes"; then
|
||||
msg_ssl="yes (Mozilla NSS)"
|
||||
if test "x$enable_smime" = "xyes"; then
|
||||
AC_DEFINE(ENABLE_SMIME,1,[Define if SMIME should be enabled])
|
||||
msg_smime="yes (Mozilla NSS)"
|
||||
fi
|
||||
- mozilla_nspr="nspr"
|
||||
- mozilla_nss="mozilla-nss"
|
||||
AC_DEFINE(HAVE_NSS,1,[Define if you have NSS])
|
||||
AC_DEFINE(HAVE_SSL,1,[Define if you have a supported SSL library])
|
||||
AC_DEFINE_UNQUOTED(MOZILLA_NSS_LIB_DIR,"`$PKG_CONFIG --variable=libdir mozilla-nss`",[Define to the full path of mozilla nss library])
|
||||
@@ -1072,9 +1080,6 @@
|
||||
dnl *************************
|
||||
dnl CFLAGS and LIBS and stuff
|
||||
dnl *************************
|
||||
-
|
||||
-GNOME_COMPILE_WARNINGS(yes)
|
||||
-CFLAGS="$CFLAGS $WARN_CFLAGS"
|
||||
case $CFLAGS in
|
||||
*-Wall*)
|
||||
# Turn off the annoying "comparison between signed and unsigned"
|
49
evolution-2.7.1-notification-cleanups.patch
Normal file
49
evolution-2.7.1-notification-cleanups.patch
Normal file
@ -0,0 +1,49 @@
|
||||
--- evolution-2.7.1/calendar/gui/alarm-notify/alarm-queue.c.notification-cleanups 2006-04-22 00:39:20.000000000 -0400
|
||||
+++ evolution-2.7.1/calendar/gui/alarm-notify/alarm-queue.c 2006-05-12 14:52:43.000000000 -0400
|
||||
@@ -1566,10 +1566,11 @@
|
||||
const char *summary, *location;
|
||||
GtkTooltips *tooltips;
|
||||
ECalComponentText text;
|
||||
- char *str, *start_str, *end_str, *alarm_str, *time_str;
|
||||
+ char *start_str, *end_str, *alarm_str, *time_str;
|
||||
icaltimezone *current_zone;
|
||||
ECalComponentOrganizer organiser;
|
||||
char *body;
|
||||
+ NotifyNotification *n;
|
||||
|
||||
d(printf("%s:%d (popup_notification)\n",__FILE__, __LINE__));
|
||||
|
||||
@@ -1601,9 +1602,6 @@
|
||||
end_str = timet_to_str_with_zone (qa->instance->occur_end, current_zone);
|
||||
time_str = calculate_time (qa->instance->occur_start, qa->instance->occur_end);
|
||||
|
||||
- str = g_strdup_printf ("%s %s",
|
||||
- start_str, time_str);
|
||||
-
|
||||
if (organiser.cn) {
|
||||
if (location)
|
||||
body = g_strdup_printf ("<b>%s</b>\n%s %s\n%s %s", organiser.cn, _("Location:"), location, start_str, time_str);
|
||||
@@ -1617,16 +1615,19 @@
|
||||
body = g_strdup_printf ("%s %s", start_str, time_str);
|
||||
}
|
||||
|
||||
- NotifyNotification *n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
|
||||
- if (!notify_notification_show(n, NULL))
|
||||
+ n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
|
||||
+
|
||||
+ /* Notifications don't timeout: require explicit user action: */
|
||||
+ notify_notification_set_timeout (n, NOTIFY_TIMEOUT_NEVER);
|
||||
+
|
||||
+ if (!notify_notification_show_and_forget (n, NULL))
|
||||
g_warning ("Could not send notification to daemon\n");
|
||||
|
||||
- /* create the private structure */
|
||||
+ g_free (body);
|
||||
g_free (start_str);
|
||||
g_free (end_str);
|
||||
g_free (alarm_str);
|
||||
g_free (time_str);
|
||||
- g_free (str);
|
||||
|
||||
|
||||
}
|
@ -2,7 +2,7 @@
|
||||
%define soup_version 2.2.2
|
||||
%define eds_version 1.5.92
|
||||
%define use_mozilla_nss 1
|
||||
%define evo_major 2.6
|
||||
%define evo_major 2.8
|
||||
%define libbonoboui_version 2.4.2
|
||||
%define orbit2_version 2.9.8
|
||||
%define gnome_icon_theme_version 1.3.6
|
||||
@ -38,8 +38,8 @@
|
||||
%define evo_plugin_dir %{_libdir}/evolution/%{evo_major}/plugins
|
||||
|
||||
Name: evolution
|
||||
Version: 2.6.1
|
||||
Release: 3
|
||||
Version: 2.7.1
|
||||
Release: 1
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
URL: http://www.ximian.com/
|
||||
@ -94,11 +94,11 @@ Patch110: evolution-2.4.1-hide-switcher-buttons-by-default.patch
|
||||
Patch802: evolution-2.5.4-fix-conduit-dir.patch
|
||||
|
||||
# Remove GNOME_COMPILE_WARNINGS from configure.in (since gnome-common might not be available when we rerun the autotools):
|
||||
Patch803: evolution-2.5.2-no-gnome-common.patch
|
||||
Patch803: evolution-2.7.1-no-gnome-common.patch
|
||||
|
||||
Patch804: evolution-2.4.1-fix-missing-declarations.patch
|
||||
Patch805: evolution-2.5.4-fix-missing-declarations.patch
|
||||
Patch806: evolution-2.5.5.1-notification-cleanups.patch
|
||||
Patch806: evolution-2.7.1-notification-cleanups.patch
|
||||
Patch808: evolution-2.5.5.1-fix-missing-declarations-2.5.5.1.patch
|
||||
Patch809: evolution-2.6.0-prototypes.patch
|
||||
|
||||
@ -367,10 +367,10 @@ ln -sf ../desktop-menu-patches/redhat-evolution-contacts.desktop $RPM_BUILD_ROOT
|
||||
ln -sf ../desktop-menu-patches/redhat-evolution-tasks.desktop $RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
|
||||
# remove upstream desktop file; use the symlinks from above (#103826)
|
||||
rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/evolution.desktop
|
||||
rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/evolution-%{evo_major}.desktop
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/mime-info/evolution.keys
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/mime-info/evolution.mime
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/mime-info/evolution-%{evo_major}.keys
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/mime-info/evolution-%{evo_major}.mime
|
||||
|
||||
# evolution link
|
||||
ln -sf ./evolution-%{evo_major} $RPM_BUILD_ROOT/%{_bindir}/evolution
|
||||
@ -635,6 +635,16 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/evolution/%{evo_major}/libmenus.so
|
||||
|
||||
%changelog
|
||||
* Fri May 12 2006 Matthew Barnes <mbarnes@redhat.com> - 2.7.1-1
|
||||
- Update to 2.7.1
|
||||
- Bump evo_major from 2.6 to 2.8
|
||||
- Upstream evolution.desktop renamed evolution-%{evo_major}.desktop.
|
||||
- Upstream evolution.keys renamed evolution-%{evo_major}.keys.
|
||||
- Upstream evolution.mime renamed evolution-%{evo_major}.mime.
|
||||
- Update line numbers in evolution-2.5.2-no-gnome-common.patch and
|
||||
evolution-2.5.5.1-notification-cleanups.patch and rename them to
|
||||
version 2.7.1.
|
||||
|
||||
* Wed May 3 2006 Matthew Barnes <mbarnes@redhat.com> - 2.6.1-3
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user