59a721b515
- Bump evo_major from 2.6 to 2.8 - Upstream evolution.desktop renamed evolution-%{evo_major}.desktop. - Upstream evolution.keys renamed evolution-%{evo_major}.keys. - Upstream evolution.mime renamed evolution-%{evo_major}.mime. - Update line numbers in evolution-2.5.2-no-gnome-common.patch and evolution-2.5.5.1-notification-cleanups.patch and rename them to version 2.7.1.
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
--- evolution-2.7.1/configure.in.no-gnome-common 2006-04-24 07:17:07.000000000 -0400
|
|
+++ evolution-2.7.1/configure.in 2006-05-12 14:46:29.000000000 -0400
|
|
@@ -747,16 +747,24 @@
|
|
check_manually="no"
|
|
fi
|
|
|
|
- if test "x${check_manually}" = "xno" && `$PKG_CONFIG --exists mozilla-nss`; then
|
|
- PKG_CHECK_MODULES(NSS, mozilla-nss, have_nss="yes")
|
|
+ if test "x${check_manually}" = "xno"; then
|
|
+ if `$PKG_CONFIG --exists mozilla-nss`; then
|
|
+ PKG_CHECK_MODULES(NSS, mozilla-nss, have_nss="yes")
|
|
+ mozilla_nspr="mozilla-nspr"
|
|
+ mozilla_nss="mozilla-nss"
|
|
+ else
|
|
+ if `$PKG_CONFIG --exists nss`; then
|
|
+ PKG_CHECK_MODULES(NSS, nss, have_nss="yes")
|
|
+ mozilla_nspr="nspr"
|
|
+ mozilla_nss="nss"
|
|
+ fi
|
|
+ fi
|
|
if test "x${have_nss}" = "xyes"; then
|
|
msg_ssl="yes (Mozilla NSS)"
|
|
if test "x$enable_smime" = "xyes"; then
|
|
AC_DEFINE(ENABLE_SMIME,1,[Define if SMIME should be enabled])
|
|
msg_smime="yes (Mozilla NSS)"
|
|
fi
|
|
- mozilla_nspr="nspr"
|
|
- mozilla_nss="mozilla-nss"
|
|
AC_DEFINE(HAVE_NSS,1,[Define if you have NSS])
|
|
AC_DEFINE(HAVE_SSL,1,[Define if you have a supported SSL library])
|
|
AC_DEFINE_UNQUOTED(MOZILLA_NSS_LIB_DIR,"`$PKG_CONFIG --variable=libdir mozilla-nss`",[Define to the full path of mozilla nss library])
|
|
@@ -1072,9 +1080,6 @@
|
|
dnl *************************
|
|
dnl CFLAGS and LIBS and stuff
|
|
dnl *************************
|
|
-
|
|
-GNOME_COMPILE_WARNINGS(yes)
|
|
-CFLAGS="$CFLAGS $WARN_CFLAGS"
|
|
case $CFLAGS in
|
|
*-Wall*)
|
|
# Turn off the annoying "comparison between signed and unsigned"
|