- Add patch to allow Anjal to build.
This commit is contained in:
parent
ef796d85eb
commit
3de59719ac
@ -1,12 +0,0 @@
|
||||
diff -up evolution-2.26.1/widgets/misc/e-attachment-bar.c.attachment-bar-crasher evolution-2.26.1/widgets/misc/e-attachment-bar.c
|
||||
--- evolution-2.26.1/widgets/misc/e-attachment-bar.c.attachment-bar-crasher 2009-04-14 12:49:45.000000000 -0400
|
||||
+++ evolution-2.26.1/widgets/misc/e-attachment-bar.c 2009-04-14 12:50:54.000000000 -0400
|
||||
@@ -450,6 +450,8 @@ update (EAttachmentBar *bar)
|
||||
if (desc)
|
||||
desc = g_strdup (desc);
|
||||
}
|
||||
+ } else {
|
||||
+ desc = g_strdup (desc);
|
||||
}
|
||||
|
||||
if (!desc)
|
37
evolution-2.27.3-anjal-support.patch
Normal file
37
evolution-2.27.3-anjal-support.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff -up evolution-2.27.3/mail/e-mail-attachment-bar.h.anjal-support evolution-2.27.3/mail/e-mail-attachment-bar.h
|
||||
--- evolution-2.27.3/mail/e-mail-attachment-bar.h.anjal-support 2009-06-12 10:54:40.000000000 -0400
|
||||
+++ evolution-2.27.3/mail/e-mail-attachment-bar.h 2009-06-23 10:37:33.000000000 -0400
|
||||
@@ -23,7 +23,7 @@
|
||||
#define E_MAIL_ATTACHMENT_BAR_H
|
||||
|
||||
#include <gtk/gtk.h>
|
||||
-#include <widgets/misc/e-attachment-view.h>
|
||||
+#include <misc/e-attachment-view.h>
|
||||
|
||||
/* Standard GObject macros */
|
||||
#define E_TYPE_MAIL_ATTACHMENT_BAR \
|
||||
diff -up evolution-2.27.3/mail/Makefile.am.anjal-support evolution-2.27.3/mail/Makefile.am
|
||||
--- evolution-2.27.3/mail/Makefile.am.anjal-support 2009-06-12 10:54:40.000000000 -0400
|
||||
+++ evolution-2.27.3/mail/Makefile.am 2009-06-23 10:37:33.000000000 -0400
|
||||
@@ -105,10 +105,6 @@ mailinclude_HEADERS = \
|
||||
libevolution_mail_la_SOURCES = \
|
||||
$(MAIL_IDL_GENERATED) \
|
||||
$(mailinclude_HEADERS) \
|
||||
- e-attachment-handler-mail.c \
|
||||
- e-attachment-handler-mail.h \
|
||||
- e-mail-attachment-bar.c \
|
||||
- e-mail-search-bar.c \
|
||||
e-searching-tokenizer.c \
|
||||
em-account-prefs.c \
|
||||
em-account-prefs.h \
|
||||
@@ -174,6 +170,10 @@ libevolution_mail_la_DEPENDENCIES = \
|
||||
libevolution-mail-shared.la
|
||||
|
||||
libevolution_mail_shared_la_SOURCES = \
|
||||
+ e-attachment-handler-mail.c \
|
||||
+ e-attachment-handler-mail.h \
|
||||
+ e-mail-attachment-bar.c \
|
||||
+ e-mail-search-bar.c \
|
||||
em-account-editor.c \
|
||||
em-account-editor.h \
|
||||
em-event.c \
|
@ -42,7 +42,7 @@
|
||||
|
||||
Name: evolution
|
||||
Version: 2.27.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Group: Applications/Productivity
|
||||
Summary: Mail and calendar client for GNOME
|
||||
License: GPLv2+ and GFDL
|
||||
@ -65,6 +65,9 @@ Patch11: evolution-2.5.4-fix-conduit-dir.patch
|
||||
# RH bug #176400
|
||||
Patch12: evolution-2.9.1-im-context-reset.patch
|
||||
|
||||
# Support for building Anjal.
|
||||
Patch13: evolution-2.27.3-anjal-support.patch
|
||||
|
||||
## Dependencies ###
|
||||
|
||||
Requires(post): GConf2
|
||||
@ -222,6 +225,7 @@ This package contains supplemental utilities for %{name} that require Perl.
|
||||
%patch10 -p1 -b .ldaphack
|
||||
%patch11 -p1 -b .fix-conduit-dir
|
||||
%patch12 -p1 -b .im-context-reset
|
||||
%patch13 -p1 -b .anjal-support
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -669,6 +673,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
|
||||
|
||||
%changelog
|
||||
* Tue Jun 23 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.3-2.fc12
|
||||
- Add patch to allow Anjal to build.
|
||||
|
||||
* Mon Jun 15 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.3-1.fc12
|
||||
- Update to 2.27.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user