- Update to 2.27.3
This commit is contained in:
parent
447a39d072
commit
ef796d85eb
@ -1 +1 @@
|
||||
evolution-2.27.2.tar.bz2
|
||||
evolution-2.27.3.tar.bz2
|
||||
|
@ -1,85 +0,0 @@
|
||||
diff -up evolution-2.27.2/mail/Makefile.am.fix-shared-mail evolution-2.27.2/mail/Makefile.am
|
||||
--- evolution-2.27.2/mail/Makefile.am.fix-shared-mail 2009-05-24 13:35:00.000000000 -0400
|
||||
+++ evolution-2.27.2/mail/Makefile.am 2009-05-29 14:34:24.000000000 -0400
|
||||
@@ -31,9 +31,8 @@ INCLUDES = \
|
||||
-DPREFIX=\""$(prefix)"\" \
|
||||
-DG_LOG_DOMAIN=\"evolution-mail\"
|
||||
|
||||
-component_LTLIBRARIES = libevolution-mail-shared.la \
|
||||
- libevolution-mail.la
|
||||
-
|
||||
+privsolib_LTLIBRARIES = libevolution-mail-shared.la
|
||||
+component_LTLIBRARIES = libevolution-mail.la
|
||||
|
||||
# Mail.idl
|
||||
MAIL_IDL = Evolution-Mail.idl
|
||||
@@ -148,7 +147,6 @@ SMIME_LIBS = \
|
||||
$(top_builddir)/smime/gui/libevolution-smime.la
|
||||
endif
|
||||
|
||||
-
|
||||
libevolution_mail_la_LIBADD = \
|
||||
$(top_builddir)/mail/libevolution-mail-shared.la \
|
||||
$(top_builddir)/e-util/libeutil.la \
|
||||
@@ -172,11 +170,11 @@ libevolution_mail_la_LIBADD = \
|
||||
libevolution_mail_la_LDFLAGS = \
|
||||
-avoid-version -module $(NO_UNDEFINED)
|
||||
|
||||
-libevolution_mail_la_DEPENDENCIES = em-filter-i18n.h
|
||||
-
|
||||
-# .server files
|
||||
+libevolution_mail_la_DEPENDENCIES = \
|
||||
+ em-filter-i18n.h \
|
||||
+ libevolution-mail-shared.la
|
||||
|
||||
-libevolution_mail_shared_la_SOURCES = \
|
||||
+libevolution_mail_shared_la_SOURCES = \
|
||||
em-account-editor.c \
|
||||
em-account-editor.h \
|
||||
em-event.c \
|
||||
@@ -238,12 +236,7 @@ libevolution_mail_shared_la_SOURCES =
|
||||
message-tag-followup.c \
|
||||
message-tag-followup.h
|
||||
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-libevolution_mail_shared_la_LIBADD = \
|
||||
+libevolution_mail_shared_la_LIBADD = \
|
||||
$(top_builddir)/e-util/libeutil.la \
|
||||
$(top_builddir)/widgets/misc/libemiscwidgets.la \
|
||||
$(top_builddir)/composer/libcomposer.la \
|
||||
@@ -252,10 +245,29 @@ libevolution_mail_shared_la_LIBADD =
|
||||
$(SMIME_LIBS) \
|
||||
$(THREADS_LIBS)
|
||||
|
||||
-libevolution_mail_shared_la_LDFLAGS = \
|
||||
- -avoid-version -module $(NO_UNDEFINED)
|
||||
+libevolution_mail_shared_la_LDFLAGS = $(NO_UNDEFINED)
|
||||
|
||||
+# --- BIG NASTY AUTOMAKE HACK ---
|
||||
+#
|
||||
+# Automake apparently sorts Makefile.am rules alphabetically. And
|
||||
+# since component_LTLIBRARIES < privsolib_LTLIBRARIES, it tries to
|
||||
+# install libevolution-mail.la before libevolution-mail-shared.la,
|
||||
+# which fails when libtool tries to relink libevolution-mail.la
|
||||
+# against the not-yet-installed libevolution-mail-shared.la.
|
||||
+install-data-am: \
|
||||
+ install-privsolibLTLIBRARIES \
|
||||
+ install-componentLTLIBRARIES \
|
||||
+ install-data-local \
|
||||
+ install-errorDATA \
|
||||
+ install-etspecDATA \
|
||||
+ install-filterDATA \
|
||||
+ install-gladeDATA \
|
||||
+ install-idlDATA \
|
||||
+ install-mailincludeHEADERS \
|
||||
+ install-schemaDATA \
|
||||
+ install-serverDATA
|
||||
|
||||
+# .server files
|
||||
|
||||
server_in_files = GNOME_Evolution_Mail.server.in.in
|
||||
server_DATA = $(server_in_files:.server.in.in=.server)
|
@ -41,8 +41,8 @@
|
||||
### Abstract ###
|
||||
|
||||
Name: evolution
|
||||
Version: 2.27.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.27.3
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/Productivity
|
||||
Summary: Mail and calendar client for GNOME
|
||||
License: GPLv2+ and GFDL
|
||||
@ -65,9 +65,6 @@ Patch11: evolution-2.5.4-fix-conduit-dir.patch
|
||||
# RH bug #176400
|
||||
Patch12: evolution-2.9.1-im-context-reset.patch
|
||||
|
||||
# Fix broken libevolution-mail-shared.
|
||||
Patch13: evolution-2.27.2-fix-shared-mail.patch
|
||||
|
||||
## Dependencies ###
|
||||
|
||||
Requires(post): GConf2
|
||||
@ -225,7 +222,6 @@ This package contains supplemental utilities for %{name} that require Perl.
|
||||
%patch10 -p1 -b .ldaphack
|
||||
%patch11 -p1 -b .fix-conduit-dir
|
||||
%patch12 -p1 -b .im-context-reset
|
||||
%patch13 -p1 -b .fix-shared-mail
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -673,6 +669,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
|
||||
|
||||
%changelog
|
||||
* Mon Jun 15 2009 Matthew Barnes <mbarnes@redhat.com> - 2.27.3-1.fc12
|
||||
- Update to 2.27.3
|
||||
|
||||
* Sun Jun 14 2009 Matthias Clasen <mclasen@redhat.com> - 2.27.2-2.fc12
|
||||
- Don't make -perl own directories that are already owned by the base package
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user